setup

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Thu May 03, 2018 12:00 am

Not sure if this is what you are asking but here it is

gcook12@gcook12-Aspire-5253:~$ mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version : v29.1-15-g280138b
MythTV Branch : fixes/29
Network Protocol : 91
Library API : 29.20180316-1
QT Version : 5.5.1
Options compiled in:
linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_vbox using_ceton using_hdpvr using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libfftw3 using_libxml2 using_lirc using_mheg using_opengl using_opengl_video using_opengl_themepainter using_qtwebkit using_qtscript using_qtdbus using_taglib using_v4l2 using_x11 using_xrandr using_xv using_profiletype using_systemd_notify using_systemd_journal using_bindings_perl using_bindings_python using_bindings_php using_freetype2 using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_mheg using_libass using_libxml2 using_libmp3lame
gcook12@gcook12-Aspire-5253:~$

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Thu May 03, 2018 12:03 am

Here is the other idea I had on what you were asking for

gcook12@gcook12-Aspire-5253:~$ dir /tmp/
config-err-bHKlEi
dropbox-antifreeze-FfqswQ
gnome-software-RJWJIZ
systemd-private-30e05fd1879b4e4ea0a910a39e5ba248-colord.service-KyvDcn
systemd-private-30e05fd1879b4e4ea0a910a39e5ba248-fwupd.service-3MwBBS
systemd-private-30e05fd1879b4e4ea0a910a39e5ba248-rtkit-daemon.service-DyT3gP
unity_support_test.0
gcook12@gcook12-Aspire-5253:~$

User avatar
bill6502
Developer
Posts: 1152
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: setup

Post by bill6502 » Thu May 03, 2018 12:17 am

OK, so clearly there's no log file there.

Again, what was the actual command line you typed, and
what was the output on the terminal window?

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Fri May 04, 2018 1:18 am

I think I finally got the log setup to download but it is 6.1 meg Not sure how to replace it. I used the steps you recommended and they did not work

User avatar
bill6502
Developer
Posts: 1152
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: setup

Post by bill6502 » Fri May 04, 2018 2:16 am

Hi,

6.1MB is way too big.

Remember we can't see what you're doing. And have asked, three times now, to see the
command you're typing so that a good log is created. I just make one with mythtv-setup
and it was about 8,000 bytes long. Please do this from back on May 1st:

Code: Select all

mythtv-setup.real --logpath /tmp 
If it fails, then paste the command you used and the output that follows. That's
the only way we can tell what's going on. If it works, then lets see the log.

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Sat May 05, 2018 10:24 pm

Sorry that I am having trouble understanding what you are asking. Here is what I am confused on. You are asking me to provide the actual command line I typed. if you are referring to when I start Mythtv, I do not type anything, the program just starts when I turn the computer on and then after what looks like a loading period, it says that it cannot locate the mythtv backend.

If you are asking what is the exact command line that I am tying meaning from what you instructed me to type in, the last item that you asked me to type in is control-d. I assume by that you mean the control character and d at the same time and when I do that, the terminal disappears so there is nothing that I can recover to send to you.

I did a printout of the log file (cat) and copy and pasted all of the printout from today so hopefully that will be what you need and I have pasted it below. I am sorry that this is taking so long. I realize you are doing this on your own time and I appreciate it. Let me know if you see where I am confused on your instructions and I will try to do better next time so you wont have to keep asking

Code: Select all

May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: C thread_unknown mythcommandlineparser.cpp:2619 (ConfigureLogging) mythbackend version: fixes/29 [v29.1-15-g280138b] www.mythtv.org
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: C thread_unknown mythcommandlineparser.cpp:2621 (ConfigureLogging) Qt version: compile: 5.5.1, runtime: 5.5.1
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: N thread_unknown mythcommandlineparser.cpp:2623 (ConfigureLogging) Enabled verbose msgs:  general
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: N thread_unknown logging.cpp:927 (logStart) Setting Log Level to LOG_INFO
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Interrupt handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Terminated handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Segmentation fault handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Aborted handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Bus error handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Floating point exception handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Illegal instruction handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Real-time signal 0 handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Hangup handler
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: N thread_unknown mythdirs.cpp:195 (InitializeMythDirs) Using runtime prefix = /usr
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: N thread_unknown mythdirs.cpp:197 (InitializeMythDirs) Using configuration directory = /home/mythtv/.mythtv
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I CoreContext mythcorecontext.cpp:271 (Init) Assumed character encoding: en_US.UTF-8
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I Logger logging.cpp:313 (run) Added logging to the console
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: N CoreContext mythcontext.cpp:599 (LoadDatabaseSettings) Empty LocalHostName.
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I CoreContext mythcontext.cpp:607 (LoadDatabaseSettings) Using localhost value of gcook12-Aspire-5253
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I CoreContext mythcontext.cpp:852 (TestDBconnection) Start up testing connections. DB localhost, BE , attempt 0, status dbAwake
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I LogForward loggingserver.cpp:302 (SyslogLogger) Added syslogging
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: N CoreContext mythcorecontext.cpp:1768 (InitLocale) Setting QT default locale to en_US
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I CoreContext mythcorecontext.cpp:1801 (SaveLocaleDefaults) Current locale en_US
May  5 16:29:28 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: N CoreContext mythlocale.cpp:123 (LoadDefaultsFromXML) Reading locale defaults from /usr/share/mythtv//locales/en_us.xml
May  5 16:29:29 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I CoreContext mythtranslation.cpp:73 (load) Loading en_us translation for module mythfrontend
May  5 16:29:29 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I CoreContext schemawizard.cpp:120 (Compare) Current MythTV Schema Version (DBSchemaVer): 1348
May  5 16:29:29 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: I CoreContext mythtranslation.cpp:73 (load) Loading en_us translation for module mythfrontend
May  5 16:29:29 gcook12-Aspire-5253 mythbackend: mythbackend[3056]: E MythSocketThread(-1) mythsocket.cpp:698 (ConnectToHostReal) MythSocket(1191600:-1): Failed to connect to (127.0.0.1:6543) Connection refused
gcook12@gcook12-Aspire-5253:~$
EDIT: cut down to a single run and put in a code block

User avatar
bill6502
Developer
Posts: 1152
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: setup

Post by bill6502 » Sat May 05, 2018 11:08 pm

That's a good log, now we need more info (it's the last line above
that's the problem.)

The output of these commands:

Code: Select all

ip address
cat /home/mythtv/.mythtv/config.xml
mysql -u mythtv -p -e "SELECT * FROM settings WHERE value IN ('MasterServerIP', 'BackendServerIP')" mythconverg
You'll be prompted for a password in the last command
and it will (should) be found in the previous command's
output. Just look between <Password>........</Password>

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Sun May 06, 2018 1:29 am

Here is what happened

Code: Select all

gcook12@gcook12-Aspire-5253:~$ ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp6s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 1c:75:08:ba:be:c6 brd ff:ff:ff:ff:ff:ff
3: wlp7s0b1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 88:9f:fa:1c:fe:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.5/24 brd 192.168.1.255 scope global dynamic wlp7s0b1
       valid_lft 84491sec preferred_lft 84491sec
    inet6 fe80::4198:8e1a:992a:31b6/64 scope link 
       valid_lft forever preferred_lft forever

User avatar
bill6502
Developer
Posts: 1152
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: setup

Post by bill6502 » Sun May 06, 2018 1:42 am

Try the 2nd two commands [corrected] again. Also, even though
it appears that there a space in /home/mythtv/.mythtv/config.xml,
there isn't.

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Sun May 06, 2018 1:52 am

Here is what happened this time

gcook12@gcook12-Aspire-5253:~$ cat /home/mythtv/.mythtv/config.xml
<Configuration>
<Database>
<PingHost>1</PingHost>
<Host>localhost</Host>
<UserName>mythtv</UserName>
<Password>NCi0hdAh</Password>
<DatabaseName>mythconverg</DatabaseName>
<Port>3306</Port>
</Database>
<WakeOnLAN>
<Enabled>0</Enabled>
<SQLReconnectWaitTime>0</SQLReconnectWaitTime>
<SQLConnectRetry>5</SQLConnectRetry>
<Command>echo 'WOLsqlServerCommand not set'</Command>
</WakeOnLAN>
</Configuration>

gcook12@gcook12-Aspire-5253:~$ mysql -u mythtv -p -e "SELECT * FROM settings WHERE value IN ('MasterServerIP, 'BackendServerIP')" mythconverg
Enter password:
ERROR 1045 (28000): Access denied for user 'mythtv'@'localhost' (using password: YES)

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Sun May 06, 2018 2:18 am

Noticed that I had used o instead of 0 in the password. Made that correction and this happened

gcook12@gcook12-Aspire-5253:~$ mysql -u mythtv -p -e "SELECT * FROM settings WHERE value IN ('MasterServerIP, 'BackendServerIP')" mythconverg
Enter password:
ERROR 1045 (28000): Access denied for user 'mythtv'@'localhost' (using password: YES)
gcook12@gcook12-Aspire-5253:~$ mysql -u mythtv -p -e "SELECT * FROM settings WHERE value IN ('MasterServerIP, 'BackendServerIP')" mythconverg
Enter password:
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'BackendServerIP')' at line 1
gcook12@gcook12-Aspire-5253:~$

User avatar
bill6502
Developer
Posts: 1152
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: setup

Post by bill6502 » Sun May 06, 2018 2:31 am

You're missing a ' after MasterServerIP. Hopefully you know
that the up arrow to look at previous commands and you can
edit them.

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Sun May 06, 2018 2:46 am

I think it worked that time. Here is what printed out. What next?

gcook12@gcook12-Aspire-5253:~$ mysql -u mythtv -p -e "SELECT * FROM settings WHERE value IN ('MasterServerIP', 'BackendServerIP')" mythconverg
Enter password:
+-----------------+-----------+----------+
| value | data | hostname |
+-----------------+-----------+----------+
| BackendServerIP | 127.0.0.1 | gcook12 |
| MasterServerIP | 127.0.0.1 | NULL |
+-----------------+-----------+----------+

User avatar
bill6502
Developer
Posts: 1152
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: setup

Post by bill6502 » Sun May 06, 2018 3:26 am

The log says: Using localhost value of gcook12-Aspire-5253.
But the above only has a BackendServerIP for gcook12.

That suggests that mythtv-setup hasn't been completed.

You mentioned earlier about having setup problems, so that's
where you should start.

Make sure your config.xml files are the same for your own user
and for user mythtv. I seem to recall working this issue with you
before.

Simple test (command): diff {~,~mythtv}/.mythtv/config.xml
Expect no differences.

gcook12
Junior
Posts: 89
Joined: Sun Nov 06, 2016 1:35 am
United States of America

Re: setup

Post by gcook12 » Sun May 06, 2018 1:32 pm

I do not recall having this problem before but I may have. Mythtv has worked flawlessly for two years but I did have some startup issues. I tried the test command you suggested and this is the response I got. I do not understand what it is saying.

gcook12@gcook12-Aspire-5253:~$ diff {~,~mythtv}/.mythtv/config.xml
2d1
< <LocalHostName>gcook12</LocalHostName>
12c11
< <Enabled>1</Enabled>
---
> <Enabled>0</Enabled>
17,21d15
< <UPnP>
< <UDN>
< <MediaRenderer>d8b3ea1c-17be-4362-bfce-7f9e7df6b82d</MediaRenderer>
< </UDN>
< </UPnP>
22a17
>

Post Reply