Seek function (Jump to)

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
wesnewell
Senior
Posts: 550
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Seek function (Jump to)

Post by wesnewell » Sun Jun 29, 2014 8:01 pm

Seek seems to go anywhere it wants to. I hit *33 right arrow and i expect it to jump 33 minutes ahead. Instead it may go anywhere, forward, backward, 1 miute ahead, an hour ahead, just random places. I use this a lot in sports recordings and now it's totally worthless. Same thing on all FE machines. Ran optimize script ok. Same problem with new recordings. Anyone got a clue?

Mythbuntu 14.04, FE & BE 0.27.1
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

wesnewell
Senior
Posts: 550
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Seek function (Jump to)

Post by wesnewell » Mon Jun 30, 2014 5:11 pm

Well, it's not random, just weird. It always goes to the same point in the recording when you enter the same value. Happens on all recordings, regardless if they've been flagged or not. Problem is, it jumps to the point in the recording that amount from the end. IOW's, if the recording is 3 hours long, entering 30 will go to the point 30 minutes from the end of the recording. At least I can make it usable now, but it just doesn't seem right. Getting these errors.
Jun 29 01:56:00 mythfe0 mythcommflag: mythcommflag[17624]: E Decoder avformatdecoder.cpp:4891 (GetFrame) decoding error#012#011#011#011eno: Unknown error 541478725 (541478725)
Jun 29 01:56:04 mythfe0 mythcommflag: mythcommflag[17624]: N CoreContext main.cpp:948 (FlagCommercials) Finished, 13 break(s) found.
Jun 29 01:56:04 mythfe0 mythcommflag: mythcommflag[17624]: I CoreContext mythcontext.cpp:1194 (~MythContext) Waiting for threads to exit.
Jun 29 01:56:06 mythfe0 mythcommflag: mythcommflag[17604]: E Decoder avformatdecoder.cpp:4891 (GetFrame) decoding error#012#011#011#011eno: Unknown error 541478725 (541478725)
Jun 29 01:56:07 mythfe0 mythcommflag: mythcommflag[17663]: E Decoder avformatdecoder.cpp:4891 (GetFrame) decoding error#012#011#011#011eno: Unknown error 541478725 (541478725)
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

wesnewell
Senior
Posts: 550
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Seek function (Jump to)

Post by wesnewell » Tue Jul 01, 2014 5:49 am

Well, I figured it out tonight. It just doesn't work like it used to in 0.23, where it jumped forward the amunt of minutes entered automatically after the entry. I'm sure most people know that it now jumps to a specific time in the recording. Pressing the right arrow subtracts the entered time from the end and jumps to that point. Pressing the left arrow goes to the time from the beginning. Still working on a lot of minor stuff, but won't bug you with it yet.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

Post Reply