No DVB option in Capture Cards, FreeBSD build issue.

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
myso
Newcomer
Posts: 7
Joined: Mon Dec 18, 2017 7:01 pm
Czech Republic

No DVB option in Capture Cards, FreeBSD build issue.

Post by myso » Mon Dec 18, 2017 8:08 pm

Dear community,

as I was kind of forced to upgrade my working 0.27 mythtv version (running on FreeBSD 11), I performed an upgrade to the latest ported version 0.28.7.

As I'm only using it with 2 DVB cars for watching a few available channels, I decided to do a clean install with a clean DB.

Unfortunately when trying to set thing up I don't see any DVB option in the Capture Cards section of mythtv-setup.

Using webcamd everything seems to be OK, as it was before upgrading:

Code: Select all

# usbconfig list
ugen0.1: <0x8086 XHCI root HUB> at usbus0, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE (0mA)
ugen0.2: <ASRock ASM107x> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (100mA)
ugen0.3: <vendor 0x05e3 USB2.0 Hub> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (100mA)
ugen0.4: <TechnoTrend TT-USB2.0> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (10mA)
ugen0.5: <Afatech DVB-T 2> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)
ugen0.6: <ASRock ASM107x> at usbus0, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE (2mA)

Code: Select all

# ps aux | grep webcamd
root    359   0.0  0.0  41656   6712  -  Is   19:13     0:16.52 /usr/local/sbin/webcamd -i 0 -d ugen0.4 -B -U webcamd -G webcamd
root    370   0.0  0.0  38836   6356  -  Is   19:13     0:06.77 /usr/local/sbin/webcamd -i 0 -d ugen0.5 -B -U webcamd -G webcamd
root  39329   0.0  0.0  14836   2452  0  S+   20:57     0:00.00 grep webcamd
Any ideas how to get the 0.28.7 running again?

Many thanks

Mike

User avatar
pgbennett
Developer
Posts: 319
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: No DVB option in Capture Cards

Post by pgbennett » Tue Dec 19, 2017 3:51 am

Card type is a drop down list with the first option as "DVB-T/S/C. ATSC or ISDB-T tuner card". If you don't have that in the list, your package may have been compiled without DVB support. Do you have a drop down list with other things but not that?

myso
Newcomer
Posts: 7
Joined: Mon Dec 18, 2017 7:01 pm
Czech Republic

Re: No DVB option in Capture Cards

Post by myso » Tue Dec 19, 2017 6:53 pm

yes, exactly, the dropdownlist doesn't have any DVB option. I was trying to attach a screenshot but it seems like I'm not allowed.

User avatar
bill6502
Developer
Posts: 1358
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: No DVB option in Capture Cards

Post by bill6502 » Tue Dec 19, 2017 8:26 pm

Try: mythtv-setup --version (or, for easier reading: mythtv-setup --version|sed "s/\s/\n/g"|grep using_dvb)

myso
Newcomer
Posts: 7
Joined: Mon Dec 18, 2017 7:01 pm
Czech Republic

Re: No DVB option in Capture Cards

Post by myso » Tue Dec 19, 2017 8:42 pm

Code: Select all

# mythtv-setup --version
Please attach all output as a file in bug reports.
MythTV Version : ad97d24
MythTV Branch : tag: v0.27.5
Network Protocol : 77
Library API : 0.27.20141016-1
QT Version : 4.8.7
Options compiled in:
 freebsd profile using_jack using_oss using_backend using_bindings_perl using_bindings_python using_bindings_php using_frontend using_hdhomerun using_ceton using_hdpvr using_ivtv using_libcrypto using_libfftw3 using_libxml2 using_libudf using_lirc using_mheg using_opengl using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_taglib using_v4l2 using_v4l1 using_x11 using_xrandr using_xv using_profiletype using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_mheg using_libass using_libxml2 using_libudf
I did build it from the FreeBSD ports tree with default config options. If I run "make config" on the port these are the possible options:

Code: Select all

[x] BINDINGS  Perl and Python bindings                                   
[ ] LIRC      Infrared remote control support                            
[x] MYSQL     MySQL database support                                     
[x] OPENGL    2D/3D rendering support via OpenGL                      
[x] VDPAU     VDPAU (GPU video acceleration) support
I am a bit confused by the version I see in mythtv-setup output. This is the package that has been built from the port:

Code: Select all

# pkg info |grep mythtv
mythtv-0.28.7_2                MythTV is a homebrew PVR project

User avatar
bill6502
Developer
Posts: 1358
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: No DVB option in Capture Cards

Post by bill6502 » Tue Dec 19, 2017 10:15 pm

That suggests that you've got at least two versions of MythTV installed.
Nothing wrong with that, just need to be careful with PATHs and libraries
etc. Typing: /usr/local/bin/mythtv-setup... may help. Seeing what's in your
init program's setup is important, e.g. systemctl cat mythtv-backend.

Can't speak to FreeBSD, but running ./configure in the MythTV source is
always my first stop.

Take a peek at the buildbot for FreeBSD here:
https://code.mythtv.org/buildbot/builde ... logs/stdio

Looks like there's something special and our bot isn't building with DVB:

DVB support no [/usr/src/linux-headers-10.3-RELEASE-p24/include/uapi]

myso
Newcomer
Posts: 7
Joined: Mon Dec 18, 2017 7:01 pm
Czech Republic

Re: No DVB option in Capture Cards

Post by myso » Wed Dec 20, 2017 11:09 am

Hi Bill,

I'm 99% sure I only have one version installed, because I always used the FreeBSD ports distribution system and portmaster to keep my software updated.

Even when running the mythtv-setup --version command with absolute path I get the same versioning.

Here the startup script:

Code: Select all

# cat /usr/local/etc/rc.d/mythbackend
#!/bin/sh

# $FreeBSD: head/multimedia/mythtv/files/mythbackend.in 340872 2014-01-24 00:14:07Z mat $

# PROVIDE: mythbackend
# REQUIRE: DAEMON mysql
# KEYWORD: shutdown

# Define mythbackend_enable in /etc/rc.conf[.local] to enable mythbackend
#
# mythbackend_enable (bool):  Set to "NO" by default.
#                             Set it to "YES" to enable mythbackend.
# mythbackend_logpath (str):  Custom logpath for mythbackend.
#                             (default /var/log/mythtv)
# mythbackend_flags (str):    Additional flags for mythbackend.
# mythbackend_user (str):     Username to run with.

. /etc/rc.subr

name="mythbackend"
rcvar=mythbackend_enable
command="/usr/local/bin/${name}"

start_precmd="mythbackend_prestart"

mythbackend_prestart()
{
        if [ ! -d ${mythbackend_logpath} ]; then
                /usr/bin/install -o ${mythbackend_user} -g wheel -m 755 -d ${mythbackend_logpath}
        fi
}

load_rc_config $name

: ${mythbackend_enable="NO"}
: ${mythbackend_logpath="/var/log/mythtv"}
: ${mythbackend_user="root"}

command_args="-d --logpath ${mythbackend_logpath}"
HOME=$(/usr/sbin/pw usershow -7 -n "${mythbackend_user}" | /usr/bin/cut -d: -f6)

run_rc_command "$1"
To me it looks like the FreeBSD port is somehow messed up, but I don't have enough knowledge/experience to comment on this issue.

I think it's best to address this with the FreeBSD community, am I right?

User avatar
bill6502
Developer
Posts: 1358
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: No DVB option in Capture Cards

Post by bill6502 » Wed Dec 20, 2017 7:27 pm

Hi,

I edited your Subject to include FreeBSD. We'll see if that gets any more
eyes on this issue.

It sounds like a build issue, as Peter mentioned (and you proved with the
--version output.)

myso
Newcomer
Posts: 7
Joined: Mon Dec 18, 2017 7:01 pm
Czech Republic

Re: No DVB option in Capture Cards, FreeBSD build issue.

Post by myso » Wed Dec 20, 2017 8:07 pm

Hi,

thanks for your inputs, meanwhile in the FreeBSD community I found out that this is a FreeBSD only related issue, the port is completely messed up (versioning out of synch, and some path problems).

For future referrence I'm attaching a link to the FreeBSD forum thread
https://forums.freebsd.org/threads/63777/

Thanks again for your assistance.

Kind regards

Mike

Post Reply