setup items won’t open

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
MBEeng
Newcomer
Posts: 2
Joined: Wed Aug 30, 2017 10:21 pm
United States of America

setup items won’t open

Post by MBEeng » Wed Aug 30, 2017 10:32 pm

I have mythbuntu 0.28 running on Ubuntu 14.04 LTS. Both front end and back end are on the same computer. After upgrading from 0.27 on 12.04LTS I used the front end setup to get video and audio working. But now, several months after upgrading, many of the front end setup items, for example video and audio playback, won't open. If I attempt to select them nothing happens. I have to back out of the setup with esc. And in back end setup the channel editor won't work. It displays the channels, and I can toggle between channel number or channel name order. But I can't edit any of the channels - the edit key does nothing. Clicking on the entry for a channel does nothing. And it won't do a channel scan, which will be a serious problem because most channels in our area will move to new broadcast channels in a year or so.

Any ideas as to what is causing this problem? Could it be that permissions have somehow gotten changed? Or is a path or symbolic link missing? In either case, where are the configuration files located? Where are the executables for the setup programs located?

mythbuntubox
Senior
Posts: 111
Joined: Tue Apr 28, 2015 1:17 pm
Great Britain

Re: setup items won’t open

Post by mythbuntubox » Fri Sep 01, 2017 4:11 pm

It might be worth trying a database repair to see if that makes any difference. Perhaps it contains some corrupted entries.

https://www.mythtv.org/wiki/User_Manual ... aintenance

Back it up first, just in case.

MikeB2013
Senior
Posts: 158
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: setup items won’t open

Post by MikeB2013 » Fri Sep 01, 2017 8:39 pm

Bit of a long shot but here goes:
Some mythtv themes use opengl, others need qt to access all features in setup screens.
Have a look at https://www.mythtv.org/wiki/Override_settings

The part about overriding the ThemePainter may be relevant.

Mike

User avatar
bill6502
Developer
Posts: 835
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: setup items won’t open

Post by bill6502 » Sat Sep 02, 2017 4:13 am

Consider going to frontend -> setup -> themes and see if there's a new
version waiting to be installed.

MBEeng
Newcomer
Posts: 2
Joined: Wed Aug 30, 2017 10:21 pm
United States of America

Re: setup items won’t open

Post by MBEeng » Wed Sep 27, 2017 10:53 pm

I solved this problem today. I checked my notes, and found that a few months after upgrading to 0.28 I had turned on the anti-tearing option on the AMD video driver. That caused a problem with windows in MythTV. Turning off compositing in Window Manager Tweaks fixed the window issue. I didn't run into the setup problem for weeks or months, and by then I had forgotten about the anti-tearing and compositing changes.
Turning off anti-tear did not fix the setup screen issue, but turning compositing back on solved the problem. Of course now some videos will have tearing, but I guess I'll have to live with that. Apparently compositing is necessary to access some of the setup screens.

Post Reply