0.28 Australian EIT guide not showing

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
notidefix
Newcomer
Posts: 9
Joined: Wed Jan 18, 2017 10:08 pm
Australia

0.28 Australian EIT guide not showing

Post by notidefix » Sat Jan 28, 2017 8:31 am

1st it was just one channel (approx. 1 month ago) and now it is all but 3 (out of 30+ channels).

my TV is able to show live guide data....so why has mythtv stopped showing it?

given that this is a recent event, I assume that something changed in either the EIT format or myth software....but the change has not affected my old television....

can anyone help with troubleshooting this problem?

notidefix
Newcomer
Posts: 9
Joined: Wed Jan 18, 2017 10:08 pm
Australia

Re: 0.28 Australian EIT guide not showing

Post by notidefix » Sat Jan 28, 2017 11:47 pm

further to my previous post, I have used DVBSNOOP to see what is going on with the EIT guide and found that:
1. EIT data is being transmitted on all channels
2. some channels have "Original_network_ID: 12913 (0x3271) [= >>ERROR: not (yet) defined... Report!<<]"
3. other channels that have the Original_network_ID defined also do not show the EIT guide.

can anyone point me to the mythtv processes for converting EIT data into a guide?

TheCook
Newcomer
Posts: 8
Joined: Sun Jan 29, 2017 4:38 am
Australia

Re: 0.28 Australian EIT guide not showing

Post by TheCook » Wed Feb 01, 2017 10:37 pm

I have used shepherd for years to grab all my channel data. It works quite well for all the channels I'm interested in and is very easy to install (on a linux box at least). Check out
http://svn.whuffy.com/

PhilB
Senior
Posts: 224
Joined: Sun May 11, 2014 6:23 pm
Great Britain

Re: 0.28 Australian EIT guide not showing

Post by PhilB » Thu Feb 02, 2017 8:33 am

I have seen a similar posting. Problem was that the eit flag in the database had been cleared for some channels. Check it with backend setup or with https://www.mythtv.org/wiki/Channel_Editor

Hth
Phil

dcw67
Newcomer
Posts: 3
Joined: Thu Feb 09, 2017 8:38 am
Australia

Re: 0.28 Australian EIT guide not showing

Post by dcw67 » Thu Feb 09, 2017 8:50 am

I found the same problem recently. I rescanned the channels since the networks had added new channels lately. Now the EPG for all SBS channels is not present. I checked in the backend setup channel editor and I have the Use Over the Air option ticked.

dvbsnoop for SBS channels shows:

Original_network_ID: 12802 (0x3202) [= >>ERROR: not (yet) defined... Report!<<]
EIT_schedule_flag: 0 (0x00)
EIT_present_following_flag: 0 (0x00)

whereas for other channels which have EPG, dvbsnoop shows:

Original_network_ID: 4114 (0x1012) [= Nine Network Australia | Nine Network Australia]
EIT_schedule_flag: 1 (0x01)
EIT_present_following_flag: 1 (0x01)

So it looks like SBS changed its network ID to something dvbsnoop doesn't know about and also is not providing EIT.

Is this the correct interpretation?
Does one report this (as suggested) and if so how?
Is there anything that can be done about this or is it justhow the data stream comes down and thats just how it is?

thanks,
David

dcw67
Newcomer
Posts: 3
Joined: Thu Feb 09, 2017 8:38 am
Australia

Re: 0.28 Australian EIT guide not showing

Post by dcw67 » Sun Mar 05, 2017 9:58 am

I got my problem sorted by rescanning the frequency for SBS. In the backend setup, go to frontend inputs and click on the Scan button. Then I chose to scan a single transport and selected the frequency for SBS. It re-found 5 old channels. I hit Update All. Save and exit. Started the frontend, selected Watch TV and went to SBS. It showed program info at the bottom of the screen whereas before it had unknown. I went into Manage Recordings -> Schedule Recordings -> Program Guide and SBS had data again. Yay!

See: https://tweakingmythtv.wordpress.com/20 ... ot-working

dcw67
Newcomer
Posts: 3
Joined: Thu Feb 09, 2017 8:38 am
Australia

Re: 0.28 Australian EIT guide not showing

Post by dcw67 » Sat Mar 25, 2017 9:43 am

This happened again and the rescan didn't fix it. I eventually discovered that there is a "Use EIT" check box for each individual channel in the channel editor. Somehow all the SBS channels had the option unchecked. I rechecked them and voila! I have my EPG for SBS again.

fraserspur
Newcomer
Posts: 13
Joined: Sun Apr 02, 2017 8:51 am
Australia

Re: 0.28 Australian EIT guide not showing

Post by fraserspur » Sun Apr 02, 2017 9:30 am

We had a similar problem with SBS not showing the EIT information, all other channels worked fine.

I entered the MythWeb interface and changed the' useonairguide' flag in Channel Info to checked but that didn't help.

Eventually I changed the SBS VICELAND call sign to SBSVICELAND without the space and it has worked since then.

Post Reply