Playback icons help menu video info for 1080 in v33

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
white_haired_uncle
Junior
Posts: 96
Joined: Thu Feb 23, 2023 8:55 pm
Location: Safe outside my gilded cage
United States of America

Playback icons help menu video info for 1080 in v33

Post by white_haired_uncle »

mythfrontend fixes/33 [v33.1-12-gc4b7e4c433-dirty] (guess it didn't like something I did, but this happens out of the box as well)
MythCenter-wide 1.10 (and Arclight, and Terra IIRC)
LANG=en_US.UTF-8

In Watch Recordings, I hit F1 to bring up a description of the icons. Where I expect to see

Recording is in 1080i High Definition

I actually see

Recording is in 720p High Definition {1080i?}

The only thing I can find that makes any sense is in
mythtv/i18n/mythfrontend_en_us.ts, (and mythtv/i18n/mythfrontend_en_ca.ts and mythtv/i18n/mythfrontend_hr.ts)
where we see things like:

Code: Select all

<message>
    <location filename="../programs/mythfrontend/playbackbox.cpp" line="5430"/>
    <source>Recording is in 1080i High Definition</source>
    <translation type="unfinished">Recording is in 720p High Definition {1080i?}</translation>
</message>
But after changing "Recording is in 720p High Definition {1080i?}" to "Recording is in 1080i High Definition" and rebuilding, I still see the wrong message.

Same for the 1080p line.

No big deal, but I thought I found an easy fix and I don't understand why it doesn't love me.
brfransen
Newcomer
Posts: 4
Joined: Mon Feb 10, 2014 3:34 pm
United States of America

Re: Playback icons help menu video info for 1080 in v33

Post by brfransen »

See this issue: https://github.com/MythTV/mythtv/issues/732

After you update the .ts file you have to run lrelease before you build.

Code: Select all

lrelease -removeidentical i18n/mythfrontend_en_us.ts
More info at: https://www.mythtv.org/wiki/Translation
white_haired_uncle
Junior
Posts: 96
Joined: Thu Feb 23, 2023 8:55 pm
Location: Safe outside my gilded cage
United States of America

[Solved] Playback icons help menu video info for 1080 in v33

Post by white_haired_uncle »

Thanks! I did wonder about that qm file, but I figured make would take care of it if it was needed. I guess not.

Now on to try to figure out why audio track 2 shows up as Spanish Castillian when it's really English with additional narration. So far, not a clue.
User avatar
kmdewaal
Developer
Posts: 555
Joined: Wed Dec 07, 2016 8:01 pm
Netherlands

Re: Playback icons help menu video info for 1080 in v33

Post by kmdewaal »

Now on to try to figure out why audio track 2 shows up as Spanish Castillian when it's really English with additional narration. So far, not a clue
A while ago I did fix something in ATSC subtitling and then I found similar wrong subtitle identifications. Most likely it is a bad configuration of the broadcaster and the stream is wrong. To investigate you need a recording (which you must have...) and stream analyzer software or players other than MythTV that do show subtitle identification.
Post Reply