Error opening jump program file buffer -vs- Synology Diskstation 218+

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
gargoyle
Newcomer
Posts: 3
Joined: Tue Feb 11, 2020 1:06 am
United States of America

Error opening jump program file buffer -vs- Synology Diskstation 218+

Post by gargoyle » Tue Feb 11, 2020 1:24 am

Hello,

I've been using MythTV for several years. I've recently changed my
system to store all data on a Synology Diskstation 218+. This
configuration worked for about a month, and then last week it
started showing:

Error opening jump program file buffer

when attempting to change channels watching LiveTV.

My system is running with this:

Myth TV version: fixes/29 (v29.1-13-g329c235)
Host OS : Ubuntu 18.04
Synology : Diskstation 218+ w/ several Tb of disk space (on 100Mbps eth)
Capture Card : HD Homerun Prime

I have followed the basic guidelines for using an NFS mount that are
described here:

<mythtv org>/wiki/Optimizing_Performance#General_Tips_For_Any_File_System
<mythtv org>/wiki/Optimizing_Performance#Network_File_Systems

I mount all of /var/lib/mythtv from the Synology, using the guidance
from the above links, via the following line in /etc/fstab:

a.b.c.d:/volume1/mythtv /var/lib/mythtv nfs rw,udp,noexec,proto=udp,mountproto=udp,intr,nfsvers=3,soft,rsize=32768,wsize=32768,ac,timeo=300,actimeo=0,noatime,nodiratime 0 1

I have tried 'tcp' and 'proto=tcp,mountproto=tcp' instead of the
'udp' versions; it didn't change the outcome.

Both 'rsize' and 'wsize' were auto-negotiated to much larger values
(when it was working). After it started failing, I reduced them to
32768. This did not change the outcome.

This is the full config of the mount point, from from '/proc/mounts':

a.b.c.d:/volume1/mythtv /var/lib/mythtv nfs rw,noexec,noatime,nodiratime,vers=3,rsize=32768,wsize=32768,namlen=255,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,soft,proto=udp,timeo=300,retrans=3,sec=sys,mountaddr=192.168.5.128,mountvers=3,mountport=892,mountproto=udp,local_lock=none,addr=192.168.5.128 0 0

On the Synology, /etc/exports contains the following:

/volume1/mythtv *(rw,async,no_wdelay,no_root_squash,insecure_locks,sec=sys,anonuid=1026,anongid=100)

Permissions on the Synology are almost certain to be acceptable, but
are not above questioning.

There are no problems with the HD Homerun Prime; using
hdhomerun_config_gui, I can tune channels and view them. As an
experiment, I ran hdhomerun_config_gui and used MythTV to watch
LiveTV. The channel tuned in MythTV and was correspondingly
reported in hdhomerun_config_gui. When I tried to switch to another
channel in MythTV, hdhomerun_config_gui showed the new channel tuned
for a brief period of time. The channel was then set to '0' as
MythTV reported the 'jump program' error and returned to the main
menu.

Based on what I've been reading regarding 'Error opening jump
program file buffer', I became convinced that this is an emergent
issue with NFS-mounting '/var/lib/mythtv' from the Synology. To
test this, I exited the MythTV frontend and stopped the backend. I
used 'rsync' to clone '/var/lib/mythtv' to a the local filesystem.
I unmounted '/var/lib/mythtv'. Finally, I moved the local copy into
'/var/lib/mythtv'.

With all the data moved onto a local disk, the error no longer
happens, thus confirming that this is an issue with the data being
on the NAS.

Comparatively, a colleague is also using MythTV on Linux with a
Synology Diskstation, but he has mounted the data using CIFS, with
no issues. So, I conclude the Diskstation is more than capable of
delivering the data that MythTV needs.

My questions are these:

1. What options should I supply to the frontend and backend to get
relevant logs? Is anyone willing to help bootstrap me in
reading these logs?

2. Does anyone know what NFS options I should be using, since the
ones I am using do not work properly.

If not the exact settings, what NFS options should I be focusing
on for experimentation?

3. If CIFS works, does anyone know the Synology-side and Linux-side
options that need to be set?

4. Does this issue manifest in the front end (where the error
message dialog is generated), or in the backend?

Where should I be looking in the source code to find out what's
the root cause of the problem (which will also guide which NFS
settings I should be fiddling with...)?

5. Does anyone know if there is a tracking ticket for this
particular problem? Should I file one?

6. Does anyone know if it would be sufficient to have just LiveTV
on the local system, and the rest of the data over NFS?

If so, how often is LiveTV data reaped / recovered? How much
impact will doing this have on my local file system usage
percentage?

gargoyle
Newcomer
Posts: 3
Joined: Tue Feb 11, 2020 1:06 am
United States of America

Re: Error opening jump program file buffer -vs- Synology Diskstation 218+

Post by gargoyle » Thu Feb 13, 2020 11:36 pm

With no ideas or information forthcoming about addressing this, I took a different tack.

I now only mount /var/lib/mythtv/recordings from the NAS.
All other directories are local.
I have had no problems since doing this.

Post Reply