Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Have a MythTV related problem? Ask for help from other MythTV users here.

Moderator: Forum Moderators

Post Reply
Marcus Aurelius
Junior
Posts: 23
Joined: Sat Dec 16, 2017 2:12 pm
United States of America

Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by Marcus Aurelius » Tue Feb 06, 2018 9:35 pm

Can someone please explain these warnings? Across 2 CPUs on 3 motherboards and kernels 4.4, 4.10, and 4.13, I have seen these in dmesg, and they are the only thing that looks amiss.

[ 5.205614] Linux video capture interface: v2.00
[ 5.205615] WARNING: You are using an experimental version of the media stack.
As the driver is backported to an older kernel, it doesn't offer
enough quality for its usage in production.
Use it with care.
Latest git patches (needed if you report a bug to linux-media@vger.kernel.org):
330dada5957e3ca0c8811b14c45e3ac42c694651 media: dvb_frontend: fix return error code
5e0d3c3a2c67c060e65e152558fa3cbdabdafe6c media: MAINTAINERS: add si2165 driver
7c4f4d1d7e5e3a5efc0a75410c7dad1c6c0be838 media: cx23885: Use semicolon after assignment instead of comma
[ 5.300444] AVX2 version of gcm_enc/dec engaged.
[ 5.300445] AES CTR mode by8 optimization enabled
[ 5.363327] WARNING: You are using an experimental version of the media stack.
As the driver is backported to an older kernel, it doesn't offer
enough quality for its usage in production.
Use it with care.
Latest git patches (needed if you report a bug to linux-media@vger.kernel.org):
330dada5957e3ca0c8811b14c45e3ac42c694651 media: dvb_frontend: fix return error code
5e0d3c3a2c67c060e65e152558fa3cbdabdafe6c media: MAINTAINERS: add si2165 driver
7c4f4d1d7e5e3a5efc0a75410c7dad1c6c0be838 media: cx23885: Use semicolon after assignment instead of comma
[ 5.378442] WARNING: You are using an experimental version of the media stack.
As the driver is backported to an older kernel, it doesn't offer
enough quality for its usage in production.
Use it with care.
Latest git patches (needed if you report a bug to linux-media@vger.kernel.org):
330dada5957e3ca0c8811b14c45e3ac42c694651 media: dvb_frontend: fix return error code
5e0d3c3a2c67c060e65e152558fa3cbdabdafe6c media: MAINTAINERS: add si2165 driver
7c4f4d1d7e5e3a5efc0a75410c7dad1c6c0be838 media: cx23885: Use semicolon after assignment instead of comma

Complete dmesg output attached:
Attachments
dmesg.log
(72.28 KiB) Downloaded 6 times

MikeB2013
Senior
Posts: 189
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by MikeB2013 » Wed Feb 07, 2018 8:25 am

Those messages are normal as it is a custom kernel with Hauppauge patches in V4L (Video 4 Linux) media stack.

On a test system I am running Xubuntu 17.10 with the Hauppauge kernel with a Hauppauge WinTV-QuadHD-DVB(885) (DVB-T/2) card and a TBS 6981 (dual DVB-S/S2) card on an Asus M5A78L-M/USB3, BIOS 2101 12/02/2014 motherboard with AMD Athlon(tm) II X2 250 Processor.

I have attached the output from dmesg for information:
dmesg_1710_hauppauge.txt
(71.13 KiB) Downloaded 9 times

Note - just an update on the Ryzen issue :

Originally I was testing on a Gigabyte GA350B Gaming 3 motherboard with a Ryzen 3 processor, but my Hauppauge QuadHD (not the ATSC version) does not work unless I include in a /etc/modprobe.d/ file "options cx23885 debug=7") , which to me indicates a timing problem somewhere in one of the drivers. Unfortunately this is not a usable configuration as the debug=7 causes massive log files (syslog and kern.log) which each get to many Gigabytes after running for a few hours, plus increased system load. Hauppauge have indicated that the issue affects both 885 and 888 versions of the QuadHD card and are working on this problem see https://github.com/b-rad-NDi/Ubuntu-med ... /issues/17

Marcus Aurelius
Junior
Posts: 23
Joined: Sat Dec 16, 2017 2:12 pm
United States of America

Re: Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by Marcus Aurelius » Wed Feb 07, 2018 2:22 pm

Mike!
Thank you so much for your response.
In looking over your dmesg output, I see that mine is significantly different at the end, where it repeatedly finds a 'Silicon Labs Si2157-A30'. Not sure what that's about. I guess I have a great deal more to learn regarding the interpretation of dmesg output. Can you possibly shed any light on that?

MikeB2013
Senior
Posts: 189
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by MikeB2013 » Sat Feb 10, 2018 11:33 am

I don't know about si2157-A30 messages, I also get them, once mythtv tries to tune to a channel, which is fine if you could successfully scan for channels in the first place.

FYI Hauppauge have just released a new builds (does not include any changes for Ryzen), which should work for QuadHD ATSC boards, however the new builds broke the QuadHD DVB versions (no channels being found in a channel scan).

Mike

Marcus Aurelius
Junior
Posts: 23
Joined: Sat Dec 16, 2017 2:12 pm
United States of America

Re: Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by Marcus Aurelius » Sun Feb 11, 2018 4:47 pm

Wow! I noticed after I updated that some changes had been made. All that red ink in dmesg went away. I was very optimistic until I re-scanned and got the same old nothing. I've asked Hauppauge for an RMA on the assumption that the card is non-op.

Marcus Aurelius
Junior
Posts: 23
Joined: Sat Dec 16, 2017 2:12 pm
United States of America

Re: Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by Marcus Aurelius » Mon Feb 12, 2018 4:13 pm

Well, I have some news. Last night, I'm scanning for channels one more time. Just to see what happens, I pull the antenna lead off the card, expecting the "Signal Strength" meter in Mythbackend to fall to zero. Instead, absolutely nothing happens. Except at some point, I notice that the scan has found 4 channels! Fiddling with the antenna lead in close proximity to the connector, I find that I can actually watch live TV on those channels by holding the lead close to or just touching the connector.

This morning, I go into the attic and unplug the amplifier, and I find that I can scan almost all the channels I would expect to find.

Can someone please explain what's going on? Too much signal with the amplifier? The same amplified antenna lead worked great on my television. Any easy way to measure signal strength?

User avatar
Steve Goodey
Moderator
Posts: 23
Joined: Fri Feb 07, 2014 6:30 pm
Location: Colchester, England
Great Britain

Re: Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by Steve Goodey » Mon Feb 12, 2018 4:43 pm

Try whacking a 6DB attenuator between the aerial connector and the card.

Marcus Aurelius
Junior
Posts: 23
Joined: Sat Dec 16, 2017 2:12 pm
United States of America

Re: Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by Marcus Aurelius » Tue Feb 13, 2018 4:15 pm

I wonder which would be preferable: Insert the attenuator as you suggest, or just do away with the amplifier altogether?

Marcus Aurelius
Junior
Posts: 23
Joined: Sat Dec 16, 2017 2:12 pm
United States of America

Re: Can't scan OTA channles with winTV-quadHD on Ubuntu 17.10

Post by Marcus Aurelius » Fri Feb 16, 2018 9:43 pm

Well, I'm watching TV on Myth. Took the amp out, and with the antenna up in the attic, it works fine. I've probably got over 20 channels. Still a couple of things to fine tune, but it works! Thanks folks!

Post Reply