MobileMyth v.7 Released - Better Late Than Never

Announcements about 3rd Party Clients
Post Reply
User avatar
jheizer
Newcomer
Posts: 10
Joined: Fri Feb 07, 2014 3:25 pm
Location: Central IL, USA
Contact:
United States of America

MobileMyth v.7 Released - Better Late Than Never

Post by jheizer » Thu Oct 23, 2014 4:29 am

Long time, no update. I've finally wrapped up an update to MobileMyth. I had grand plans to incorporate ChromeCasts with this but when Google finally got around to releasing the final SDK, I was against the rules. So it is a bit light on new features.

What is MobileMyth you ask since it has been so long:
- Goal of the project is to have a platform independent web browser based frontend
- Support phones, tablets, desktops
- HLS Stream files or access them directly
- Videos
- Remote play to frontends (though this could be prettier)
- View Statuses/upcoming/conflicts/storage/etc
- Auto transcode HLS streams and auto remove them
- Proxy all backend access through your webserver so no vpn is required although in some cases the video streaming has issues.

What's New:
- Brand new theme
- WoL Support for remote frontends
- Gallery support for the possible new plugin currently in master
- Completely new Services API layer to better support any Myth version.

Currently Support .25-.28-pre (as of a few months ago, I know some stuff in master has changed recently probably) I also have not tested against .25-.26 lately.

http://www.mobilemyth.net/

Give it a try and let me know what you think.

Image

pkendall64
Newcomer
Posts: 3
Joined: Thu Nov 13, 2014 3:27 am
New Zealand

Re: MobileMyth v.7 Released - Better Late Than Never

Post by pkendall64 » Thu Nov 13, 2014 3:32 am

Hi, I've installed via the repo on a 12.04 ubuntu backend system.
I have configured everthing in the initial screens then I restarted apache and when I connecto the mobilemyth URL I the error below.
I can go back to the admin screens, I just can't get the main UI going at all.

Code: Select all

Array index is out of range.

Description: HTTP 500. Error processing request.

Stack Trace:

System.IndexOutOfRangeException: Array index is out of range.
  at _default.DisplayRecentSlider () [0x00000] in <filename unknown>:0 
  at _default.Page_Init (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0 
  at System.Web.UI.Control.OnInit (System.EventArgs e) [0x00000] in <filename unknown>:0 
  at System.Web.UI.Page.OnInit (System.EventArgs e) [0x00000] in <filename unknown>:0 
  at System.Web.UI.Control.InitRecursive (System.Web.UI.Control namingContainer) [0x00000] in <filename unknown>:0 
  at System.Web.UI.Page.InternalProcessRequest () [0x00000] in <filename unknown>:0 
  at System.Web.UI.Page.ProcessRequest (System.Web.HttpContext context) [0x00000] in <filename unknown>:0 
Version information: Mono Runtime Version: 2.10.8.1 (Debian 2.10.8.1-1ubuntu2.2); ASP.NET Version: 4.0.30319.1

User avatar
jheizer
Newcomer
Posts: 10
Joined: Fri Feb 07, 2014 3:25 pm
Location: Central IL, USA
Contact:
United States of America

Re: MobileMyth v.7 Released - Better Late Than Never

Post by jheizer » Thu Nov 13, 2014 3:40 am

pkendall64 wrote:Hi, I've installed via the repo on a 12.04 ubuntu backend system.
I have configured everthing in the initial screens then I restarted apache and when I connecto the mobilemyth URL I the error below.
I can go back to the admin screens, I just can't get the main UI going at all.
Do you have any recordings? It looks like a bug in the recent recordings display on the home page. On the frontend settings page uncheck displaying those.

pkendall64
Newcomer
Posts: 3
Joined: Thu Nov 13, 2014 3:27 am
New Zealand

Re: MobileMyth v.7 Released - Better Late Than Never

Post by pkendall64 » Thu Nov 13, 2014 5:51 am

Do you have any recordings?
Yes, I do have recordings, I have some for the last 3 days, then some from over a week ago.
These recordings show in the mythweb/tv/recorded page.

Like you said, if I disable the recent recordings it works after that.
Is there something else I can supply that can help diagnose the problem for you?

User avatar
jheizer
Newcomer
Posts: 10
Joined: Fri Feb 07, 2014 3:25 pm
Location: Central IL, USA
Contact:
United States of America

Re: MobileMyth v.7 Released - Better Late Than Never

Post by jheizer » Fri Nov 14, 2014 2:27 am

Yeah can you open a browser and navigate to http://YouBackendIp:6544/Dvr/GetRecorde ... &Count=100

Then paste bin that and reply. I'll put more checking around that code in the next release to make sure it does bring everything down in the future as well.

pkendall64
Newcomer
Posts: 3
Joined: Thu Nov 13, 2014 3:27 am
New Zealand

Re: MobileMyth v.7 Released - Better Late Than Never

Post by pkendall64 » Fri Nov 14, 2014 6:40 am

Hi, attached is the file output from the call.
Attachments
get.txt
XML file returned from the call get GetRecordedList
(28.73 KiB) Downloaded 60 times

philled
Newcomer
Posts: 2
Joined: Fri Nov 14, 2014 7:54 am
Australia

Re: MobileMyth v.7 Released - Better Late Than Never

Post by philled » Fri Nov 14, 2014 7:58 am

I'm using the latest version of mobilemyth installed from a repo on my Ubunru 12.04 MythTV backend. Since running it yesterday my backend has suddenly run out of disk space. My guess is that there are some transcoded files lying around from mobilemyth. Can you please tell me where these might live so I can track them down and get rid of them as my MythTV backend box is down and out until I clean up some disk space.

User avatar
jheizer
Newcomer
Posts: 10
Joined: Fri Feb 07, 2014 3:25 pm
Location: Central IL, USA
Contact:
United States of America

Re: MobileMyth v.7 Released - Better Late Than Never

Post by jheizer » Fri Nov 14, 2014 1:56 pm

They go to the HLS storage group. If that is not defined I believe they went to ~/.mythtv/hlstemp or something similar. If they were recordings and you deleted them in MobileMyth after watching it will clean it up. If not Myth does not yet have a tie between recordings and the generated HLS files. In that case this will auto clean up hls files where the recording/video no longer exists. http://www.mobilemyth.net/index.php/auto-clean-up/ or namually you can delete them via the backend by going to http://backendip:6544 API | Examples | HTTP Live Streaming and deleting them there. I plan to have a duplicate of that screen within MM on the next release.

philled
Newcomer
Posts: 2
Joined: Fri Nov 14, 2014 7:54 am
Australia

Re: MobileMyth v.7 Released - Better Late Than Never

Post by philled » Sat Nov 15, 2014 1:36 am

jheizer wrote:They go to the HLS storage group. If that is not defined I believe they went to ~/.mythtv/hlstemp or something similar. If they were recordings and you deleted them in MobileMyth after watching it will clean it up. If not Myth does not yet have a tie between recordings and the generated HLS files. In that case this will auto clean up hls files where the recording/video no longer exists. http://www.mobilemyth.net/index.php/auto-clean-up/ or namually you can delete them via the backend by going to http://backendip:6544 API | Examples | HTTP Live Streaming and deleting them there. I plan to have a duplicate of that screen within MM on the next release.
Thanks - that was a brilliant answer. For some reason I could delete them all through the http://backendip:6544 UI, but you did help me to track down where all of these files live and I found 2.7GB of them. There was a whole load there, some from months ago so unrelated to mythmobile.

This gave me an opportunity for a good cleanup. I deleted them manually and have freed up loads of disk space in my partitions :)

For anyone else who's looking for the files, I found them under /home/mythtv/.mythtv/tmp/hls. On a MythBuntu box this isn't a directory area you would visit very much because the mythtv account isn't one you normally log on with, so it's worth checking this out from time to time.

perkins1724
Junior
Posts: 31
Joined: Tue Nov 18, 2014 7:44 am
Australia

Re: MobileMyth v.7 Released - Better Late Than Never

Post by perkins1724 » Tue Nov 18, 2014 7:48 am

Hi, bringing this here as requested from the mailing list.

I receive the following error after installation from the repo. No idea where to go next, any assistance greatly appreciated:

Code: Select all

Application Exception


System.ArgumentOutOfRangeException
Argument is out of range.
Parameter name: dueTime

Description: HTTP 400.Error processing request.

Details: Non-web exception. Exception origin (name of application or object): mscorlib.

Exception stack trace:
  at System.Threading.Timer.Change (Int64 dueTime, Int64 period, Boolean first) [0x00000] in <filename unknown>:0 
  at System.Threading.Timer.Init (System.Threading.TimerCallback callback, System.Object state, Int64 dueTime, Int64 period) [0x00000] in <filename unknown>:0 
  at System.Threading.Timer..ctor (System.Threading.TimerCallback callback, System.Object state, Int32 dueTime, Int32 period) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Threading.Timer:.ctor (System.Threading.TimerCallback,object,int,int)
  at System.Web.HttpContext.StartTimeoutTimer () [0x00000] in <filename unknown>:0 
  at System.Web.HttpApplication.PreStart () [0x00000] in <filename unknown>:0 
  at System.Web.HttpApplication.Start (System.Object x) [0x00000] in <filename unknown>:0 
  at System.Web.HttpApplication.System.Web.IHttpHandler.ProcessRequest (System.Web.HttpContext context) [0x00000] in <filename unknown>:0 
  at System.Web.HttpRuntime.Process (System.Web.HttpWorkerRequest req) [0x00000] in <filename unknown>:0 
  at System.Web.HttpRuntime.RealProcessRequest (System.Object o) [0x00000] in <filename unknown>:0 
  at System.Web.HttpRuntime.ProcessRequest (System.Web.HttpWorkerRequest wr) [0x00000] in <filename unknown>:0 
  at Mono.WebServer.MonoWorkerRequest.ProcessRequest () [0x00000] in <filename unknown>:0 


Version Information: 3.2.8 (Debian 3.2.8+dfsg-4ubuntu1); ASP.NET Version: 4.0.30319.17020

Seven
Newcomer
Posts: 6
Joined: Sat Feb 08, 2014 11:40 am
Australia

Re: MobileMyth v.7 Released - Better Late Than Never

Post by Seven » Mon Feb 02, 2015 11:11 pm

As posted to the mythtv-user mailing list http://www.gossamer-threads.com/lists/m ... 641#579641

I'm also getting some errors with 0.7.1 from the repo or manually installed, if I roll back to 0.7 it works perfectly

Both With either the JWplayer (Error #2048) or VLC I get failures, however they play perfectly with JWplayer via the internal Example streaming site http://backend:6544/

File reading failed:

VLC could not open the file "C:\Users\...\AppData\Local\Temp\4022_20141111064900.mpg.864x480_800kV_128kA.av.m3u8" (Bad file descriptor).

File reading failed:

VLC could not open the file "C:\Users\...\AppData\Local\Temp\4022_20141111064900.mpg.864x480_800kV_128kA.ao_32kA.m3u8" (Bad file descriptor).

File reading failed:

VLC could not open the file "C:\Users\...\AppData\Local\Temp\4022_20141111064900.mpg.864x480_800kV_128kA.av.m3u8" (Bad file descriptor).

Your input can't be opened:

VLC is unable to open the MRL 'file:///C:/Users/.../AppData/Local/Temp/4022_20141111064900.mpg.864x480_800kV_128kA.av.m3u8'. Check the log for details.

File reading failed:

VLC could not open the file "C:\Users\...\AppData\Local\Temp\4022_20141111064900.mpg.864x480_800kV_128kA.ao_32kA.m3u8" (Bad file descriptor).

Your input can't be opened:

VLC is unable to open the MRL 'file:///C:/Users/.../AppData/Local/Temp/4022_20141111064900.mpg.864x480_800kV_128kA.ao_32kA.m3u8'. Check the log for details.

if I roll back to 0.7 everything is working again

I get these errors below in Both 0.7 & 0.7.1 so not related I think


2014-11-12 12:39:21,138 [Threadpool worker] ERROR ASP.global_asax System.TypeInitializationException: An exception was thrown by the type initializer for FrontendScanner ---> System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running.
at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00000] in :0
at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x00000] in :0
at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x00000] in :0
at Mono.Zeroconf.ServiceBrowser..ctor () [0x00000] in :0
at FrontendScanner..cctor () [0x00000] in :0
--- End of inner exception stack trace ---

I cant find any other logs that report any issues, if there anything else I can check let me know.

Cheers,

Anthony
Last edited by Seven on Mon Feb 02, 2015 11:54 pm, edited 1 time in total.

User avatar
jheizer
Newcomer
Posts: 10
Joined: Fri Feb 07, 2014 3:25 pm
Location: Central IL, USA
Contact:
United States of America

Re: MobileMyth v.7 Released - Better Late Than Never

Post by jheizer » Mon Feb 02, 2015 11:15 pm

Do you have the video proxy option enabled? I have to rebuild the playlist file I get from myth and it looks like it is not working correctly and trying to find the files locally vs through mobilemyth or hitting the backend directly.

Seven
Newcomer
Posts: 6
Joined: Sat Feb 08, 2014 11:40 am
Australia

Re: MobileMyth v.7 Released - Better Late Than Never

Post by Seven » Tue Feb 03, 2015 12:11 am

From memory I tried with the proxy option both enabled and disabled and if I roll back to the 0.7 release all is well again. (But this was some time ago)

if I were to guess at the issue, I'd assuming that the HLS files were not being created as JWplayer is also failing playback.

is there some debugging I can enable to test further?

Anthony

paul
Newcomer
Posts: 2
Joined: Mon Mar 23, 2015 3:44 pm
Guinea Bissau

Re: MobileMyth v.7 Released - Better Late Than Never

Post by paul » Mon Mar 23, 2015 3:51 pm

Hi ,

I've just tried to install mobile myth on my backend only machine using the debian packages.

It installed fine , but when visiting the webserver I'm getting an error:

System.ArgumentOutOfRangeException
Argument is out of range.
Parameter name: dueTime
Description: HTTP 400.Error processing request.


Looking at the log file in the installed directory it shows:

2015-03-23 15:34:48,930 [Threadpool worker] INFO ASP.global_asax Site Started
2015-03-23 15:34:48,948 [Threadpool worker] ERROR ASP.global_asax System.TypeInitializationException: An exception was thrown by the type initializer for FrontendScanner ---> System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running.
at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () [0x00000] in <filename unknown>:0
at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () [0x00000] in <filename unknown>:0
at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () [0x00000] in <filename unknown>:0
at Mono.Zeroconf.ServiceBrowser..ctor () [0x00000] in <filename unknown>:0
at FrontendScanner..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at ASP.global_asax.Application_Start (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0

I've been unable to get any page to display correctly , incluing http://XXXX/mobilemyth/admin

Any advice?

Seven
Newcomer
Posts: 6
Joined: Sat Feb 08, 2014 11:40 am
Australia

Re: MobileMyth v.7 Released - Better Late Than Never

Post by Seven » Wed Jun 15, 2016 3:40 am

Re: my previous posts I did end up getting this working in 0.7.2 after I upgraded to Mythbuntu 14.04 but now I'm testing in a VM before I upgrade to 0.28
anyone got this running under 0.28 and mythbuntu 16.04?

2016-06-15 10:47:23,892 [Threadpool worker] INFO ASP.global_asax Site Started
2016-06-15 10:47:23,919 [Threadpool worker] ERROR ASP.global_asax System.TypeInitializationException: The type initializer for 'FrontendScanner' threw an exception. ---> System.Exception: No Zeroconf providers could be found or initialized. Necessary daemon may not be running.
at Mono.Zeroconf.Providers.ProviderFactory.GetProviders () <0x403e63e0 + 0x0097f> in <filename unknown>:0
at Mono.Zeroconf.Providers.ProviderFactory.get_DefaultProvider () <0x403e6380 + 0x0001b> in <filename unknown>:0
at Mono.Zeroconf.Providers.ProviderFactory.get_SelectedProvider () <0x403e6320 + 0x0001f> in <filename unknown>:0
at Mono.Zeroconf.ServiceBrowser..ctor () <0x403e61a0 + 0x0002b> in <filename unknown>:0
at FrontendScanner..cctor () <0x403e60d0 + 0x0008b> in <filename unknown>:0
--- End of inner exception stack trace ---
at ASP.global_asax.Application_Start (System.Object sender, System.EventArgs e) <0x403b3420 + 0x00093> in <filename unknown>:0

Post Reply