mythfrontend V31 clean build fails to start

For discussion of topics specific to MythTV on linux
Post Reply
tobiz
Junior
Posts: 21
Joined: Mon Dec 02, 2019 9:53 pm
Great Britain

mythfrontend V31 clean build fails to start

Post by tobiz » Sat Nov 14, 2020 4:39 pm

Given up with ubuntu 18.04 V31 package install tried build from source. Followed all instructions and got clean build and install. mythbackend runs ok, mythtv-setup runs ok, mythfrontend fails with:

Code: Select all

$ mythfrontend
libEGL warning: DRI2: failed to authenticate
"Display: Requesting EGL for 'Mesa Project, 1.4'"
libEGL warning: DRI2: failed to authenticate
2020-11-14 16:24:39.233901 I  Setup Interrupt handler
2020-11-14 16:24:39.233917 I  Setup Terminated handler
2020-11-14 16:24:39.233921 I  Setup Segmentation fault handler
2020-11-14 16:24:39.233928 I  Setup Aborted handler
2020-11-14 16:24:39.233931 I  Setup Bus error handler
2020-11-14 16:24:39.233936 I  Setup Floating point exception handler
2020-11-14 16:24:39.233940 I  Setup Illegal instruction handler
2020-11-14 16:24:39.233946 I  Setup Real-time signal 0 handler
2020-11-14 16:24:39.233950 I  Setup User defined signal 1 handler
2020-11-14 16:24:39.233955 I  Setup User defined signal 2 handler
2020-11-14 16:24:39.233959 I  Setup Hangup handler
2020-11-14 16:24:39.234017 C  mythfrontend version: fixes/31 [v31.0-118-geb3c84de5f] www.mythtv.org
2020-11-14 16:24:39.234020 C  Qt version: compile: 5.9.5, runtime: 5.9.5
2020-11-14 16:24:39.234049 I  Ubuntu 18.04.5 LTS (x86_64)
2020-11-14 16:24:39.234051 N  Enabled verbose msgs:  general
2020-11-14 16:24:39.234061 N  Setting Log Level to LOG_INFO
2020-11-14 16:24:39.244423 N  Using runtime prefix = /usr/local
2020-11-14 16:24:39.244428 N  Using configuration directory = /home/pjr/.mythtv
2020-11-14 16:24:39.244474 I  Assumed character encoding: en_GB.UTF-8
2020-11-14 16:24:39.244768 I  Loading en_gb translation for module mythfrontend
2020-11-14 16:24:39.244935 I  Empty LocalHostName. This is typical.
2020-11-14 16:24:39.244938 I  Using a profile name of: 'atlast-vm3' (Usually the same as this host's name.)
2020-11-14 16:24:39.244985 I  Start up testing connections. DB localhost, BE , attempt 0, status dbAwake, Delay: 2000
2020-11-14 16:24:39.245497 I  Added logging to the console
2020-11-14 16:24:40.304170 N  Setting QT default locale to en_GB
2020-11-14 16:24:40.304178 I  Current locale en_GB
2020-11-14 16:24:40.304209 N  Reading locale defaults from /usr/local/share/mythtv//locales/en_gb.xml
2020-11-14 16:24:40.311458 I  Display: Found screen 'VGA-1'
2020-11-14 16:24:40.311471 I  Display: Using screen 'VGA-1' (Make: Unknown Model: Unknown)
2020-11-14 16:24:40.311479 I  Display: Qt screen pixel ratio: 1.00
2020-11-14 16:24:40.311489 I  Display: Geometry: 1680x942+0+0 Size(Qt): 440mmx246mm
2020-11-14 16:24:40.314985 N  Display: Desktop video mode: 1680x942 59.956Hz
2020-11-14 16:24:40.314990 N  Display: Display is using sRGB colourspace
2020-11-14 16:24:40.322689 I  ScreenSaverDBus: Created for DBus service: org.freedesktop.ScreenSaver
2020-11-14 16:24:40.323863 I  ScreenSaverDBus: Created for DBus service: org.freedesktop.PowerManagement.Inhibit
2020-11-14 16:24:40.325927 I  Starting process manager
2020-11-14 16:24:40.325949 I  Starting process signal handler
2020-11-14 16:24:40.327802 I  Starting IO manager (write)
2020-11-14 16:24:40.327862 I  Starting IO manager (read)
2020-11-14 16:24:40.377924 I  ScreenSaverX11Private: DPMS is active.
2020-11-14 16:24:40.439958 I  PowerDBus: Added UPower.Device '/org/freedesktop/UPower/devices/line_power_AC'
2020-11-14 16:24:40.439966 I  Power: Unknown power source
2020-11-14 16:24:40.460592 I  Power: Supported actions: Suspend,Restart,Shutdown
2020-11-14 16:24:40.464014 I  Listening on TCP 0.0.0.0:6547
2020-11-14 16:24:40.464635 I  Listening on TCP [::]:6547
2020-11-14 16:24:43.138319 I  Connecting to lcd server: 127.0.0.1:6545 (try 1 of 10)
2020-11-14 16:24:43.139567 I  Loading en_gb translation for module mythfrontend
2020-11-14 16:24:43.168641 E  LIRC: Failed to read config file '/home/pjr/.lircrc'
2020-11-14 16:24:43.168665 I  No joystick configuration found, not enabling joystick control
2020-11-14 16:24:43.168669 I  UDPListener: Enabling
2020-11-14 16:24:43.169399 I  Binding to UDP 0.0.0.0:6948
2020-11-14 16:24:43.169433 I  Binding to UDP [::]:6948
2020-11-14 16:24:43.212156 I  Display: Have main widget
2020-11-14 16:24:43.215602 I  UI Screen Resolution: 900 x 600
2020-11-14 16:24:43.243118 I  Display: Have main window
2020-11-14 16:24:43.243936 I  Display: Found screen 'VGA-1'
2020-11-14 16:24:43.261661 I  OpenGL: OpenGL vendor        : VMware, Inc.
2020-11-14 16:24:43.261667 I  OpenGL: OpenGL renderer      : llvmpipe (LLVM 10.0.0, 256 bits)
2020-11-14 16:24:43.261670 I  OpenGL: OpenGL version       : 3.1 Mesa 20.0.8
2020-11-14 16:24:43.261672 I  OpenGL: Qt platform          : xcb
2020-11-14 16:24:43.261705 I  OpenGL: EGL display          : Yes
2020-11-14 16:24:43.261707 I  OpenGL: EGL images           : Yes
2020-11-14 16:24:43.261709 I  OpenGL: Qt OpenGL format     : OpenGL 3.1
2020-11-14 16:24:43.261711 I  OpenGL: Qt OpenGL surface    : RGBA: 8880 Depth: 0 Stencil: 0
2020-11-14 16:24:43.261713 I  OpenGL: Max texture size     : 8192
2020-11-14 16:24:43.261715 I  OpenGL: Max texture units    : 128
2020-11-14 16:24:43.261717 I  OpenGL: Shaders              : Yes
2020-11-14 16:24:43.261719 I  OpenGL: NPOT textures        : Yes
2020-11-14 16:24:43.261724 I  OpenGL: Multitexturing       : Yes
2020-11-14 16:24:43.261727 I  OpenGL: Rectangular textures : Yes
2020-11-14 16:24:43.261730 I  OpenGL: Buffer mapping       : Yes
2020-11-14 16:24:43.261732 I  OpenGL: Framebuffer objects  : Yes
2020-11-14 16:24:43.261736 I  OpenGL: 16bit framebuffers   : Yes
2020-11-14 16:24:43.261738 I  OpenGL: Unpack Subimage      : Yes
2020-11-14 16:24:43.261741 I  OpenGL: GL_RED/GL_R8         : Yes
2020-11-14 16:24:43.277176 I  OpenGL: Initialised MythRenderOpenGL
2020-11-14 16:24:43.277182 I  OpenGL: Using full range output
2020-11-14 16:24:43.281801 I  MythUIHelper: Pruning cache directory: /home/pjr/.mythtv/cache/remotecache
2020-11-14 16:24:43.281845 I  MythUIHelper: Kept 0 files, deleted 0 files, stat error on 0 files
2020-11-14 16:24:43.281851 I  MythUIHelper: Pruning cache directory: /home/pjr/.mythtv/cache/thumbnails
2020-11-14 16:24:43.281908 I  MythUIHelper: Kept 7 files, deleted 0 files, stat error on 0 files
2020-11-14 16:24:43.460155 I  MythCoreContext::ConnectCommandSocket(): Connecting to backend server: 127.0.0.1:6543 (try 1 of 1)
2020-11-14 16:24:43.461727 I  MythCoreContext::CheckProtoVersion(): Using protocol version 91 BuzzOff
2020-11-14 16:24:43.578418 E  CECAdapter: Failed to find any CEC devices.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
2020-11-14 16:24:44.080351 I  CECAdapter: Closing down CEC.
2020-11-14 16:24:44.084522 E  RAOP Device: Aborting startup - no key found.
2020-11-14 16:24:44.086757 I  AirPlay: Created airplay objects.
2020-11-14 16:24:44.087184 I  Listening on TCP 0.0.0.0:5100
2020-11-14 16:24:44.087276 I  Listening on TCP [::]:5100
2020-11-14 16:24:44.104291 I  Current MythTV Schema Version (DBSchemaVer): 1361
2020-11-14 16:24:44.109898 I  VDPAUHelp: VDPAU is NOT available
2020-11-14 16:24:44.112844 I  VAAPIDec: VAAPI functionality checked failed
2020-11-14 16:24:44.123802 E  NVDECInterop: Failed to initialise CUDA API
2020-11-14 16:24:44.124238 I  NVDEC: No NVDEC decoders found
2020-11-14 16:24:44.124609 I  V4L2_M2M: No V4L2 decoders found
2020-11-14 16:24:44.468857 N  Registering Internal as a media playback plugin.
2020-11-14 16:24:44.469993 N  MediaMonitor disabled by user setting.
Segmentation fault (core dumped)
mythfrontend gets as far as showing window surround then crashes.
This on VirtualBox V5.2.34.iso system running ubuntu 18.04. Mythbackend seen to be running from System Monitor.
Note, V31 runtime requires libexiv2-27 which is not available on 18.04, libexiv2-14 is, so used that but that doesn't look like the problem. Got similar results several months ago so went to source build of v30 which all worked ok.

User avatar
paulh
Developer
Posts: 585
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: mythfrontend V31 clean build fails to start

Post by paulh » Sat Nov 14, 2020 9:16 pm


tobiz
Junior
Posts: 21
Joined: Mon Dec 02, 2019 9:53 pm
Great Britain

Re: mythfrontend V31 clean build fails to start

Post by tobiz » Wed Nov 18, 2020 12:30 am

Thanks for these. I've abandoned building and running in a VM. I suspect mythfrontend seems to get confused as to what the IP address is for localhost. I've resorted to a clean build of V31 in a 'real' ubuntu 18.04 and everything works.

Post Reply