[Solved, really] Mythbackend 0.29 Won't Start on Ubuntu 18.04

For discussion of topics specific to MythTV on linux
kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: [NOT Solved] Mythbackend 0.29 Won't Start on Ubuntu 18.04

Post by kbocek » Thu Jul 23, 2020 8:41 pm

Damn, this was working for awhile. I don't know what changed. The systemctl cat command just gives me the /lib/systemd/system file. Nothing myth in /etc/rc*.

Code: Select all

# ps -alx | grep myth
4   118   646     1  20   0  47264  3440 poll_s Ss   ?          0:09 avahi-daemon: running [myth.local]
4   128 14502     1  20   0 4563368 75840 poll_s Ssl ?          0:01 /usr/bin/mythbackend --quiet --syslog local7
0     0 14547  1349  20   0  14428  1008 pipe_w S+   pts/0      0:00 grep --color=auto myth
Does the avahi-daemon line mean anything? Are you suggesting I remove these startup files and use my manual one?

User avatar
bill6502
Developer
Posts: 1730
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: [NOT Solved] Mythbackend 0.29 Won't Start on Ubuntu 18.04

Post by bill6502 » Thu Jul 23, 2020 8:51 pm

Not worried about avahi. No, I was asking about old SYSV files in /etc/init.d. But the ps is
what's expected.

Desperation mode, remove all capture cards and try to restart. The SEGV was looping
through the cards in an earlier log snippet.

kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: [NOT Solved] Mythbackend 0.29 Won't Start on Ubuntu 18.04

Post by kbocek » Thu Jul 23, 2020 9:27 pm

I think that did it! Running solidly for 6 minutes so far. I had done some manual DB manipulation (I know I'm not supposed to). This time I did everything through mythtv-setup.

Now I need to figure out the recordings thing I started in the other thread.

Post Reply