Ubuntu 20.04 PPA

For discussion of topics specific to MythTV on linux
Post Reply
kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Ubuntu 20.04 PPA

Post by kbocek » Fri Jul 17, 2020 8:25 pm

I just upgraded a host to Ubuntu 20.04 LTS. But I get an error if I try to add the 0.29 PPA. Yes, I know that's not the current version.

Any ideas?

wesnewell
Senior
Posts: 672
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Ubuntu 20.04 PPA

Post by wesnewell » Fri Jul 17, 2020 8:50 pm

What command did you use to add it?
What was the error message?
It may not be supported in 20.04. Maybe it's time to upgrade to v31.
BE/FE-Asrock AB350 Pro Ryzen 3 3200G, 6 atsc tuners. FE's-GF8200's Athlon II, Ryzen 3 2200G. Mythtv user since 2005.

kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Ubuntu 20.04 PPA

Post by kbocek » Fri Jul 17, 2020 10:17 pm

God I hate this upgrade nonsense. I can never get it right. My whole setup is 0.29. I built this host to move mythbackend off a CentOS 6 host where upgrading is hard. Silly me I upgraded from 18.04 to 20.04 thinking it would be covered. Plus I picked Ubuntu thinking it would make things easier. The upshot is I need to get 0.29 on this host.

So is the PPA broken for 20.04?

Will the source compile on 20.04 or does that need to be updated too.

wesnewell
Senior
Posts: 672
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Ubuntu 20.04 PPA

Post by wesnewell » Sat Jul 18, 2020 4:37 am

PPA for V31 works fine for me on 20.04lts. Why would you want to compile it. Just load V31 from the repo. apt-get install mythtv from root terminal. maybe this will help.
https://launchpad.net/~mythbuntu/+archive/ubuntu/0.29
BE/FE-Asrock AB350 Pro Ryzen 3 3200G, 6 atsc tuners. FE's-GF8200's Athlon II, Ryzen 3 2200G. Mythtv user since 2005.

kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Ubuntu 20.04 PPA

Post by kbocek » Sun Jul 19, 2020 3:00 pm

Thanks for the reply Wes. The problem is I need to get 0.29 on this host. It looks like there is no PPA for 0.29 on Ubuntu 20.04. I think I made a mistake upgrading Ubuntu.

wesnewell
Senior
Posts: 672
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Ubuntu 20.04 PPA

Post by wesnewell » Sun Jul 19, 2020 4:42 pm

I just added it to 20.04. Whether or not it works, I couldn't say as I'm running V31. With the database changes from 18.04 to 20.04, I kind of doubt it.I'm pretty sure if you install the old DB too it would probably work, but why not just upgrade to V31 and be done with it.
root@mythfe0:/home/wes# add-apt-repository ppa:mythbuntu/0.29
Released
More info: https://launchpad.net/~mythbuntu/+archive/ubuntu/0.29
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease [111 kB]
Get:3 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Ign:4 http://ppa.launchpad.net/mythbuntu/0.29/ubuntu focal InRelease
Hit:5 http://archive.canonical.com/ubuntu focal InRelease
Get:6 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Get:7 http://ppa.launchpad.net/mythbuntu/31/ubuntu focal InRelease [17.5 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [255 kB]
Get:9 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [21.2 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [139 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [192 kB]
Get:12 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [35.7 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages [69.3 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [132 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [176 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:17 http://us.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [1,972 B]
Err:18 http://ppa.launchpad.net/mythbuntu/0.29/ubuntu focal Release
404 Not Found [IP: 2001:67c:1560:8008::15 80]
Get:19 http://ppa.launchpad.net/mythbuntu/31/ubuntu focal/main i386 Packages [2,368 B]
Get:20 http://ppa.launchpad.net/mythbuntu/31/ubuntu focal/main amd64 Packages [7,084 B]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/mythbuntu/0.29/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@mythfe0:/home/wes#
BE/FE-Asrock AB350 Pro Ryzen 3 3200G, 6 atsc tuners. FE's-GF8200's Athlon II, Ryzen 3 2200G. Mythtv user since 2005.

kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Ubuntu 20.04 PPA

Post by kbocek » Mon Jul 20, 2020 8:00 pm

I'm trying. I'm really trying to upgrade to 31. It's just the CentoOS 6 host I currently have the backend on. I built this host to move mythbackend to. And then I (stupidly) upgraded it Ubuntu host to 20.04 not thinking about things. But you say 0.29 probably won't run on 20.04?

wesnewell
Senior
Posts: 672
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: Ubuntu 20.04 PPA

Post by wesnewell » Mon Jul 20, 2020 8:19 pm

I'm confused. If you are trying to upgrade to mythtv v31 on 20.04lts then all you have to do is install it. V31 is the default in the repo. From CL sudo apt-get install mythtv should install everything you need minus the plugins, which you can install later if you want them. Of course then all the remote frontends will need to be V31 too.
BE/FE-Asrock AB350 Pro Ryzen 3 3200G, 6 atsc tuners. FE's-GF8200's Athlon II, Ryzen 3 2200G. Mythtv user since 2005.

kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Ubuntu 20.04 PPA

Post by kbocek » Tue Jul 21, 2020 5:19 pm

What I want to do is move 0.29 from a CentOS 6 host to this Ubuntu host. Make sure it's all working, *then* I'll upgrade everything to 31. I see there is a process for downgrading Ubuntu. I'm going to try it.

kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Ubuntu 20.04 PPA

Post by kbocek » Tue Jul 21, 2020 6:29 pm

Well I tried to follow:
https://linuxconfig.org/how-to-downgrad ... us-version

But it didn't work. I guess I'll pull this host out of the rack and reinstall 18.04. Sigh. My endless battle trying to match Myth to the proper distro.

kbocek
Senior
Posts: 176
Joined: Mon Jul 20, 2015 4:42 pm
United States of America

Re: Ubuntu 20.04 PPA

Post by kbocek » Tue Jul 21, 2020 10:16 pm

0.29 installed fine from PPA after reinstalling Ubuntu 18.04. This is a headless server so I setup VNC. Mythtv-setup ran fine. Now I just need to move the backend.

Post Reply