DVD menus freezing in episode section since updating to v31

For discussion of topics specific to MythTV on linux
Post Reply
Robert Worrall
Newcomer
Posts: 14
Joined: Sun Jun 25, 2017 2:38 pm
Great Britain

DVD menus freezing in episode section since updating to v31

Post by Robert Worrall » Sun Mar 29, 2020 9:10 pm

Hello,

Since updating to version 31 DVDs crash at the dvd episode selection screen. The output just before crashing is:

2020-03-29 22:01:05.111062 I AFD: Opened codec 0x7f81a406d5c0, id(DVD_SUBTITLE) type(Subtitle)
2020-03-29 22:01:05.111076 I AFD: Opened codec 0x7f81a4092440, id(DVD_SUBTITLE) type(Subtitle)
2020-03-29 22:01:05.111083 I AFD: codec AC3 has 2 channels
2020-03-29 22:01:05.111315 I AFD: Opened codec 0x7f81a406ee80, id(AC3) type(Audio)
2020-03-29 22:01:09.698427 W OpenGLInterop: Not a valid hardware frame
2020-03-29 22:01:10.279233 I OpenGLInterop: Deleted 1 textures in 1 groups

is anyone else having this issue?

thanks

Rob.
:P

User avatar
mark_k
Developer
Posts: 61
Joined: Tue Jan 28, 2020 3:14 pm
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Post by mark_k » Wed Apr 15, 2020 9:18 am

Rob

I'm not seeing any crashes with DVD playback.

Can you get any more details?

Firstly a complete 'mythfrontend -v playback' log and ideally a backtrace when it crashes - are you using a packaged version or building from source? if from source, can you produce a debug build for the backtrace?

As a last resort, what DVD is it?

Thanks and regards
Mark

Robert Worrall
Newcomer
Posts: 14
Joined: Sun Jun 25, 2017 2:38 pm
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Post by Robert Worrall » Tue Apr 28, 2020 9:47 pm

Hi Mark,

It seems to happen regardless of the DVD. Running the frontend with the playback log shows a number of repeated output:

020-04-28 22:37:15.670107 I OpenGLInterop: Deleted 1 textures in 1 groups
2020-04-28 22:37:15.670435 I VDPAUInterop: Setup deinterlacer '2x VDPAU Basic'
2020-04-28 22:37:15.672483 W DVDPlayer: In DVD Menu: No video frames in queue
2020-04-28 22:37:15.682620 W DVDPlayer: In DVD Menu: No video frames in queue
2020-04-28 22:37:15.692769 W DVDPlayer: In DVD Menu: No video frames in queue
2020-04-28 22:37:15.702912 W DVDPlayer: In DVD Menu: No video frames in queue
2020-04-28 22:37:15.713046 W DVDPlayer: In DVD Menu: No video frames in queue

This prompted me to try another render than VDPAU, which has fixed the problem, weird as I haven't had an update the NVIDIA driver. I might be something to do with the plasma desktop as I am on KDE neon. However when using another rendered the playback is now slowing. I am going to have a play about with the compositor and NVIDIA settings to see if this fixes the problem. In the meantime if you have any suggestions I would be grateful for any help.

Rob.

Robert Worrall
Newcomer
Posts: 14
Joined: Sun Jun 25, 2017 2:38 pm
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Post by Robert Worrall » Tue Apr 28, 2020 10:01 pm

Sorry, Mark. I also meant to say this from the ubuntu 31 repository.

Rob.

User avatar
mark_k
Developer
Posts: 61
Joined: Tue Jan 28, 2020 3:14 pm
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Post by mark_k » Mon May 04, 2020 3:52 pm

Rob

To be clear - are you only seeing the issue with VDPAU enabled?

Can you post the full output from 'mythfrontend -v playback' from a crash?

thanks and regards
Mark

Robert Worrall
Newcomer
Posts: 14
Joined: Sun Jun 25, 2017 2:38 pm
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Post by Robert Worrall » Wed May 27, 2020 9:58 pm

Hi Mark ,

Sorry for such a delay in coming back to you. I have tried to work this out myself but to no avail. I have put the full output into a file and attached it as it is too big to paste here.

Thanks again for your help.

Rob.
Attachments
frontendoutput.txt
output from command mythfrontend -v playback | tee -a frontendoutput.txt
(142.96 KiB) Downloaded 18 times

Robert Worrall
Newcomer
Posts: 14
Joined: Sun Jun 25, 2017 2:38 pm
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Post by Robert Worrall » Wed May 27, 2020 10:09 pm

Another odd thing that is happening if I change the playback profile from VDPAU to anything else e.g 'High Quality' The audio is out of sync and playback is very slow. I have recently built a myth box for a friend and this is now doing the same regardless of setting. He does not have an nvidia GPU so can not use VDPAU. I have attached the output when using another profile any ideas what is going on.

Grateful as always.

Rob
Attachments
frontendoutput- High quality.txt
(25.19 KiB) Downloaded 15 times

blm-ubunet
Senior
Posts: 120
Joined: Sun Jun 15, 2014 1:08 am
Cambodia

Re: DVD menus freezing in episode section since updating to v31

Post by blm-ubunet » Fri May 29, 2020 1:32 am

Robert

I doubt this has any affect on your DVD playback but..
Your GT1030 is not listed (by Nvidia) as supported by the latest legacy driver 390..
Should be using 440.

Last DVD I played in MythTV was excellent (VDPAU & similar build to v0.31)

The whole linux desktop/Xorg is a train wreck.
Was better 10 years ago! Now it's all tearing & judder or a win3.1 interface.
It takes a lot of messing around to wrangle control over the compositing desktop managers in Mate/Gnome (& KDE prob.).
The unredirecting full screen is the problem.

The Nvidia driver has a setting that enables an OSD that reveals if it is using blitter (very bad for VDPAU) or overlay presentation mode.
(controlled in nvidia-settings)

User avatar
mark_k
Developer
Posts: 61
Joined: Tue Jan 28, 2020 3:14 pm
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Post by mark_k » Tue Sep 22, 2020 10:51 am

Just a heads up for anyone having DVD issues with .31 whilst using VAAPI and/or VDPAU.

A fix went in yesterday - so please update and report back if there are still issues.

Thanks and regards
Mark

Post Reply