Issues getting mythnetvision to work

For discussion of topics specific to MythTV on linux
Post Reply
pquesinb
Newcomer
Posts: 1
Joined: Sat Sep 07, 2019 8:39 pm
United States of America

Issues getting mythnetvision to work

Post by pquesinb » Sat Sep 07, 2019 9:01 pm

Hi All,

I've recently installed MythTV release 30 on Ubuntu Server 18.04.2 LTS. I'd like to try out the grabbers for PBS and other similar plugins. After goiing through the Wiki to meet all dependency requirements to get mythnetvision to run. When I launch the frontend, the extra options to search and browse internet videos are missing from the menu. Taking a closer look, I see the following error in the terminal:

Code: Select all

mythfrontend.real[8172]: mythfrontend[8172]: ! CoreContext mythcorecontext.cpp:2027 (TestPluginVersion) MythCoreContext::TestPluginVersion(): Plugin mythnetvision (30.20180319-1) binary version does not match libraries (30.20181231-1)
Any ideas on how to address this problem without having to compile everything from source? I installed the complete mythtv package the easy way, with apt.

Thanks!

- Phil

User avatar
paulh
Developer
Posts: 436
Joined: Thu Feb 06, 2014 6:09 pm
Great Britain

Re: Issues getting mythnetvision to work

Post by paulh » Sun Sep 08, 2019 12:33 pm

The version of any plugins must match the version of the core libraries. Somehow you have an older version of the MythNetVision plugin installed which doesn't match the installed libraries.

I assume you have already done the usual 'sudo apt update' and 'sudo apt upgrade' to make sure everything is up to date?

It's a good idea to use the mythbuntu fixes ppa if you aren't already at ppa:mythbuntu/30

Code: Select all

sudo add-apt-repository ppa:mythbuntu/30
sudo apt-get update

Post Reply