intermittent back end connection problem

For discussion of topics specific to MythTV on linux
Post Reply
MBEeng
Newcomer
Posts: 11
Joined: Wed Aug 30, 2017 10:21 pm
United States of America

intermittent back end connection problem

Post by MBEeng » Fri Aug 02, 2019 5:07 am

MythTV normally starts without any problems, but sometimes the front end starts, and then an error message appears saying that MythTV couldn’t connect to the master back end server. When this happens the error message will go away after a short time, then reappear. The only remedy is to turn off the MythTV computer, then restart. Often the error message will re-appear after MythTV is restarted, and it will require several restarts before MythTV starts correctly, and then behaves normally. Waiting for perhaps 15 minutes or more before attempting to restart MythTV seems to help.

Details of the system: Both back end and front end are on the same computer. The computer is running MythBuntu 0.28/ Ubuntu 14.04. Motherboard CPU/GPU AMD Zacate E35M1-M PRO. The computer connects to the internet via WiFi.

Does anybody know what might be causing this problem? Could it be due to problems timing problems for the startup due to the WiFi card having problems connecting to the WiFi network?

wesnewell
Senior
Posts: 508
Joined: Mon Jun 23, 2014 6:54 pm
Location: Wylie TX, USA
United States of America

Re: intermittent back end connection problem

Post by wesnewell » Fri Aug 02, 2019 6:03 am

AFAIK, you don't need and internet connection for mythtv to operate. Although I wouldn't rule out the system slowing down trying to get the connection.
BE/FE-Asrock AB350 Pro AMD Ryzen 3 2200G, 6 atsc tuners. Frontends-GF8200's,,AMD Athlon II's. Mythtv user since 2005.

User avatar
heyted
Senior
Posts: 100
Joined: Sun Jun 08, 2014 2:14 am
Location: South Florida
Contact:
United States of America

Re: intermittent back end connection problem

Post by heyted » Fri Aug 02, 2019 3:23 pm

Ubuntu 14.04 is a bit old. Consider installing 18.04. Is the backend and frontend set to use "localhost" and not an ip address in Setup --> General? If the frontend is automatically starting, maybe a delay could help (bash -c "sleep 20 && mythfrontend --service").
Ted | My blog

User avatar
bill6502
Developer
Posts: 1358
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: intermittent back end connection problem

Post by bill6502 » Sat Aug 03, 2019 4:05 pm

I'd try this: grep "<Host>" {~,~mythtv}/.mythtv/config.xm and expect the response
to be: <Host>localhost</Host> for both config.xml files. That will cause the backend
to use a socket, rather than a TCP connection for mysql. It's the best practice for the
backend and a combined frontend/backend.

Post Reply