Intel NUC8i7BEH; HD Homerun Quatro; linuxmint-19.2-xfce-64bit-beta; - Unable to find a free device

For discussion of topics specific to MythTV on linux
Post Reply
Compuguide
Newcomer
Posts: 2
Joined: Tue Jul 23, 2019 1:05 pm
Great Britain

Intel NUC8i7BEH; HD Homerun Quatro; linuxmint-19.2-xfce-64bit-beta; - Unable to find a free device

Post by Compuguide » Tue Jul 23, 2019 2:19 pm

When I install linuxmint-19.2-xfce-64bit-beta (or Xubuntu 18.04.02 or Ubuntu 18.04.02) onto the latest generation Intel NUC8i7BEH, the backend setup runs fine and I'm able to scan and find channels OK but further down the line MythTV fails to find the HDHomeRun Quatro with the following error in mythbackend.log
Jul 23 10:43:46 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: E CoreContext recorders/hdhrstreamhandler.cpp:386 (Connect) HDHRSH[0](12517D77): Unable to find a free device

If, however, I install Windows 10 onto the box and then run a VirtualBox VM of Ubuntu 18.04.02, mythtv finds the HDHomerun Quatro and runs perfectly
Clearly this is not ideal and I'd much prefer to run mythtv under the native linux, rather than in a VM

This seems like a kernel issue but I have no idea how to resolve it.
below is a copy of the relevant section of the mythbackend.log

Any help would be appreciated.
Thanks.

Code: Select all

Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: C thread_unknown mythcommandlineparser.cpp:2607 (ConfigureLogging) mythbackend version:  [v30.0] wwwmythtvorg
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: C thread_unknown mythcommandlineparser.cpp:2609 (ConfigureLogging) Qt version: compile: 5.9.5, runtime: 5.9.5
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: N thread_unknown mythcommandlineparser.cpp:2611 (ConfigureLogging) Enabled verbose msgs:  general
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: N thread_unknown logging.cpp:734 (logStart) Setting Log Level to LOG_INFO
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I Logger logging.cpp:296 (run) Added logging to the console
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Interrupt handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Terminated handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Segmentation fault handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Aborted handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Bus error handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Floating point exception handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Illegal instruction handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Real-time signal 0 handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Hangup handler
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: N thread_unknown mythdirs.cpp:203 (InitializeMythDirs) Using runtime prefix = /usr
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: N thread_unknown mythdirs.cpp:205 (InitializeMythDirs) Using configuration directory = /home/mythtv/.mythtv
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext mythcorecontext.cpp:272 (Init) Assumed character encoding: en_GB.UTF-8
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I LogForward loggingserver.cpp:246 (SyslogLogger) Added syslogging
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext mythcontext.cpp:641 (LoadDatabaseSettings) Empty LocalHostName. This is typical.
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext mythcontext.cpp:650 (LoadDatabaseSettings) Using a profile name of: 'pvruser-NUC8i7BEH' (Usually the same as this host's name.)
Jul 23 14:11:36 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext mythcontext.cpp:900 (TestDBconnection) Start up testing connections. DB localhost, BE , attempt 0, status dbAwake, Delay: 2000
Jul 23 14:11:37 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: N CoreContext mythcorecontext.cpp:1780 (InitLocale) Setting QT default locale to en_GB
Jul 23 14:11:37 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext mythcorecontext.cpp:1813 (SaveLocaleDefaults) Current locale en_GB
Jul 23 14:11:37 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: N CoreContext mythlocale.cpp:123 (LoadDefaultsFromXML) Reading locale defaults from /usr/share/mythtv//locales/en_gb.xml
Jul 23 14:11:37 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext mythtranslation.cpp:64 (load) Loading en_gb translation for module mythfrontend
Jul 23 14:11:37 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext schemawizard.cpp:120 (Compare) Current MythTV Schema Version (DBSchemaVer): 1350
Jul 23 14:11:37 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext mythtranslation.cpp:64 (load) Loading en_gb translation for module mythfrontend
Jul 23 14:11:37 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: N CoreContext main_helpers.cpp:605 (run_backend) MythBackend: Starting up as the master server.
Jul 23 14:11:38 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: I CoreContext recorders/hdhrstreamhandler.cpp:378 (Connect) HDHRSH[0](12517D77): Added 0 devices from 12517D77
Jul 23 14:11:38 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: E CoreContext recorders/hdhrstreamhandler.cpp:386 (Connect) HDHRSH[0](12517D77): Unable to find a free device
Jul 23 14:11:38 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: E CoreContext recorders/channelbase.cpp:796 (CreateChannel) ChannelBase: CreateChannel() Error: Failed to open device 12517D77
Jul 23 14:11:38 pvruser-NUC8i7BEH mythbackend: mythbackend[955]: E CoreContext main_helpers.cpp:205 (setupTVs) Problem with capture cards. Card 1 failed init

MikeB2013
Senior
Posts: 422
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: Intel NUC8i7BEH; HD Homerun Quatro; linuxmint-19.2-xfce-64bit-beta; - Unable to find a free device

Post by MikeB2013 » Tue Jul 23, 2019 5:01 pm

Disclosure: I don't have any HD Homeruns, but I do have other network tuners (VBOX).

Can you clarify the statement "but further down the line MythTV fails to find the HDHomeRun Quatro ...", was this after a reboot of the linux system or directly after using mythtv-setup ?

If it was after a reboot, it is likely that mythbackend started up before networking was fully available (up).
This is a common problem, a quick test to see if you have this problem is to run in terminal session :

Code: Select all

sudo systemctl daemon-reload   
sudo systemctl restart mythtv-backend
The sudo systemctl daemon-reload may not be necessary, but will do no harm.
For the solution see thread https://lists.gt.net/mythtv/users/625986#625986
Mike

Compuguide
Newcomer
Posts: 2
Joined: Tue Jul 23, 2019 1:05 pm
Great Britain

Re: Intel NUC8i7BEH; HD Homerun Quatro; linuxmint-19.2-xfce-64bit-beta; - Unable to find a free device

Post by Compuguide » Wed Jul 24, 2019 8:02 am

MikeB2013 wrote:
Tue Jul 23, 2019 5:01 pm
Can you clarify the statement "but further down the line MythTV fails to find the HDHomeRun Quatro ...", was this after a reboot of the linux system or directly after using mythtv-setup ?

If it was after a reboot, it is likely that mythbackend started up before networking was fully available (up).
This is a common problem, a quick test to see if you have this problem is to run in terminal session :

Code: Select all

sudo systemctl daemon-reload   
sudo systemctl restart mythtv-backend
The sudo systemctl daemon-reload may not be necessary, but will do no harm.
For the solution see thread https://lists. gt. net/mythtv/users/625986#625986
Mike
Brilliant!
Thanks for that advice, and sorry for the vagueness in my "further down the line MythTV fails" comment.
I tried restarting the mythtv backend and it resolved the problem.
So I will now proceed with implementing the instructions you referenced to test the Ethernet interface.
Thanks again!

Post Reply