Page 1 of 1

0.29 on Centos 6

Posted: Tue Jan 15, 2019 5:09 pm
by kbocek
So it's time to upgrade my setup from 0.24.

Can the 0.29 *backend only* run on Centos 6? I know the usual dance regarding QT. Looks like QT 5.1 is possible on Centos 6.

What about packages? There was a user who replaced ATRPMS and was compiling the current version for Centos 6 but I can't remember where they were. Anyone know?

Thanks.

Re: 0.29 on Centos 6

Posted: Wed Jan 16, 2019 8:20 pm
by bill6502
The project has buildbots that compile master and v30 and Centos 7.
None for v29.

Note that v30 was released on 2019-01-14. Maybe some other Centos
user will chime in re Centos 6.

Re: 0.29 on Centos 6

Posted: Thu Jan 17, 2019 2:01 pm
by Gribnif
I have to ask: why not upgrade to CentOS 7? I use 7 on my backend and five of my frontends, and the upgrade from 6 wasn't too bad.

Re: 0.29 on Centos 6

Posted: Fri Jan 18, 2019 5:30 pm
by kbocek
I've gotten to love CentOS 7. But the host running my backend is CentOS 6 and it's also hosting other services. I am not looking forward to installing 7 and then fixing all the services. Doable, but a multi-hour chore.

BTW the collection I was talking about is SCrpms:

http://scrpms.net/pub/

Stephen Collier has compiled 0.29 for CentOS 6. Regarding 30, he doesn't have it yet. Are we getting rid of the dot versioning? Is it 30 and not .30 now?

Stephen does stuff here:

https://groups.google.com/forum/#!forum/scrpms-users

Re: 0.29 on Centos 6

Posted: Fri Jan 18, 2019 5:44 pm
by bill6502
Yes, v30 is correct. Currently, and more specifically, the git tag is: v30.0
and the branch is: fixes/30

Re: 0.29 on Centos 6

Posted: Thu Jan 24, 2019 8:36 pm
by kbocek
BTW Stephen Collier has posted builds for V30. Including for CentOS 6.