"ALSA: Try to manually increase audio buffer" causing delays

For discussion of topics specific to MythTV on linux
Post Reply
Posts: 1
Joined: Tue Aug 30, 2016 9:23 pm
United States of America

"ALSA: Try to manually increase audio buffer" causing delays

Post by cedyathome » Wed May 02, 2018 7:43 pm

It takes a few seconds - sometimes as much a 5 - to play a recorded show on my mythtv .29

Looking though the frontend log, I find that it stalls here:

May 2 10:36:50 *****-HTPC mythfrontend.real: mythfrontend[1673]: W CoreContext audio/audiooutputalsa.cpp:243 (IncPreallocBufferSize) ALSA: Try to manually increase audio buffer with: echo 192 | sudo tee /proc/asound/card1/pcm7p/sub0/prealloc

Why is this happening every time? Is there something I can do to get around it?

So far, I've tried changing the audio output from DEV:0 Card 3 (or something like that) to ALSA:Default.
Playback will sometimes (maybe once every few days) stall for a few seconds and continue, but audio works fine.

I've been running mythtv on this computer since 2010, so the hardware is a bit old, but I can't see any memory swapping taking place (I have 2GB) and CPU usage stays low.

User avatar
Steve Goodey
Posts: 107
Joined: Fri Feb 07, 2014 6:30 pm
Location: Colchester, England
Great Britain

Re: "ALSA: Try to manually increase audio buffer" causing delays

Post by Steve Goodey » Thu May 03, 2018 8:42 am

I'm not sure if this error message is anything to worry about. I had the same on my system but was not causing a problem that I could see.

Have you tried doing what it says? i.e.

in a terminal window echo 192 | sudo tee /proc/asound/card1/pcm7p/sub0/prealloc

Would probably have to do it as su.

Post Reply