Unable to launch backend service

For discussion of topics specific to MythTV on linux
Post Reply
abhishikthaharsha
Newcomer
Posts: 1
Joined: Mon Apr 16, 2018 6:52 am
India

Unable to launch backend service

Post by abhishikthaharsha » Mon Apr 16, 2018 7:19 am

Hi There,

I have followed the mythtv wiki page for installing the mythtv from source and setup the DB and configured the mythtv-setup with Demo Source as I do not have tuner. When I am launching the backend service it is not running and getting the error as in the log below. Attaching the DB dump if needed. Please help me in proceeding further.



2018-04-16 02:03:41.409009 C mythbackend version: fixes/29 [v29.1-12-g60e40b3]
2018-04-16 02:03:41.409018 C Qt version: compile: 5.5.1, runtime: 5.5.1
2018-04-16 02:03:41.409020 N Enabled verbose msgs: general
2018-04-16 02:03:41.409025 N Setting Log Level to LOG_INFO
2018-04-16 02:03:41.419532 I Added logging to the console
2018-04-16 02:03:41.419702 I Setup Interrupt handler
2018-04-16 02:03:41.419708 I Setup Terminated handler
2018-04-16 02:03:41.419712 I Setup Segmentation fault handler
2018-04-16 02:03:41.419715 I Setup Aborted handler
2018-04-16 02:03:41.419718 I Setup Bus error handler
2018-04-16 02:03:41.419721 I Setup Floating point exception handler
2018-04-16 02:03:41.419724 I Setup Illegal instruction handler
2018-04-16 02:03:41.419729 I Setup Real-time signal 0 handler
2018-04-16 02:03:41.419732 I Setup Hangup handler
2018-04-16 02:03:41.419806 N Using runtime prefix = /usr/local
2018-04-16 02:03:41.419808 N Using configuration directory = /home/gaian/.mythtv
2018-04-16 02:03:41.419841 I Assumed character encoding: en_IN
2018-04-16 02:03:41.419844 W This application expects to be running a locale that specifies a UTF-8 codeset, and many features may behave improperly with your current language settings. Please set the LC_ALL or LC_CTYPE, and LANG variable(s) in the environment in which this program is executed to include a UTF-8 codeset (such as 'en_US.UTF-8').
2018-04-16 02:03:41.420007 N Empty LocalHostName.
2018-04-16 02:03:41.420013 I Using localhost value of gaian-nuc
2018-04-16 02:03:41.420036 I Start up testing connections. DB localhost, BE , attempt 0, status dbAwake
2018-04-16 02:03:42.435391 N Setting QT default locale to en_IN
2018-04-16 02:03:42.435410 I Current locale en_IN
2018-04-16 02:03:42.435473 E No locale defaults file for en_IN, skipping
2018-04-16 02:03:42.436690 I Loading en_us translation for module mythfrontend
2018-04-16 02:03:42.450300 I Current MythTV Schema Version (DBSchemaVer): 1348
2018-04-16 02:03:42.450426 I Loading en_us translation for module mythfrontend
2018-04-16 02:03:42.450695 N MythBackend: Starting up as the master server.
2018-04-16 02:03:42.452006 E TVRec[1]: Problem finding starting channel, setting to default of '3'.
2018-04-16 02:03:42.455265 E Scheduler: No channel sources defined in the database
Attachments
mythconvergdbdump.txt
(105.47 KiB) Downloaded 27 times

User avatar
pgbennett
Developer
Posts: 321
Joined: Mon Apr 27, 2015 5:41 pm
United States of America

Re: Unable to launch backend service

Post by pgbennett » Mon Apr 16, 2018 2:05 pm

I suggest you add a demo or import capture card, then add a demo video source. In the demo source specify "no grabber". Then add an input connection to connect the source to the tuner. Also add a channel to the source. Give the channel any number and any name. After this you should be able to start the backend.

Post Reply