Ubuntu 16.04 QT 5.6.3 Mythtv fixes/29 issues

For discussion of topics specific to MythTV on linux
Post Reply
jester13rok
Newcomer
Posts: 2
Joined: Sun Nov 26, 2017 9:34 pm
United States of America

Ubuntu 16.04 QT 5.6.3 Mythtv fixes/29 issues

Post by jester13rok » Sun Nov 26, 2017 9:53 pm

I'm running into several issues with this build, it seems that there are issues with QT5WebKit, I've commented out configure:

diff --git a/mythtv/configure b/mythtv/configure
+# if $(pkg-config --exists Qt5WebKit) || $(pkg-config --exists QtWebKit) ; then
+# enable qtwebkit
+# else
+# check_ecxx ${qt_inc} ${qt_inc}/QtCore <<EOF && enable qtwebkit
+# #include <QtWebKit/QtWebKit>
+# int main(void){ return 0; }
+# EOF
+# fi
+
+# enabled qtwebkit || die "Error! QtWebkit headers not found"

and get past the error, but then get linker errors in building mythavtest, it doesn't like references in libs/libmyth-29... when building mythavtest: (i had to omit the so libaries, the forum bot complains about them thinking is a url
<BUNCH OF ERRORS THIS IS ONLY THE END SNIPPET>
undefined reference to `QLabel::focusInEvent(QFocusEvent*)@Qt_5'
undefined reference to `QAbstractSpinBox::inputMethodQuery(Qt::InputMethodQuery) const@Qt_5'
undefined reference to `QDesktopWidget::primaryScreen() const@Qt_5'
undefined reference to `QSqlQuery::bindValue(QString const&, QVariant const&, QFlags<QSql::ParamTypeFlag>)@Qt_5'
undefined reference to `QDomElement::text() const@Qt_5'
undefined reference to `QChar::toLower(unsigned int)@Qt_5'
undefined reference to `QAbstractSocket::waitForReadyRead(int)@Qt_5'
collect2: error: ld returned 1 exit status
Makefile:204: recipe for target 'mythavtest' failed
make: *** [mythavtest] Error 1

any suggestions, I was able to successfully build fixes/28, but had issues with QT swap buffers in the mythfrontend running.

I built QT using their run script:
qt-opensource-linux-x64-5.6.3.run

Here is my config call:
./configure --prefix=/usr/local/mythtv29 --qmake=/usr/local/Qt5.6.3/5.6.3/gcc_64/bin/qmake

User avatar
bill6502
Developer
Posts: 1374
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: Ubuntu 16.04 QT 5.6.3 Mythtv fixes/29 issues

Post by bill6502 » Sun Nov 26, 2017 11:20 pm

Hi,

Been building on *buntu for years, you shouldn't need to edit configure
(works on 14.04 through 17.10.)

Do you have things like: qtdeclarative5-dev libqt5webkit5-dev libqt5opengl5-dev qtscript5-dev qt5-qmake

See this if you haven't: https://www.mythtv.org/wiki/Build_from_ ... th_Ansible
Click on Expand to see what's needed.

jester13rok
Newcomer
Posts: 2
Joined: Sun Nov 26, 2017 9:34 pm
United States of America

Re: Ubuntu 16.04 QT 5.6.3 Mythtv fixes/29 issues

Post by jester13rok » Mon Nov 27, 2017 1:15 am

I wanted to say thanks, I saw the ansible link, but I'm old school and thought I could get it working, used ansible and it looks like it is building with qt 5.6.3, now hopefully I don't get any qt errors when trying to display on mythtv front end, Haven't build mythtv since 2009.

Post Reply