Page 1 of 1

MythTV Gives Segmentation Fault

Posted: Sat Aug 29, 2020 4:58 pm
by jjthomas
I had it running but then I got the white box. I installed the Nvidia drivers, rebooted and now when I run mythtv-setup I get the following error:

Code: Select all

2020-08-29 09:45:53.554863 I  Using Frameless Window
2020-08-29 09:45:53.554895 I  Using Full Screen Window
2020-08-29 09:45:53.586231 I  UI Screen Resolution: 1600 x 1200
2020-08-29 09:45:53.593462 W  OpenGL: Could not determine whether Sync to VBlank is enabled.
Handling Segmentation fault
Segmentation fault (core dumped)
jjthomas@anthem:~ $ kldstat
Id Refs Address                Size Name
 1   24 0xffffffff80200000  2272390 kernel
 2    1 0xffffffff82473000   3b9450 zfs.ko
 3    2 0xffffffff8282d000     a448 opensolaris.ko
 4    1 0xffffffff82b21000     1860 uhid.ko
 5    1 0xffffffff82b23000     1a40 wmt.ko
 6    1 0xffffffff82b25000     2908 ums.ko
 7    1 0xffffffff82b28000      acf mac_ntpd.ko
jjthomas@anthem:~ $ uname -a
FreeBSD 12.1-STABLE FreeBSD 12.1-STABLE r364392 GENERIC  amd64
jjthomas@anthem:~ $ 
Prior to installing the nvidia driver, it was working fine, sans the whitebox error. I do have a ZFS backup that I can restore, if necessary, although I would prefer not to. Google did not help... I'm attaching a zip file of my session.

Any ideas?

Thank you.


Re: MythTV Gives Segmentation Fault

Posted: Mon Aug 31, 2020 3:30 am
by jjthomas
I recovered the ZFS backup and I got the same error. So I will reinstall and leave Nvidia out of the mix. I may have taken the snapshot after I installed Nvidia. :(