MythWeb problems under Yosemite [They're Back!!]

For discussion of topics specific to MythTV on OSX
tvdave
Junior
Posts: 57
Joined: Sun Jun 29, 2014 10:11 am
Australia

Re: MythWeb problems under Yosemite [They're Back!!]

Post by tvdave » Thu Mar 19, 2015 11:58 pm

Hi Lee,

The problems sound familiar. As a work around I have disabled the firewall - as the machine is behind a NAT and firewall on a private network, the risk is contained.

Machine spec
Mac Mini 2012 - 2.5Ghz i5 processor, 4Gb RAM, 512Gb hard drive (5400RPM - mechanical) - https://support.apple.com/kb/SP659?locale=en_US

I will send you the database file a bit later (when I am home).

tvdave
Junior
Posts: 57
Joined: Sun Jun 29, 2014 10:11 am
Australia

Re: MythWeb problems under Yosemite [They're Back!!]

Post by tvdave » Sun Mar 22, 2015 7:14 am

Here is the config file. I am just wondering if I should apply your latest build with bug fixes or if there are some underlying issues which I need to address first?
Attachments
my.cnf.log
my.cnf file (renamed to allow upload)
(671 Bytes) Downloaded 24 times

User avatar
pvr4me
Senior
Posts: 627
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: MythWeb problems under Yosemite [They're Back!!]

Post by pvr4me » Sun Mar 22, 2015 2:02 pm

tvdave wrote:Here is the config file. I am just wondering if I should apply your latest build with bug fixes or if there are some underlying issues which I need to address first?
I'm not sure why you're having this issue...I'm self-taught at configuring and running mysql! I see from the database log, that sometimes your database uses '0.0.0.0' and other times reports:

Code: Select all

150317  6:11:47 [Note] Server socket created on IP: '::'.
I don't know if that's relevant to your problem or not.


Re the my.cnf file, it HAS to be at '/opt/dvr/etc/mariadb/my.cnf' or it won't be used. _Is that_ where you found it?


Finally, how does the Mac obtain an IP address? DHCP from the router? Do you have a rule so that it always gets the same IP address?

Craig
The MacPorts guy.

tvdave
Junior
Posts: 57
Joined: Sun Jun 29, 2014 10:11 am
Australia

Re: MythWeb problems under Yosemite [They're Back!!]

Post by tvdave » Sun Mar 22, 2015 9:32 pm

Yes - the config file was found where you told me and named my.cnf (I just had to rename it to put it on the board).

The machine has a fixed IP but gets the DNS via DHCP. Just looking at what you highlighted, I wonder if there is a problem with accidentally leaving IPv6 on?

I might run some tests and disable IPv6 to see what happens.

Post Reply