Updated OS X Installer - 0.27.4

For discussion of topics specific to MythTV on OSX
User avatar
pvr4me
Senior
Posts: 627
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: Updated OS X Installer - 0.27.4

Post by pvr4me » Sun Jan 25, 2015 4:38 pm

Yeah, sorry, forgot to adapt for the path the all-in-one-installer uses. That should be:

Code: Select all

sudo ls -l /opt/dvr/var/db/mariadb
Then

Code: Select all

sudo tail -n 25  "/opt/dvr/var/db/mariadb/<hostname>.local.err"
BTW, Console (wrt Myth) is just showing that you've tried to enable the backend without the database running. Launchd tries every 300 seconds to start the backend in case the database has come up in the meantime. You have a bunch of other stuff that is being killed or throttled that I've never seen before. When you said you did a "clean install", what did you mean?

Craig
The MacPorts guy.

sergea29
Junior
Posts: 34
Joined: Wed Aug 06, 2014 2:41 pm
Canada

Re: Updated OS X Installer - 0.27.4

Post by sergea29 » Sun Jan 25, 2015 6:48 pm

thanks. Here are the results:

Code: Select all

total 57400
-rw-r--r--    1 root    _mysql         0 16 Oct 20:21 .turd_mariadb-server
-rw-rw----    1 _mysql  admin          3 25 Jan 00:07 Machine.pid
-rw-rw----    1 _mysql  admin      16384 25 Jan 00:05 aria_log.00000001
-rw-rw----    1 _mysql  admin         52 25 Jan 00:05 aria_log_control
-rw-rw----    1 _mysql  admin    5242880 25 Jan 00:07 ib_logfile0
-rw-rw----    1 _mysql  admin    5242880 24 Jan 23:21 ib_logfile1
-rw-rw----    1 _mysql  admin   18874368 25 Jan 00:05 ibdata1
-rw-rw----    1 _mysql  admin       2828 25 Jan 00:07 localhost.err
drwx------   74 _mysql  admin       2516 24 Jan 23:29 mysql
drwx------  240 _mysql  admin       8160 24 Jan 23:34 mythconverg
drwx------   20 _mysql  admin        680 24 Jan 23:08 performance_schema
drwx------    2 _mysql  admin         68 24 Jan 23:08 test
I ain't getting any thing for the other command:

Code: Select all

machine:~ famille$ sudo tail -n 25  "/opt/dvr/var/db/mariadb/machine.local.err"
tail: /opt/dvr/var/db/mariadb/machine.local.err: No such file or directory
machine:~ famille$ sudo tail -n 25  "/opt/dvr/var/db/mariadb/nadiaadnsimac10.local.err"
tail: /opt/dvr/var/db/mariadb/nadiaadnsimac10.local.err: No such file or directory
machine:~ famille$ sudo tail -n 25  "/opt/dvr/var/db/mariadb/<nadiaadnsimac10>.local.err"
tail: /opt/dvr/var/db/mariadb/<nadiaadnsimac10>.local.err: No such file or directory
machine:~ famille$ sudo tail -n 25  "/opt/dvr/var/db/mariadb/<machine>.local.err"
tail: /opt/dvr/var/db/mariadb/<machine>.local.err: No such file or directory
machine:~ famille$ sudo tail -n 25  "/opt/dvr/var/db/mariadb/<hostname>.local.err"
tail: /opt/dvr/var/db/mariadb/<hostname>.local.err: No such file or directory
machine:~ famille$
I added a new SSD and reinstalled Maverick with a bootable USB.

Serge

User avatar
pvr4me
Senior
Posts: 627
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: Updated OS X Installer - 0.27.4

Post by pvr4me » Mon Jan 26, 2015 1:20 am

sergea29 wrote:thanks. Here are the results:

Code: Select all

total 57400
...
-rw-rw----    1 _mysql  admin       2828 25 Jan 00:07 localhost.err
...
I ain't getting any thing for the other command:

...
You want:

Code: Select all

sudo tail -n 25  "/opt/dvr/var/db/mariadb/localhost.err"
Craig
The MacPorts guy.

sergea29
Junior
Posts: 34
Joined: Wed Aug 06, 2014 2:41 pm
Canada

Re: Updated OS X Installer - 0.27.4

Post by sergea29 » Tue Jan 27, 2015 12:58 am

Here si the output of the command. I do not know if you see anything here?

Code: Select all

150126 10:03:12 InnoDB: Completed initialization of buffer pool
150126 10:03:13 InnoDB: highest supported file format is Barracuda.
150126 10:03:13 Percona XtraDB (http://www.percona.com) 5.5.38-MariaDB-35.2 started; log sequence number 1597945
150126 10:03:13 [Note] Server socket created on IP: '::'.
150126 10:03:13 [Note] Event Scheduler: Loaded 0 events
150126 10:03:13 [Note] /opt/dvr/lib/mariadb/bin/mysqld: ready for connections.
Version: '5.5.39-MariaDB'  socket: '/opt/dvr/var/run/mariadb/mysqld.sock'  port: 3306  Source distribution
150126 18:43:06 [Note] /opt/dvr/lib/mariadb/bin/mysqld: Normal shutdown

150126 18:43:06 [Note] Event Scheduler: Purging the queue. 0 events
150126 18:43:06  InnoDB: Starting shutdown...
150126 18:43:07  InnoDB: Shutdown completed; log sequence number 1597945
150126 18:43:07 [Note] /opt/dvr/lib/mariadb/bin/mysqld: Shutdown complete

150126 18:43:29 InnoDB: The InnoDB memory heap is disabled
150126 18:43:29 InnoDB: Mutexes and rw_locks use GCC atomic builtins
150126 18:43:29 InnoDB: Compressed tables use zlib 1.2.8
150126 18:43:30 InnoDB: Initializing buffer pool, size = 128.0M
150126 18:43:30 InnoDB: Completed initialization of buffer pool
150126 18:43:30 InnoDB: highest supported file format is Barracuda.
150126 18:43:30 Percona XtraDB (http://www.percona.com) 5.5.38-MariaDB-35.2 started; log sequence number 1597945
150126 18:43:30 [Note] Server socket created on IP: '::'.
150126 18:43:30 [Note] Event Scheduler: Loaded 0 events
150126 18:43:30 [Note] /opt/dvr/lib/mariadb/bin/mysqld: ready for connections.
Version: '5.5.39-MariaDB'  socket: '/opt/dvr/var/run/mariadb/mysqld.sock'  port: 3306  Source distribution
Serge

User avatar
pvr4me
Senior
Posts: 627
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: Updated OS X Installer - 0.27.4

Post by pvr4me » Tue Jan 27, 2015 2:27 am

The database seems to be running fine. If you use Activity Monitor, set to view All Processes, you should see mysqld.

So it appears the first 3 commands in the Database section did work, at least. What was it that made you think the database was not running?

You should be able to pick up from the fourth command:

Code: Select all

mysql -u root < /opt/dvr/share/mythtv/database/mythconverg_init.sql
http://www.mythtv.org/wiki/MacPorts#Database

If the command succeeds, you'll get no output--only errors are reported.

And then go on and load the time zone stuff. It won't hurt to do these latter commands regardless of whether they worked the first time or not.

Craig
The MacPorts guy.

sergea29
Junior
Posts: 34
Joined: Wed Aug 06, 2014 2:41 pm
Canada

Re: Updated OS X Installer - 0.27.4

Post by sergea29 » Wed Jan 28, 2015 3:48 am

Thanks Craig,

I rechecked and now mysqld is running. Is possible that restarting my computer got it running. Since my first attempt my computer was updated to 10.10.1. I completed the commands and tested live TV and it worked and copied the file in the Default folder. I then checked to do a recording but had no program info. I went back and added the XMLID info and got program info and scheduled a recording. It did not work and now live TV does not work. Here is part of the backend log for the recording that was suppose to happen fro 9-9:30.

Code: Select all

2015-01-27 20:59:00.130802 I [27604/10755] Scheduler scheduler.cpp:2140 (HandleReschedule) - Reschedule requested for PLACE PrepareToRecord
2015-01-27 20:59:00.142236 I [27604/10755] Scheduler scheduler.cpp:2253 (HandleReschedule) - Scheduled 1 items in 0.0 = 0.00 match + 0.00 check + 0.00 place
2015-01-27 20:59:02.187837 C [27604/11527] SSDP ssdp.cpp:339 (ProcessData) - SSDP Request from WAN IP address (0.0.0.0). Possible SSDP Reflection attempt. Ignoring as security risk.
2015-01-27 20:59:30.913325 I [27604/8983] TVRecEvent tv_rec.cpp:1567 (HandlePendingRecordings) - TVRec[6]: ASK_RECORDING 6 28 0 0
2015-01-27 20:59:30.913325 I [27604/9731] TVRecEvent tv_rec.cpp:1567 (HandlePendingRecordings) - TVRec[7]: ASK_RECORDING 7 28 0 0
015-01-27 21:54:27.077220 N [27604/11011] Expire autoexpire.cpp:264 (CalcParams) - AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
2015-01-27 21:54:33.778195 I [27604/8983] TVRecEvent tv_rec.cpp:1050 (HandleStateChange) - TVRec[6]: Changing from None to RecordingOnly
2015-01-27 21:54:33.778233 I [27604/8983] TVRecEvent mythdbcon.cpp:409 (PurgeIdleConnections) - New DB connection, total: 7
2015-01-27 21:54:33.779422 I [27604/8983] TVRecEvent tv_rec.cpp:3603 (TuningCheckForHWChange) - TVRec[6]: HW Tuner: 6->6
2015-01-27 21:54:34.105026 I [27604/2579] CoreContext scheduler.cpp:705 (UpdateRecStatus) - Updating status for "Schitt's Creek":"Bad Parents" on cardid 6 (Will Record => Recorder Failed)
2015-01-27 21:54:34.491297 I [27604/8983] TVRecEvent tv_rec.cpp:1050 (HandleStateChange) - TVRec[6]: Changing from RecordingOnly to None
2015-01-27 21:54:34.511326 N [27604/10755] Scheduler autoexpire.cpp:264 (CalcParams) - AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
2015-01-27 21:54:34.511445 I [27604/10755] Scheduler scheduler.cpp:2140 (HandleReschedule) - Reschedule requested for CHECK -9 2 0 UpdateRecStatus2 | Schitt's Creek | Bad Parents | Johnny and Moira attempt to get to know their children; Alexis believes that Mutt is having an affair with the mayor's wife. | EP020708650004
2015-01-27 21:54:34.526108 I [27604/10755] Scheduler scheduler.cpp:2253 (HandleReschedule) - Scheduled 0 items in 0.0 = 0.00 match + 0.00 check + 0.00 place
015-01-27 21:56:18.127787 E [27604/11267] JobQueue programinfo.cpp:2358 (GetPlaybackURL) - ProgramInfo(1061_20150128025500.mpg): GetPlaybackURL: '1061_20150128025500.mpg' should be local, but it can not be found.
2015-01-27 21:56:18.129361 E [27604/11267] JobQueue programinfo.cpp:2358 (GetPlaybackURL) - ProgramInfo(1061_20150128025500.mpg): GetPlaybackURL: '1061_20150128025500.mpg' should be local, but it can not be found.
2015-01-27 21:56:18.131449 I [27604/15623] Metadata_1 jobqueue.cpp:2156 (DoMetadataLookupThread) - JobQueue: Metadata Lookup Starting for "Schitt's Creek":"Bad Parents" recorded from channel 1061 at 2015-01-28T02:55:00Z
Any clue?

Serge

User avatar
pvr4me
Senior
Posts: 627
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: Updated OS X Installer - 0.27.4

Post by pvr4me » Wed Jan 28, 2015 2:56 pm

sergea29 wrote:I ... scheduled a recording. It did not work and now live TV does not work. Here is part of the backend log for the recording that was suppose to happen fro 9-9:30.
First, you are running with "Max required Free Space: 1.0 GB"--I think this is too small. Do you have a separate disk for recording storage? I would leave at least 4 gigs free in that case; I have a dedicated 2TB drive and leave 12 GB free. If you are recording on your boot drive...that's a bad idea. If you are still going to do it, you need to leave a LOT more free space (20 GB?).

The log shows the recording failed but there is not much context. You are using the HDHomerun Plus, right? And did the setup as if it were an HDHomerun Dual, right? If you are using transcoding in the Plus, you must set the number of virtual tuners to 1 for each of the physical tuners.

Please do another test. Stop the backend and then restart it so we get a new log file. Immediately schedule a recording. If it fails, stop the backend again and attach the whole backend log to your next posting.

Craig
The MacPorts guy.

User avatar
pvr4me
Senior
Posts: 627
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: Updated OS X Installer - 0.27.4

Post by pvr4me » Wed Jan 28, 2015 3:00 pm

Oh, and please make sure to use the strongest local channel for your recording test. I believe some folks in Montreal are able to record from upstate NY broadcasters but the distance makes it challenging.
The MacPorts guy.

sergea29
Junior
Posts: 34
Joined: Wed Aug 06, 2014 2:41 pm
Canada

Re: Updated OS X Installer - 0.27.4

Post by sergea29 » Thu Jan 29, 2015 3:34 pm

Thanks Craig,

I closed the Backend and went through the setup. I changed my # of virtuel tuners to 1. Started the Backend then Frontend and disabled airplay and erevything now seems to work. I did not check to see if indeed I had transcoding on my HDHomerun Plus, but I am assuming it was and that is what fixed my problem. Later today when I have more time I will check the transcoding on my tuner. Just to check, is this enabled through my tuner's GUI or can it be defined by Mythtv. The other thing I want to make sure is that I asumed my HDHomerun plus has two tuners so I defined 0 and 1. Is this right? An odd thing I noticed though is in the frontend when check the status, there are a lot of other tuners showing up not available and the new ones are not identified as 0 and 1 but like 5 and 6. It is like if the tuners from the previous setups are still showing and my new configurtaion just adds on new ones, 5 and 6.

Another observation I made is that if I have another programme using my HDHomerun, Myth (Live TV anyways) cannot acces it.

I plan on doing alot of test and was wondering what is the easiest way to delete all thoses recording so I will not see them in Myth once I do not need them?

Finally, with regards to the WIKI, if someone goes through it carefully they shoud be ok, you have done a great job enableing rookies like me to setup Myth. Here are some comments that might help rookies like me: a confusing part is with regards to adding a password for the database. If you decide to keep that in the WIKI, instructions on how to start the server to add the passowrd would be usefull. This is where I trip up and try to start the server without any luck. Another comment would be to maybe add some links to help with the Backend setup. There is alot of informtaion in the Backend and it is easy for the user to be unsure if he is doing the right thing.

Thanks again for all the help,

Serge

User avatar
pvr4me
Senior
Posts: 627
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada
Contact:
Canada

Re: Updated OS X Installer - 0.27.4

Post by pvr4me » Thu Jan 29, 2015 4:27 pm

sergea29 wrote:I closed the Backend and went through the setup. I changed my # of virtuel tuners to 1. Started the Backend then Frontend and disabled airplay and erevything now seems to work. I did not check to see if indeed I had transcoding on my HDHomerun Plus, but I am assuming it was and that is what fixed my problem. Later today when I have more time I will check the transcoding on my tuner. Just to check, is this enabled through my tuner's GUI or can it be defined by Mythtv.

Your HDHomerun Plus has a built-in web page for setting the transcoding options (so I'm told, I don't own one).
The other thing I want to make sure is that I asumed my HDHomerun plus has two tuners so I defined 0 and 1. Is this right? An odd thing I noticed though is in the frontend when check the status, there are a lot of other tuners showing up not available and the new ones are not identified as 0 and 1 but like 5 and 6. It is like if the tuners from the previous setups are still showing and my new configurtaion just adds on new ones, 5 and 6.

In mythtv-setup there is a command to delete all existing tuners. After doing so, new tuners will be numbered starting from 0. The unavailable tuners will be a problem. Now that you know the routine, it should be easy enough to delete all and then re-add the tuners 0 and 1 for your HDHR.
Another observation I made is that if I have another programme using my HDHomerun, Myth (Live TV anyways) cannot acces it.

Yeah, don't do that. Myth expects to have sole access to the tuners. This is kind of a fundamental assumption related to the fact that Myth started with PCI tuners that could not be shared by others.
I plan on doing alot of test and was wondering what is the easiest way to delete all thoses recording so I will not see them in Myth once I do not need them?

LiveTV gets deleted automatically after a day. Check out the recording options, there may be a way to cause recordings to expire quickly. You didn't say where you are storing your recordings. DON'T let your boot disk run out of space; use the Free Space setting to reserve LOTS.
Finally, with regards to the WIKI, if someone goes through it carefully they shoud be ok, you have done a great job enableing rookies like me to setup Myth. Here are some comments that might help rookies like me: a confusing part is with regards to adding a password for the database. If you decide to keep that in the WIKI, instructions on how to start the server to add the passowrd would be usefull. This is where I trip up and try to start the server without any luck. Another comment would be to maybe add some links to help with the Backend setup. There is alot of informtaion in the Backend and it is easy for the user to be unsure if he is doing the right thing.
Yeah, the root password for the database is a perennial thorn. In many cases, setting a root password is utterly unnecessary but for some folks it will be essential. And I only know enough about MySQL to be dangerous! ;) I think I'll talk to the maintainer of the database packages on MacPorts and see if the instructions that are emitted can be made sane for our environment.

Could you be more specific about "links to help with the Backend setup"? For OS X, the only viable tuners are the SiliconDust products and we've got links to the major models. Also, I am trying to avoid the "wall-of-text" problem. The MacPorts page is already quite long and detailed and more than a few users have gone astray because they didn't read everything that is there. I've toyed with the idea of a YouTube video but it would take a lot of work to do it well. And it would only cover setting up one type of tuner and one guide source.

Oh, plus the devs are working on replacing mythtv-setup with a web-based process. Hopefully this is going to be a lot more streamlined with the esoteric setting hidden behind "Advanced" buttons.

Craig
The MacPorts guy.

sergea29
Junior
Posts: 34
Joined: Wed Aug 06, 2014 2:41 pm
Canada

Re: Updated OS X Installer - 0.27.4

Post by sergea29 » Thu Jan 29, 2015 4:46 pm

Thanks Craig, no I am not saving on the boot disk. . For deleting recordings is there any way other than expire?

For the links, I just meant similar one or ones to the ones you already have but to more delailed information on setting up the Backup such as wiki/User_Manual:Detailed_configuration_Backend.

If you need anything else let me know and I should be able to back to you later tonight.

Serge

Post Reply