Page 1 of 1

QT conflicts

Posted: Fri Mar 30, 2018 5:34 pm
by doconnor
When I try to update mythtv.28 with macports this error is generated:

:info:configure found qmake at /opt/local/libexec/qt5/bin/qmake but version failed
:info:configure got version: QMake version 3.1 Using Qt version 5.10.0 in /opt/local/libexec
/qt5/lib
:info:configure qmake for Qt5.2 or newer not found.

That version of qmake is provided by qt5-qtbase which is from Qt version 5.1 Is it safe to upgrade to qt56 or qt59 with mythtv.28? It's not clear how I would upgrade it.

Re: QT conflicts

Posted: Fri Mar 30, 2018 9:45 pm
by pvr4me
I'll have a look at this in the next few days.

Craig

Re: QT conflicts

Posted: Mon Apr 02, 2018 8:51 pm
by pvr4me
I've updated the port to include fixes up to Feb 1, 2018 which includes a fix related to the above. Please run

sudo port selfupdate
sudo port clean mythtv-core.28

and then proceed with the normal upgrade.

BTW, playback in mythfrontend (and etc) seems to be OK with Qt 5.10.1. However, there may be problems with certain of the settings pages. The arrow keys appeared to be completely non-functional on at least one page in the General settings. No time right now to test extensively. Please report if you notice problems.

Craig
(May roll back to Qt 5.6 or 5.7 ...)

Re: QT conflicts

Posted: Mon Apr 02, 2018 11:43 pm
by doconnor
It is upgraded now. Thanks.