Commercial Flagging No Longer Working

For discussion of topics specific to MythTV on OSX

Commercial Flagging No Longer Working

Postby leejk » Tue Jan 03, 2017 3:50 am

Hi,

I'm not sure when this problem started, since I've not been watching any of the recordings for the last couple of months. Commercial detection flagging is no longer working on my 0.27.4 setup. Even tho the log states that breaks were found, when I view the recording in myth frontend, there are no cuts displayed when I press the 'e' key, so it looks like it is failing to record the cutlist in the database. The last part of the mythcommflag log looks a little suspicious, but I'm not sure. I was wondering if anyone else has had problems with commercial detection since upgrading to Sierra, since I think that is my biggest change?

Code: Select all
2017-01-02 20:02:37.181178 I [11462/775] CoreContext ClassicCommDetector.cpp:367 (go) - Finding Logo
2017-01-02 20:06:07.466356 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 0% Completed @ 21.1488 fps.
2017-01-02 20:14:23.672013 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 10% Completed @ 21.16 fps.
2017-01-02 20:24:58.388776 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 20% Completed @ 19.0548 fps.
2017-01-02 20:39:33.988189 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 30% Completed @ 16.0086 fps.
2017-01-02 20:54:23.118051 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 40% Completed @ 14.9009 fps.
2017-01-02 21:08:28.680282 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 50% Completed @ 14.3432 fps.
2017-01-02 21:22:59.038914 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 60% Completed @ 14.0231 fps.
2017-01-02 21:36:50.628193 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 70% Completed @ 13.8106 fps.
2017-01-02 21:51:19.702389 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 80% Completed @ 13.6524 fps.
2017-01-02 22:05:58.164798 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 90% Completed @ 13.5147 fps.
2017-01-02 22:19:53.705412 E [11462/10243] Decoder avformatdecoder.cpp:4941 (GetFrame) - decoding error
         eno: Unknown error: 541478725 (541478725)
2017-01-02 22:19:55.861369 N [11462/775] CoreContext main.cpp:948 (FlagCommercials) - Finished, 5 break(s) found.
2017-01-02 22:19:55.890199 I [11462/775] CoreContext mythcontext.cpp:1194 (~MythContext) - Waiting for threads to exit.
leejk
Junior
 
Posts: 55
Joined: Wed Mar 18, 2015 1:51 am

Re: Commercial Flagging No Longer Working

Postby pvr4me » Tue Jan 03, 2017 2:20 pm

leejk wrote:I'm not sure when this problem started, since I've not been watching any of the recordings for the last couple of months. Commercial detection flagging is no longer working on my 0.27.4 setup. Even tho the log states that breaks were found, when I view the recording in myth frontend, there are no cuts displayed when I press the 'e' key, so it looks like it is failing to record the cutlist in the database. The last part of the mythcommflag log looks a little suspicious, but I'm not sure. I was wondering if anyone else has had problems with commercial detection since upgrading to Sierra, since I think that is my biggest change?

Code: Select all
2017-01-02 20:02:37.181178 I [11462/775] CoreContext ClassicCommDetector.cpp:367 (go) - Finding Logo
2017-01-02 20:06:07.466356 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 0% Completed @ 21.1488 fps.
2017-01-02 20:14:23.672013 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 10% Completed @ 21.16 fps.
2017-01-02 20:24:58.388776 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 20% Completed @ 19.0548 fps.
2017-01-02 20:39:33.988189 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 30% Completed @ 16.0086 fps.
2017-01-02 20:54:23.118051 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 40% Completed @ 14.9009 fps.
2017-01-02 21:08:28.680282 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 50% Completed @ 14.3432 fps.
2017-01-02 21:22:59.038914 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 60% Completed @ 14.0231 fps.
2017-01-02 21:36:50.628193 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 70% Completed @ 13.8106 fps.
2017-01-02 21:51:19.702389 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 80% Completed @ 13.6524 fps.
2017-01-02 22:05:58.164798 I [11462/775] CoreContext ClassicCommDetector.cpp:545 (go) - 90% Completed @ 13.5147 fps.
2017-01-02 22:19:53.705412 E [11462/10243] Decoder avformatdecoder.cpp:4941 (GetFrame) - decoding error
         eno: Unknown error: 541478725 (541478725)
2017-01-02 22:19:55.861369 N [11462/775] CoreContext main.cpp:948 (FlagCommercials) - Finished, 5 break(s) found.
2017-01-02 22:19:55.890199 I [11462/775] CoreContext mythcontext.cpp:1194 (~MythContext) - Waiting for threads to exit.

Commercial flagging creates a skip list. In Edit mode, you need to use "Z" to load the skip list before it can become a cut list. See:

https://www.mythtv.org/wiki/Keybindings#In_edit_mode

The 'decoding error' is common, in my experience, and just means that it hit the end of the file.

Craig
The MacPorts guy.
User avatar
Canadapvr4me
Senior
 
Posts: 464
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada

Re: Commercial Flagging No Longer Working

Postby leejk » Fri Jan 06, 2017 12:18 am

Ah OK, I didn't realize there were 2 possible types of breaks. Now I know what happened.

thx
leejk
Junior
 
Posts: 55
Joined: Wed Mar 18, 2015 1:51 am


Return to OSX



Who is online

Users browsing this forum: No registered users and 2 guests