Page 1 of 3

Hauppauge HD-PVR2 / Colossus2 support

Posted: Thu Mar 01, 2018 12:12 am
by jpoet
For those waiting for MythTV support:

https://github.com/jpoet/HauppaugeUSB

Please note: I don't read these forums very often, but I will do my best to answer questions.

John

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Sun Mar 11, 2018 11:25 pm
by gnurocks
John,

This is a game changer. Thank you, thank you, thank you. Been waiting for something to push me to Mythtv v29. Plus, I always wanted to get away from external devices like my 1212 HD-PVR and their wall wart power supplies. Just bought my Colossus 2 and a PCIE 1x riser adapter. Parts got here Friday. Can't wait to integrate.

I compiled your code and came across:

make: *** No rule to make target `-lboost_log', needed by `hauppauge2'. Stop.

Fixed the above error on Ubuntu MATE 17.10 by installing libboost-log-dev and libboost-programs-options-dev. To compile, you obviously need build-essential too. Hope this helps others.

Thanks again. Al

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Mon Mar 12, 2018 12:00 am
by jpoet
Thanks. I have updated the README with that information.

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Thu Mar 22, 2018 12:41 am
by jjis
Used the guide on Github to connect the HD PVR 2 to Linux, with trial and error have it working, can record through the terminal. Not gotten MythTV working with it yet. Terminal is fine for now.

The issue I keep having is the bitrate will not change from the default. When I used it with Windows, the default bitrate was 11mpbs. I first tried on Linux with the configuration that Hauppuge recommends. With their config the bitrate was 6, there was a settings.cfg file but changing the settings didn't help still only got 6.

Used the Github set up, finally have it all working with the terminal but still the bitrate won't change. i tried VBR and CBR, diffeerent bitrates and the video always comes with a bitrate of a little below 9. Even making all the birates in the config file blank, it still records at a little under 9.

I finally heard back from Hauppauge and they told me the bitrate cannot be changed.

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Wed Mar 28, 2018 11:32 pm
by jpoet
Hi Donald,

I don't know what to tell you. It works for me. I tried

Code: Select all

/opt/Hauppauge/bin/hauppauge2 --serial <serial> -r 15000000 -C 0 -o test.ts
and then did

Code: Select all

mediainfo test.ts
and it reports

Code: Select all

Overall bit rate                         : 15.5 Mb/s
My best guess is that it has something to do with your input.

John

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Fri Mar 30, 2018 7:49 pm
by jjis
Here is a copy of the Colossus1 conf file

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Fri Mar 30, 2018 10:38 pm
by jpoet
Hi Dennis,

I gather that you don't have any experience with configuration files of this type. The '#' in front of a line means that it is a comment. That also is used to allow option "place holders". Basically, if the starts with a '#', then that line is ignored.

If you want to change an option, and have it take effect, you need to make sure that the line does not start with a '#'.

John

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Sat Mar 31, 2018 3:57 am
by jjis
Could I have a look at your conf file, to get an idea of what I'm doing wrong.

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Sat Mar 31, 2018 8:47 pm
by gnurocks
Works for me as well. However, for my Colossus 2 connected to a set top box via component cables, I used:

Code: Select all

sudo /opt/Hauppauge/bin/hauppauge2 -s <serial number of device> -i 1 -a 0 -r 15000000 -C 0 -o /tmp/test.ts
When I did:

Code: Select all

mediainfo test.ts
I got:

Code: Select all

Overall bit rate                         : 15.9 Mb/s
Hope this helps.

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Sun Apr 01, 2018 1:06 am
by jpoet
jjis wrote:
Sat Mar 31, 2018 3:57 am
Could I have a look at your conf file, to get an idea of what I'm doing wrong.
I am just using the defaults, so my config file won't help you much. I have edited your config file to remove the '#' from the beginning of the relevant options, to activate them. Maybe this will help you.

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Tue Apr 03, 2018 12:01 pm
by jjis
Got the bitrate working correctly. Another issue as come up though, when I load the video in Avidemux it will not seek to the correct frame. Posted on Videohelp and someone there looked at a sample recording. Was told the key frames were too high.

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Thu Nov 08, 2018 6:40 pm
by atinker
Hello, I have a Hauppauge HDPVR2 model 157210. I've got this device working very well under Arch Linux with the Hauppauge testApp. My myth backend runs on Arch and I don't have a Ubuntu box ready.

In my haste I have attempted to install the wrapper on an Arch system. I installed the boost and libusb packages then used the install instructions as a guide with the exception of using hauppauge_hdpvr2_157210_patched_2016-09-26.tar.gz.

The build ends in an error which I've included below. Can someone help please?

Code: Select all

g++ -g -c -Wall -std=c++11 -fdiagnostics-color -DBOOST_LOG_DYN_LINK -pthread -m64 -g -O3 -D_GNU_SOURCE -DDRIVER_BUILD -DHAUPPAUGE -DHCW_E5BDA `pkg-config --cflags libusb-1.0` -I.. -I./Hauppauge/Common -I./Wrappers/linux -I./Hauppauge/Common/FX2API -I./Hauppauge/Common/Rx/ADV7842 -I./Hauppauge/Common/Rx/ADV7842/RX -I./Hauppauge/Common/Rx/ADV7842/RX/LIB -I./Hauppauge/Common/Rx/ADV7842/RX/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/MACROS -I./Hauppauge/Common/Rx -I./Hauppauge/Common/EncoderDev -I./Hauppauge/Common/EncoderDev/HAPIHost -I./Hauppauge/Common/EncoderDev/HAPIHost/MChip `pkg-config --cflags libusb-1.0` Logger.cpp -o Logger.o
g++ -g -c -Wall -std=c++11 -fdiagnostics-color -DBOOST_LOG_DYN_LINK -pthread -m64 -g -O3 -D_GNU_SOURCE -DDRIVER_BUILD -DHAUPPAUGE -DHCW_E5BDA `pkg-config --cflags libusb-1.0` -I.. -I./Hauppauge/Common -I./Wrappers/linux -I./Hauppauge/Common/FX2API -I./Hauppauge/Common/Rx/ADV7842 -I./Hauppauge/Common/Rx/ADV7842/RX -I./Hauppauge/Common/Rx/ADV7842/RX/LIB -I./Hauppauge/Common/Rx/ADV7842/RX/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/MACROS -I./Hauppauge/Common/Rx -I./Hauppauge/Common/EncoderDev -I./Hauppauge/Common/EncoderDev/HAPIHost -I./Hauppauge/Common/EncoderDev/HAPIHost/MChip `pkg-config --cflags libusb-1.0` Common.cpp -o Common.o
g++ -g -c -Wall -std=c++11 -fdiagnostics-color -DBOOST_LOG_DYN_LINK -pthread -m64 -g -O3 -D_GNU_SOURCE -DDRIVER_BUILD -DHAUPPAUGE -DHCW_E5BDA `pkg-config --cflags libusb-1.0` -I.. -I./Hauppauge/Common -I./Wrappers/linux -I./Hauppauge/Common/FX2API -I./Hauppauge/Common/Rx/ADV7842 -I./Hauppauge/Common/Rx/ADV7842/RX -I./Hauppauge/Common/Rx/ADV7842/RX/LIB -I./Hauppauge/Common/Rx/ADV7842/RX/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/MACROS -I./Hauppauge/Common/Rx -I./Hauppauge/Common/EncoderDev -I./Hauppauge/Common/EncoderDev/HAPIHost -I./Hauppauge/Common/EncoderDev/HAPIHost/MChip `pkg-config --cflags libusb-1.0` MythTV.cpp -o MythTV.o
g++ -g -c -Wall -std=c++11 -fdiagnostics-color -DBOOST_LOG_DYN_LINK -pthread -m64 -g -O3 -D_GNU_SOURCE -DDRIVER_BUILD -DHAUPPAUGE -DHCW_E5BDA `pkg-config --cflags libusb-1.0` -I.. -I./Hauppauge/Common -I./Wrappers/linux -I./Hauppauge/Common/FX2API -I./Hauppauge/Common/Rx/ADV7842 -I./Hauppauge/Common/Rx/ADV7842/RX -I./Hauppauge/Common/Rx/ADV7842/RX/LIB -I./Hauppauge/Common/Rx/ADV7842/RX/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/MACROS -I./Hauppauge/Common/Rx -I./Hauppauge/Common/EncoderDev -I./Hauppauge/Common/EncoderDev/HAPIHost -I./Hauppauge/Common/EncoderDev/HAPIHost/MChip `pkg-config --cflags libusb-1.0` HauppaugeDev.cpp -o HauppaugeDev.o
g++ -g -c -Wall -std=c++11 -fdiagnostics-color -DBOOST_LOG_DYN_LINK -pthread -m64 -g -O3 -D_GNU_SOURCE -DDRIVER_BUILD -DHAUPPAUGE -DHCW_E5BDA `pkg-config --cflags libusb-1.0` -I.. -I./Hauppauge/Common -I./Wrappers/linux -I./Hauppauge/Common/FX2API -I./Hauppauge/Common/Rx/ADV7842 -I./Hauppauge/Common/Rx/ADV7842/RX -I./Hauppauge/Common/Rx/ADV7842/RX/LIB -I./Hauppauge/Common/Rx/ADV7842/RX/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/HAL -I./Hauppauge/Common/Rx/ADV7842/RX/HAL/4G/ADV7842/MACROS -I./Hauppauge/Common/Rx -I./Hauppauge/Common/EncoderDev -I./Hauppauge/Common/EncoderDev/HAPIHost -I./Hauppauge/Common/EncoderDev/HAPIHost/MChip `pkg-config --cflags libusb-1.0` hauppauge2.cpp -o hauppauge2.o
g++ Logger.o Common.o MythTV.o HauppaugeDev.o hauppauge2.o -o hauppauge2 libADV7842.a -lboost_program_options -lboost_log -lboost_log_setup -lboost_system -lboost_thread -lboost_filesystem  `pkg-config --libs libusb-1.0` -lpthread 
/usr/bin/ld: libADV7842.a(FX2Device.o): in function `FX2Device_t::loadFirmware()':
/opt/hdpvr2wrapper/HauppaugeUSB/./Hauppauge/Common/FX2API/FX2Device.cpp:89: undefined reference to `FX2Device_t::m_firmwareBytesLen'
/usr/bin/ld: /opt/hdpvr2wrapper/HauppaugeUSB/./Hauppauge/Common/FX2API/FX2Device.cpp:89: undefined reference to `FX2Device_t::m_firmwareBytes'
collect2: error: ld returned 1 exit status
make: *** [Makefile:56: hauppauge2] Error 1

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Fri Nov 09, 2018 6:05 pm
by ibedonc
did you install all the dev packages ?

I have it working on Ubuntu server 18.04.1

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Fri Nov 09, 2018 7:38 pm
by atinker
Re: Hauppauge HD-PVR2 / Colossus2 support
by ibedonc » Fri Nov 09, 2018 6:05 pm

did you install all the dev packages ?

I have it working on Ubuntu server 18.04.1
Thank you ibedonc. I have updated my original post which was not clear. I will test it on an Ubuntu machine over the weekend. I would still like to get it running under Arch linux. As far as I know Arch does not have different packages for dev and runtime.

Re: Hauppauge HD-PVR2 / Colossus2 support

Posted: Sat Dec 22, 2018 10:04 pm
by jpoet
https://github.com/jpoet/HauppaugeUSB has been updated.

* Interlaced fields are now in the correct order
* AC3 via HDMI now works
* AC3 via S/PDIF and video via Component is working.