[Solved] UK FreeSAT Tuning Question...

For discussion related to MythTV which doesn't belong in another forum.

Moderator: Forum Moderators

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Wed Jan 31, 2018 7:12 pm

Hi Mike many many tx for the detailed response... I will give the alternative TBS drivers a go...

Although 1st I think I need to get my kernel up to date.... as It would seem I am stuck at:-

Code: Select all

Linux media0 4.7.2-040702-generic #201608201334 SMP Sat Aug 20 17:37:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
I was forced to load a later kernel when I installed my mythbuntu system some 12 months ago,.. as many of the core MoBo features did not work... I 'Assumed',.. as the kernel played catch up,.. it would automatically update my kernel as and when... This is clearly not the case,..

I need to get my kernel back into line...

many Tx & Rgds

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Sat Feb 03, 2018 9:50 am

Hi Mike,.. Took the hit this morning and upgraded my kernel to:-

Code: Select all

Linux media0 4.15.0-041500-generic #201802011154 SMP Thu Feb 1 11:55:45 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
So kernel, and all other things ( as far as I can see ) are up to date,.. and system boots without issue.
Of course that leaves the dvb drivers to be re-installed.... and I have duly started the process to install the 'open-source' drivers...

Everything goes ok until the 'make j4',... there are a few warning as expected,.. but the error that is created I am unable to find any reference to either on mythtv or TBS web sites....

I have installed the perl utils and some libelf-dev modules.... which has resolved quite a few of the warnings,... But I am unable to get past the error,....

Do you have any ideas as to why I may be getting this error,.. as I must confess,.. I struggle with compile errors for complex trees like this...
I have included the output of make j4 if that can help spread any light on the problem for you...

Many Tx

Mark

Code: Select all

  
  CC [M]  /home/fred/tbs_open_source_drivers/media_build/v4l/dvb_net.o
  CC [M]  /home/fred/tbs_open_source_drivers/media_build/v4l/dvb_ringbuffer.o
/home/fred/tbs_open_source_drivers/media_build/v4l/dvb_ringbuffer.c: In function 'dvb_ringbuffer_free':
/home/fred/tbs_open_source_drivers/media_build/v4l/dvb_ringbuffer.c:74:9: error: implicit declaration of function 'ACCESS_ONCE' [-Werror=implicit-function-declaration]
  free = ACCESS_ONCE(rbuf->pread) - rbuf->pwrite;
         ^
  CC [M]  /home/fred/tbs_open_source_drivers/media_build/v4l/dvb_math.o
cc1: some warnings being treated as errors
scripts/Makefile.build:316: recipe for target '/home/fred/tbs_open_source_drivers/media_build/v4l/dvb_ringbuffer.o' failed
make[3]: *** [/home/fred/tbs_open_source_drivers/media_build/v4l/dvb_ringbuffer.o] Error 1
make[3]: *** Waiting for unfinished jobs....
Makefile:1514: recipe for target '_module_/home/fred/tbs_open_source_drivers/media_build/v4l' failed
make[2]: *** [_module_/home/fred/tbs_open_source_drivers/media_build/v4l] Error 2
make[2]: Leaving directory '/usr/src/linux-headers-4.15.0-041500-generic'
Makefile:51: recipe for target 'default' failed
make[1]: *** [default] Error 2
make[1]: Leaving directory '/home/fred/tbs_open_source_drivers/media_build/v4l'
Makefile:26: recipe for target 'all' failed
make: *** [all] Error 2
Attachments
TBSmakej4log.txt
(42.76 KiB) Downloaded 29 times

MikeB2013
Senior
Posts: 427
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: UK FreeSAT Tuning Question...

Post by MikeB2013 » Sat Feb 03, 2018 11:42 am

Looks like your 4.15 kernel is too new for TBS Open Source Drivers. I just tried it on kernel 4.15 from mainline kernel repository and get the same build failure.

My fully updated 16.04 LTS system is running 4.13.0-32-generic #35~16.04.1-Ubuntu SMP Thu Jan 25 10:13:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux from ubuntu repositories.

I suggest you remove the 4.15 kernel (and associated headers) and install linux-image-generic-hwe-16.04 then try building the TBS Open Source drivers (when you cd into media_build do "make distclean" before the other commands, this cleans the build tree).

Mike

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Sat Feb 03, 2018 2:48 pm

Thanks for that Mike,.. Making progress albeit in small steps....

Have loaded kernel:-

Code: Select all

Linux mythtv0 4.13.16-041316-generic #201711240901 SMP Fri Nov 24 09:02:42 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Myth box now boots up and runs Mythtv.... as drivers seem to work,... However I am not sure the firmware is correct as I cannot view normal tv,.. essentially no signal,.. looking at the dmesg output there seems to be some conflict with firmware,.. but I am not sure how to resolve this... I have downloaded the firmware as per web site and extracted as follows

Code: Select all

unzip -p tbs-linux-drivers_v130901.zip linux-tbs-drivers.tar.bz2 | tar jxOf - linux-tbs-drivers/v4l/tbs6981fe_driver.o.x86_64 | dd bs=1 skip=10144 count=55486 of=dvb-fe-cx24117.fw
This is a snippet of the dmesg output,.. inferring something is not right with the firmware it is trying to use... Any thoughts gratefully received..

Many thanks..

Mk

Code: Select all

[Sat Feb  3 14:22:17 2018] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[Sat Feb  3 14:22:17 2018] i2c i2c-13: av201x: Airoha Technology AV201x successfully attached
[Sat Feb  3 14:22:17 2018] SAA716x Budget 0000:06:00.0: TurboSight TBS 6982SE  MAC=00:22:ab:f0:77:55
[Sat Feb  3 14:22:17 2018] SAA716x Budget 0000:06:00.0: DVB: registering adapter 1 frontend 0 (TurboSight TBS 6982SE DVB-S/S2)...
[Sat Feb  3 14:22:17 2018] EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: (null)
[Sat Feb  3 14:22:17 2018] dvbdev: DVB: registering new adapter (SAA716x dvb adapter)
[Sat Feb  3 14:22:17 2018] i2c i2c-15: Added multiplexed i2c bus 16
[Sat Feb  3 14:22:17 2018] si2168 15-0064: Silicon Labs Si2168-B40 successfully identified
[Sat Feb  3 14:22:17 2018] si2168 15-0064: firmware version: B 4.0.2
[Sat Feb  3 14:22:17 2018] si2157 16-0062: Silicon Labs Si2147/2148/2157/2158 successfully attached
[Sat Feb  3 14:22:17 2018] SAA716x Budget 0000:09:00.0: TurboSight TBS 6285  MAC[0]=ff:ff:ff:ff:ff:ff
[Sat Feb  3 14:22:17 2018] SAA716x Budget 0000:09:00.0: DVB: registering adapter 2 frontend 0 (TurboSight TBS 6285 DVB-T/T2/C)...
[Sat Feb  3 14:22:17 2018] dvbdev: DVB: registering new adapter (SAA716x dvb adapter)
[Sat Feb  3 14:22:17 2018] i2c i2c-15: Added multiplexed i2c bus 17
[Sat Feb  3 14:22:17 2018] si2168 15-0066: Silicon Labs Si2168-B40 successfully identified
[Sat Feb  3 14:22:17 2018] si2168 15-0066: firmware version: B 4.0.2
[Sat Feb  3 14:22:17 2018] si2157 17-0060: Silicon Labs Si2147/2148/2157/2158 successfully attached
.......
[Sat Feb  3 14:24:38 2018] si2157 16-0062: Direct firmware load for dvb-tuner-si2158-a20-01.fw failed with error -2
[Sat Feb  3 14:24:38 2018] si2157 16-0062: firmware file 'dvb-tuner-si2158-a20-01.fw' not found
[Sat Feb  3 14:24:38 2018] si2168 15-0064: Direct firmware load for dvb-demod-si2168-02.fw failed with error -2
[Sat Feb  3 14:24:38 2018] si2168 15-0064: Direct firmware load for dvb-demod-si2168-02.fw failed with error -2
[Sat Feb  3 14:24:38 2018] si2168 15-0064: firmware file 'dvb-demod-si2168-02.fw' not found
[Sat Feb  3 14:24:38 2018] si2157 16-0062: found a 'Silicon Labs Si2158-A20'
[Sat Feb  3 14:24:38 2018] si2157 16-0062: Direct firmware load for dvb-tuner-si2158-a20-01.fw failed with error -2
[Sat Feb  3 14:24:38 2018] si2157 16-0062: firmware file 'dvb-tuner-si2158-a20-01.fw' not found
[Sat Feb  3 14:24:38 2018] si2168 15-0064: Direct firmware load for dvb-demod-si2168-02.fw failed with error -2
[Sat Feb  3 14:24:38 2018] si2168 15-0064: Direct firmware load for dvb-demod-si2168-02.fw failed with error -2
[Sat Feb  3 14:24:38 2018] si2168 15-0064: firmware file 'dvb-demod-si2168-02.fw' not found
[Sat Feb  3 14:24:38 2018] si2157 16-0062: found a 'Silicon Labs Si2158-A20'




MikeB2013
Senior
Posts: 427
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: UK FreeSAT Tuning Question...

Post by MikeB2013 » Sat Feb 03, 2018 4:55 pm

Whoops!

I forgot to mention TBS firmware package Install instructions are at https://github.com/tbsdtv/linux_media/wiki

You should reboot after installing the firmware, most firmware loads are done during boot, there are some exceptions, but it is safer to reboot.

Mike

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Sat Feb 03, 2018 6:03 pm

Hi Mike Tried a few more things,.. which all proved a little fruitless...

In Desperation tried a cold restart,.. ( proper switch off ).. and it now seems to work... Ahhhhhh

Just need to see if my tuning data still holds... as I did a retune along the way...
.... Tuning still fails... Mux's show as undefind.. humm more head scratching,... do I need to delete cards and start retune again..

MikeB2013
Senior
Posts: 427
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: UK FreeSAT Tuning Question...

Post by MikeB2013 » Sat Feb 03, 2018 6:18 pm

There is a possibility that the order of cards detected at startup has changed, so what mythtv thought was a DVB-T/T2 card is now a DVB-S/S2 card. This is a fairly common problem with more than one tuner card, I have had this problem a few times. The order of card detection is not guaranteed between reboots (sometimes it works, other times it changes, as during boot there are many things running in parallel).

The output of dmesg | grep frontend will list the cards in order of detection.

You don't normally need to rescan/retune , just "delete all capture cards" (not delete all capture cards on <hostname>) and add them in again. Then use Input Connections to setup the correct Video Source and the other required settings. The actual tuning data is associated with Video Source, not the actual tuner cards.

Don't understand why this would impact accessing existing recordings.

Mike

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Sat Feb 03, 2018 7:49 pm

Mike just a quick update for today's activity,... Did a cold restart,.. and that did fix some initial issues,.. even though mysql,. and myth-backend were running OK,.. the previous recordings did not show up,.. yes strange,... But seems ok for now as watching some previously recorded stuff..
For now,.. I think,.. the order seems to be good,.. but I think there are some tuning funnies,.. Having said that its now recording,.. ( so the 'heat is off' ),.. but I will play further either tomorrow or Monday now...

BTW does the IR driver stuff get compiled in,.. as remote does not work,.. ( have not done any digging yet on this ).

'tuning data is associated with Video Source',.. that's a useful little nugget of info,... tx again,...rgds

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Tue Feb 06, 2018 9:18 am

Hi Mike,.. ( thankyou for your support so far) took the approach this morning to 'start again'.... re-complied from scratch,.. cleaned out old drivers... reloaded firmware files,.. and deleted all FreeView Tuning data, inc. mux's.
Did a mux frequency rescan,.. and although 730Mhz finds channels,.. 762Mhz fails,... failing to actually get a lock.
One thing I have noticed is signal strength is on 56%,.. where as before I'm sure it was in the 99% area for my freeview channels... Not sure if this means anything.
I can see nothing in dmesg output,. although lots of downloading firmware at the end... is this as it take so long?? . but have included just in case useful, as well as as a snip from syslog... as the TBS drivers load.
Do you have any thoughts,.. as I am now beginning to struggle,.. as it might seem it 'should' work......
Attachments
syslog-snip.txt
(4.9 KiB) Downloaded 21 times
dmesg.txt
(85.23 KiB) Downloaded 20 times

MikeB2013
Senior
Posts: 427
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: UK FreeSAT Tuning Question...

Post by MikeB2013 » Tue Feb 06, 2018 7:31 pm

Nothing stands out to me in those attachments.

Don't know why it is downloading firmware so many times, but I have a Hauppauge QuadHD (DVB-T/T2) pcie tuner card which uses Si2168 but with cx23885 driver and also downloads the firmware many times but it works!

The signal strength at 56% may or may not be on the low side, but if you thought was around 99% on a previous occasion, it might be worthwhile checking the connections to the card (I presume you are using an F-connector adapter to standard UK antenna connection) . I thought at one point you had managed to scan all desired DVB-T/T2 muxes ?

There was an old problem with having more than one type of TBS card installed see https://freetoairamerica.wordpress.com/ ... your-irqs/

Can you provide the outputs from the following two command in a terminal:
cat /proc/interrupts
lsmod


Mike

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Tue Feb 06, 2018 9:00 pm

Mike output attached,..
Your comments on signal strength had crossed my mind,.. but the Media box had not been touched,.. but as I'm sure you know that is an 'assumption',... I will check...and yes I use f-connectors to standard (old) UHF connections...

Yes I did manage to scan all mux's,.. Freeview was perfect,.. ( well the best its been for a long time) ,.. then I upgraded the kernel,.. and updated the drivers and it sort of all went pear shaped,...

Is there some funny with the kernel here,.. I was on 'stuck' on 4.7,... because the i915 chips set did not work with the initial mythbuntu release of some 12+months ago,. ( when I built the system).

Many tx.
K.R.
Attachments
lsmod-int.txt
(6.42 KiB) Downloaded 18 times

MikeB2013
Senior
Posts: 427
Joined: Mon Jul 25, 2016 4:16 pm
Great Britain

Re: UK FreeSAT Tuning Question...

Post by MikeB2013 » Wed Feb 07, 2018 8:54 am

Those interrupts look fine, both using MSI.

I really don't know what to suggest next.

I suppose you could try going back to your original configuration (try first with the TBS Open Source drivers, falling back to the TBS Closed Source drivers if necessary) at least it should solve your Freeview issues, but that still leaves the missing Pick TV and other channels on Freesat.

Mike

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Sat Feb 10, 2018 8:43 pm

Hi Mike,..
After initially not getting very far with the open source drivers with my 28 system,.. I decided to 'bite the bullet' and build a 29 system,.. ( I just happen to have a spare SSD for just such occasions ).
Backed up database,.. and proceeded to build a new 29 system.. complied in open drivers... ( I did stumble across some funnies with PATH,.. with my new system looking for myth-backend in /usr/bin rather than /usr/local/bin... but this was my error for copying over my old systemd-system file...

The official 170330 TBS drivers,.. just fail to compile with kernel 4.13.. Fortunately the open source drivers compile with 4.13,.. ( But not the current 4.15.. ).

Initially things did not run/tune, even with the open source diver,.. However after some patience and use of more settings ( this was key!! ) in the Mux tuning fields ( 'auto' is just not good enough ),.. things did 'lock',.. and bring in missing channels.

And The big one,.... No Pick TV+1 with SAT,.. I did a full channel scan on the SAT Tuner,.. and this time ( for the first time ) gave me in excess of 900 channels,... including Pick+1, and many more unseen channels,... whoopi!!!!! I have never seen this many channels before on a SAT tune...

I have still to resolve my remote control,.. as I do not seem to have installed the IR driver that enable the chipset on the TBS card,..
Still WIP,.. but much closer than I was...

many tx for your help,.. I will update as this develop

User avatar
stuarta
Developer
Posts: 198
Joined: Wed Feb 05, 2014 5:13 pm
Great Britain

Re: UK FreeSAT Tuning Question...

Post by stuarta » Tue Feb 20, 2018 11:28 am

There is a known issue which I haven't had a chance to look into yet, but for certain muxes
the channels are correctly detected as DVB, and then redetected as SCTE channels.

This certainly affects 5HD, and I believe that Pick is also affected.

Regards
Stuart

User avatar
diyhouse
Senior
Posts: 201
Joined: Mon Mar 31, 2014 9:42 am
Great Britain

Re: UK FreeSAT Tuning Question...

Post by diyhouse » Thu Feb 22, 2018 12:26 pm

That's interesting know,.. Tx for the comment Stuart,..

Pretty much got my system all back up and running on xubuntu 16.04,.. and configured the odds-n-sods backend stuff,.. that mythbuntu did for a user,.. (and I like many took for granted... ).
Haven't yet managed to sort IR controller,.. but have purchased one of those mickey mouse wireless keyboards (palm sized) in the mean time,.. yes build quality not fantastic,.. but for £10,.. great value,. and they work a treat.
But a lot learnt,.. and my knowledge is the richer for it... Tx to folks

Post Reply