[SOLVED] Metadata lookup fails in 0.29 on 16.04

For discussion related to MythTV which doesn't belong in another forum.

Moderator: Forum Moderators

User avatar
keepitsimpleengineer
Junior
Posts: 18
Joined: Fri Oct 03, 2014 9:53 pm
Location: Central California, U.S.A.
Contact:
United States of America

Re: [SOLVED] Metadata lookup fails in 0.29 on 16.04

Post by keepitsimpleengineer » Wed Sep 20, 2017 7:25 pm

mrkstate wrote:So - for those of us - still struggling to get this resolved - and who are not going thru a re-build of the set up...

Looking to solve our issues - as it seems to be a change in a configuration somewhere due to the upgrade ...
I really have no clue as to what happened. I reran this and there was no change..?

Code: Select all

root@KISE-055:/# find / -name '*tvdb_api*'
/usr/lib/python2.7/dist-packages/MythTV/ttvdb/tvdb_api.py.old
/usr/lib/python2.7/dist-packages/MythTV/ttvdb/tvdb_api.pyc
/usr/lib/python2.7/dist-packages/MythTV/ttvdb/tvdb_api.py
/usr/lib/python2.7/dist-packages/MythTV/ttvdb/tvdb_api.pyc.off
/home/mythtv/.mythtv/cache/tvdb_api
/home/mythtv/.mythtv/cache/tvdb_api/tvdb_api.sqlite
/home/ljohnson/.mythtv/cache/tvdb_api
/home/ljohnson/.mythtv/cache/tvdb_api/tvdb_api.sqlite
And by
3rd Tuner card was not fully functional thereafter so I re-downloaded the firmware and redid the setup, which included video sources.
Redoing the set up including using mysql to drop tables per "Fixing Capture Card Setup Errors" ☛ https://help.ubuntu.com/community/MythT ... g_settings and then "Setup Capture Cards" ☛ https://www.mythtv.org/wiki/Setup_Captu ... tuner_card

I should note that this was originally a mythbuntu installation and there .mythbuntu directories which are apparently no longer in use.

I addition I got caught by the move to systemd, inadvertently running two mythbackends simultaneously. There is ☛ https://www.mythtv.org/wiki/Systemd_myt ... figuration as 'mythbackend.service' and not mentioned anywhere I could find that 0.29 comes with it's own 'mythtv-backend.service' in '/lib/systemd/system/' which gave me fits, checking with 'sudo systemctl status myth*' revealed that two mythbackends running simultaneously.

Hope this is helpful... .. .

User avatar
bill6502
Developer
Posts: 1289
Joined: Fri Feb 07, 2014 5:28 pm
United States of America

Re: [SOLVED] Metadata lookup fails in 0.29 on 16.04

Post by bill6502 » Thu Sep 21, 2017 1:20 am

Updated the systemd Wiki with a warning about .service names. Thanks for
the comment.

darknicht
Newcomer
Posts: 9
Joined: Thu Sep 28, 2017 10:50 pm
Canada

Re: [SOLVED] Metadata lookup fails in 0.29 on 16.04

Post by darknicht » Thu Sep 28, 2017 11:13 pm

I just wanted to mention that I had the same issue after upgrading from Mythbuntu 14.04/0.27 to Ubuntu 16.04/0.28

I had intermittent failures with mythmetadatalookups erroring out with code 128. It turned out that only my master backend was successfully running mythmetadatalookup. Both slave backends would error out immediately upon running mythmetadatalookup with an error about not being able to find the /home/mythtv/.mythtv/cache directory. So it looks like the 0.27->0.28 upgrade worked fine on the master, but failed to create the needed cache directories on the slave backends.

To solve it... on each slave backend...

Code: Select all

user@mythbe1$ sudo su mythtv
mythtv@mythbe1$ mkdir ~/.mythtv/cache
mythtv@mythbe1$ mkdir ~/.mythtv/cache/tvdb_api
mythtv@mythbe1$ exit
Note: Mythbuntu runs mythtv programs as the user 'mythtv' so that's why it is looking it that user's home directory. Substitute whatever user your installation runs under if you aren't running Mythbuntu.

Post Reply