did fresh install since upgrade didn't work

For discussion related to MythTV which doesn't belong in another forum.

Moderator: Forum Moderators

Post Reply
jfabernathy
Junior
Posts: 92
Joined: Wed Feb 18, 2015 2:37 pm
United States of America

did fresh install since upgrade didn't work

Post by jfabernathy » Wed Jan 17, 2018 11:28 am

I wanted to document this so it may help others with similar problems. I was on mythbuntu 16.04 with v.28 of mythtv. I wanted to upgrade to v29, but no luck. Too many errors. What I finally did was take a old PC and build a fresh install of Ubuntu Server 16.04.3 and build up mythtv v29 from there. I had saved my recordings and backed up database to a NAS so I could restore to where I was on v.28 before I started. Since mythbuntu is not being maintained so many potential issues are not being taken care of for you. Also v29 switches to mariadb from mysql and that introduces some issues.

I wrote down every step I did so I could repeat it later if I had to do this again. I put my instructions on blogger so others could get any value there was there. You can find the blog at: http://mythtvinstall.blogspot.com/2018/ ... dless.html

My setup is combining a mythtv backend with a samba file server in one box. I use a Hauppauge HVR-2250 PCIe tuner card and SiliconDust HDHomerun Connect networked tuner. I have a APC UPS and software to shutdown if power fails. I include instructions on remote frontends setup to match this v29 setup, database maintenance, and emails from mythtv cron jobs with status.

The format is not perfect, but it's steps that I did and could repeat if necessary to rebuild, which was my goal.

Post Reply