recorder failed

For discussion related to MythTV which doesn't belong in another forum.

Moderator: Forum Moderators

Re: recorder failed

Postby MikeB2013 » Fri May 19, 2017 1:17 pm

The lack of old logs is normal - mythtv rotates the log files (so they do not use all your disk space).

From a quick look at the logs, this indicates a problem:

May 13 19:03:06 JACK mythbackend: mythbackend[1304]: E CoreContext storagegroup.cpp:790 (CheckAllStorageGroupDirs) SG(Default): Group 'Default' wants to use directory '/mnt/oldrec/', but this directory is not writeable.

This looks like remote storage, if so it has permissions issues for user mythtv (which is what the mythbackend runs under), also if it goes away for any reason (network?) it is going to cause confusion in mythbackend.

You might also check permissions on the underlying mount point see https://www.mythtv.org/wiki/Troubleshoo ... ermissions.

A complete listing of your StorageGroups would be useful :
In a terminal on the mythbackend (when finished in mysql type exit to leave):
mysql -uroot -p mythconverg
select * from storagegroup;


Another issue I see is lots of files (some going back to 2013) requiring deletion are not being found, which usually indicates storage problems (missing directories).

Mike
Great BritainMikeB2013
Senior
 
Posts: 104
Joined: Mon Jul 25, 2016 4:16 pm

Re: recorder failed

Postby bpmod » Fri May 19, 2017 2:44 pm

I guess the single biggest question is how to keep the network from randomly disappearing.

mysql -uroot -p mythconverg
select * from storagegroup;
returns the following:
Code: Select all
+----+-------------+----------+------------------------------+
| id | groupname   | hostname | dirname                      |
+----+-------------+----------+------------------------------+
|  1 | Default     | JACK     | /var/lib/mythtv/recordings/  |
|  2 | Videos      | JACK     | /var/lib/mythtv/videos/      |
|  3 | LiveTV      | JACK     | /var/lib/mythtv/livetv/      |
|  4 | Coverart    | JACK     | /var/lib/mythtv/coverart/    |
|  5 | DB Backups  | JACK     | /var/lib/mythtv/db_backups/  |
|  6 | Trailers    | JACK     | /var/lib/mythtv/trailers/    |
|  7 | Fanart      | JACK     | /var/lib/mythtv/fanart/      |
|  8 | Screenshots | JACK     | /var/lib/mythtv/screenshots/ |
|  9 | Banners     | JACK     | /var/lib/mythtv/banners/     |
| 10 | Default     | JACK     | /mnt/oldrec/                 |
+----+-------------+----------+------------------------------+
10 rows in set (0.00 sec)


I also need to figure out why the share on DEAN (mounted as /mnt/oldrec on JACK) suddenly became readonly.

Brian
Canadabpmod
Junior
 
Posts: 19
Joined: Fri Mar 25, 2016 3:42 pm

Re: recorder failed

Postby MikeB2013 » Fri May 19, 2017 7:27 pm

Brian,

Is your mysql server on JACK (I noticed some msql reconnects in the logs) ?

I have a combined frontend/backend system plus remote frontends, but my mythbackend logs never show any mysql reconnects.

Mike
Great BritainMikeB2013
Senior
 
Posts: 104
Joined: Mon Jul 25, 2016 4:16 pm

Re: recorder failed

Postby bpmod » Fri May 19, 2017 8:51 pm

MikeB2013 wrote:Brian,

Is your mysql server on JACK (I noticed some msql reconnects in the logs) ?

I have a combined frontend/backend system plus remote frontends, but my mythbackend logs never show any mysql reconnects.

Mike

Yes. JACK has backend, frontend, mysql and storage.

Brian
Canadabpmod
Junior
 
Posts: 19
Joined: Fri Mar 25, 2016 3:42 pm

Re: recorder failed

Postby bpmod » Mon May 22, 2017 10:40 pm

I reinstalled JACK from scratch. I have not set up a storage group for the old recordings on DEAN. For the past two days or so I have not been able to get Live TV to work, but I have done some test recordings which have been perfectly successful. Until today. Now I am back to the same problem. The recordings have failed with the cryptic "Recorder Failed" message.

The backend log can be found at http://www.bpmod.net/backend.log

Brian
Canadabpmod
Junior
 
Posts: 19
Joined: Fri Mar 25, 2016 3:42 pm

Re: recorder failed

Postby pvr4me » Tue May 23, 2017 12:33 pm

bpmod wrote:I reinstalled JACK from scratch. I have not set up a storage group for the old recordings on DEAN. For the past two days or so I have not been able to get Live TV to work, but I have done some test recordings which have been perfectly successful. Until today. Now I am back to the same problem. The recordings have failed with the cryptic "Recorder Failed" message.

The backend log can be found at http://www.bpmod.net/backend.log

Brian

I'm guessing you meant:

http://www.bpmod.net/mythbackend.log

That log, though, covers over two days and shows all kinds of errors. Could you please restart the backend to create a new log, try Live TV and post the result if it fails.

Craig
The MacPorts guy.
User avatar
Canadapvr4me
Senior
 
Posts: 525
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada

Re: recorder failed

Postby bpmod » Tue May 23, 2017 1:11 pm

pvr4me wrote:I'm guessing you meant:

http://www.bpmod.net/mythbackend.log

My apologies. You are correct.

pvr4me wrote:That log, though, covers over two days and shows all kinds of errors. Could you please restart the backend to create a new log, try Live TV and post the result if it fails.

Craig

Restarting the backend did not create a new log; it only added to that one. LiveTV now starts, but it won't let me change channels. My primary problem in this thread, though, is not that Live TV doesn't work. It is all the recordings that fail with no apparent cause. I, personally, do not know enough to find the cause within those logs.

I have uploaded the current backend log.

Edited to add: I am right back to the point I was before re-installing from scratch. Under "Watch recordings" in frontend, I get 0 of 0 MB free and no recordings successful or otherwise are shown. I can now say with certainty that it is not because the network has gone away. Everything is on the same machine. I will upload the log again in a moment.

Edit again: I have uploaded the frontend log as well http://www.bpmod.net/mythfrontend.log

Thanks for your help.

Brian
Canadabpmod
Junior
 
Posts: 19
Joined: Fri Mar 25, 2016 3:42 pm

Re: recorder failed

Postby pvr4me » Tue May 23, 2017 2:56 pm

Given that you have intermittent problems with different aspects of Myth, I think that your issue may be hardware rather than software.

You have multiple HDHomerun tuners, correct? Are you recording from cable or OTA? If OTA, growing trees now coming out in leaf could be messing up reception. Or the antenna could have shifted due to winter winds. If cable, rain-soaked ground could be shorting out your signal. Just a couple of WAG's about problems that could be affecting the signal path. In fact, coax connections are notoriously problematic. Jostling the cables can cause a once-good connection to be intermittent. You may be able to use the hdhomerun_config utility to test reception and the network. However, it may take some time to figure out which channel(s) and/or which HDHomerun tuner(s) exhibit a problem.

You haven't described your network. Again, a bad cable or a poor connection or a failing NIC could be limiting your network throughput such that Myth thinks your tuners are unavailable. A bad NIC in 'jack' could be why Myth keeps losing and reacquiring the local client.

Perhaps somebody who knows your OS better than me can tell you which system logs to review.

Craig
The MacPorts guy.
User avatar
Canadapvr4me
Senior
 
Posts: 525
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada

Re: recorder failed

Postby MikeB2013 » Tue May 23, 2017 4:06 pm

On Ubuntu (and variants)

The output of dmesg (from a terminal session) may show network issues and other things on the server.

The mysql error.log (in /var/log/mysql/) should indicate any issues with connections to the database.

Unfortunately I don't know much about HDHomerun tuners, apart from "max recordings" (in mythtv-setup) having to be set to 1 (the default is 2) for certain variants and use. Maybe someone who knows about these tuners could comment ?

Mike
Great BritainMikeB2013
Senior
 
Posts: 104
Joined: Mon Jul 25, 2016 4:16 pm

Re: recorder failed

Postby pvr4me » Wed May 24, 2017 12:47 pm

MikeB2013 wrote:On Ubuntu (and variants)

The output of dmesg (from a terminal session) may show network issues and other things on the server.

The mysql error.log (in /var/log/mysql/) should indicate any issues with connections to the database.

Unfortunately I don't know much about HDHomerun tuners, apart from "max recordings" (in mythtv-setup) having to be set to 1 (the default is 2) for certain variants and use. Maybe someone who knows about these tuners could comment ?


That's part of the reason I asked the OP about the source of his material. The HDHomerun Prime and Extend models needs max recordings = 1. The Extend only needs this if the device is recompressing the material--but that's normally the reason for buying the device.

Craig
The MacPorts guy.
User avatar
Canadapvr4me
Senior
 
Posts: 525
Joined: Fri Feb 07, 2014 7:25 pm
Location: near Toronto, Canada

Previous

Return to General Discussion



Who is online

Users browsing this forum: No registered users and 2 guests