Atlas XML TV Listings and Mythfilldatabase adding channels

Moderator: justinh

Post Reply
flitter
Newcomer
Posts: 10
Joined: Wed Aug 20, 2014 2:58 am
Australia

Atlas XML TV Listings and Mythfilldatabase adding channels

Post by flitter » Mon Jan 26, 2015 7:39 pm

Hi,

I've managed to configure the Atlas XMLTV feed to get listings and have all of the channels and listing data showing in mythweb but i'm coming across a 'strangeness'. When I run mythfilldatabase I get additional channels added to the database every time it runs. These channels have a "" (or NULL) channum column.

mythfilldatabase throws this error whenever it runs...

DB Error (MSqlQuery):
Query was:
INSERT INTO channel (chanid, channum, sourceid, callsign, name, serviceid, atsc_major_chan, atsc_minor_chan, useonairguide, visible, tvformat, icon, xmltvid, default_authority) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
Bindings were:
:AUTHORITY="", :CALLSIGN="BBCAS", :CHANID=5159, :CHANNUM=NULL,
:ICON="p131917.png", :MAJORCHAN=0, :MINORCHAN=0, :NAME="BBC Asian Network",
:SERVICEID=0, :SOURCEID=5, :TVFORMAT="Default", :USEOAG=false, :VISIBLE=true,
:XMLTVID="asian.bbc.co.uk"
Driver error was [2/1048]:
QMYSQL3: Unable to execute statement
Database error was:
Column 'channum' cannot be null

It appears not to recognise that a channel has been added even though it's in the table leading to 'duplicate' entries.

mysql> select * from channel where callsign = "bbcas";
+--------+---------+--------+----------+----------+-------------------+-------------+----------+--------------+-----------------+-------------+----------+------------+--------+-------+----------+---------+---------------+---------------+---------+-----------+----------+-----------------+-----------------+---------------------+-------------------+------------+--------+
| chanid | channum | freqid | sourceid | callsign | name | icon | finetune | videofilters | xmltvid | recpriority | contrast | brightness | colour | hue | tvformat | visible | outputfilters | useonairguide | mplexid | serviceid | tmoffset | atsc_major_chan | atsc_minor_chan | last_record | default_authority | commmethod | iptvid |
+--------+---------+--------+----------+----------+-------------------+-------------+----------+--------------+-----------------+-------------+----------+------------+--------+-------+----------+---------+---------------+---------------+---------+-----------+----------+-----------------+-----------------+---------------------+-------------------+------------+--------+
| 5171 | | NULL | 5 | BBCAS | BBC Asian Network | p131917.png | NULL | | asian.bbc.co.uk | 0 | 32768 | 32768 | 32768 | 32768 | Default | 1 | | 0 | NULL | 0 | 0 | 0 | 0 | 0000-00-00 00:00:00 | | -1 | NULL |
| 5128 | 709 | NULL | 5 | BBCAS | BBC Asian Network | p131917.png | NULL | | asian.bbc.co.uk | 0 | 32768 | 32768 | 32768 | 32768 | Default | 1 | | 0 | NULL | 0 | 0 | 0 | 0 | 0000-00-00 00:00:00 | | -1 | NULL |
| 5159 | | NULL | 5 | BBCAS | BBC Asian Network | p131917.png | NULL | | asian.bbc.co.uk | 0 | 32768 | 32768 | 32768 | 32768 | Default | 1 | | 0 | NULL | 0 | 0 | 0 | 0 | 0000-00-00 00:00:00 | | -1 | NULL |
+--------+---------+--------+----------+----------+-------------------+-------------+----------+--------------+-----------------+-------------+----------+------------+--------+-------+----------+---------+---------------+---------------+---------+-----------+----------+-----------------+-----------------+---------------------+-------------------+------------+--------+

I've been through and cleaned up with mythtv-setup a few times but they keep appearing. The 'all' debug on mythfilldatabase provides no information on how it determines if a channel exists or not and a --manual run produces a 'channel skipped' message on channels with this problem.

Does anyone else see this? How can I troubleshoot it?

PS - loving forums instead of mailing lists!!! Much easier to search.

User avatar
dekarl
Developer
Posts: 228
Joined: Thu Feb 06, 2014 11:01 pm
Germany

Re: Atlas XML TV Listings and Mythfilldatabase adding channe

Post by dekarl » Tue Jan 27, 2015 7:59 am

Some questions based on my experience.
  • Is this video source connected to a video device? (it looks like it is
  • has this channel been scannend from the video source? (it does not look like it is, mplexid is NULL and serviceid is 0!)
If the atlas channel's xmltvid has not been added to a dvb channel in mythtv's database, then I have seen all sorts of strange behaviour. I'd either delete the broken instances, add the xmltvid manually and let mythfilldatabase do its thing, or remove the channel from the grabber's configuration.

flitter
Newcomer
Posts: 10
Joined: Wed Aug 20, 2014 2:58 am
Australia

Re: Atlas XML TV Listings and Mythfilldatabase adding channe

Post by flitter » Tue Jan 27, 2015 8:12 am

Thanks - it wasn't attached to a capture card, but this evening I tried attaching it to a device and now i'm not seeing any errors. I've cleaned up the database and removed all of the channels that were added by mythfilldatabase and it seems to be okay now (no errors).

The video source hadn't been scanned from the listings source (as this did not appear to work) or from a video source.

I think it's okay now, it would be great if the error message was a bit more meaningful (i.e. identifying the reason it's trying to add a new channel).

Thanks!

Post Reply