Technisat SkyStar2 probleme mit FW ..

Moderators: daschatten, dekarl

Technisat SkyStar2 probleme mit FW ..

Postby linuxer » Tue Jul 11, 2017 9:54 pm

Hallo Leute,

bis letzte Woche lief mein Videorechner noch ohne Probleme. Dann hat sich meine Festplatte verabschiedet und seit dem ist da der Wurm drinne.

Folgendes Problem.
Mein Rechner ist schon betagt lief aber noch ohne Probleme.
Kubuntu 16.04 mit Technisat Skystar 2 Karte.

Seit in Kubuntu 16.04 nicht mehr Linux-firmware-nonfree mitgeliefert wird musste ich es von Hand installieren.
Das hat letztes mal auch super geklappt und alles lief Prima bis meine alte Platte nicht mehr wollte.
Also habe ich mir ne neue Festplatte gekauft und mit dem alten USB-Stick die 16.04er version versucht wieder zu installieren.
Dieser Stick hatte ich schon bei der letzten Installation benutzt und alles lief gut.
Das Linux-firmware-Nonfree von Hand installiert, mythtv installiert und versucht ins setup zu gehen.
Das funktionierte aber nicht.
systemctl status mythtv-backend.service bringt folgenden Fehler:

Code: Select all
thomas@videorechner:~$ systemctl status mythtv-backend.service
● mythtv-backend.service - MythTV Backend
   Loaded: loaded (/lib/systemd/system/mythtv-backend.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Tue 2017-07-11 23:09:37 CEST; 24min ago
     Docs: https://www.mythtv.org/wiki/Mythbackend
  Process: 1871 ExecStart=/usr/bin/mythbackend --quiet --syslog local7 $ADDITIONAL_ARGS (code=exited, status=138)
 Main PID: 1871 (code=exited, status=138)

Jul 11 23:09:36 videorechner systemd[1]: mythtv-backend.service: Unit entered failed state.
Jul 11 23:09:36 videorechner systemd[1]: mythtv-backend.service: Failed with result 'exit-code'.
Jul 11 23:09:37 videorechner systemd[1]: mythtv-backend.service: Service hold-off time over, scheduling restart.
Jul 11 23:09:37 videorechner systemd[1]: Stopped MythTV Backend.
Jul 11 23:09:37 videorechner systemd[1]: mythtv-backend.service: Start request repeated too quickly.
Jul 11 23:09:37 videorechner systemd[1]: Failed to start MythTV Backend.


Ich habe dann weiter gegraben und folgendes gefunden...

Code: Select all
thomas@videorechner:~$ dmesg | grep fw
[  226.225533] b2c2_flexcop_pci 0000:00:0e.0: Direct firmware load for dvb-fe-cx24120-1.20.58.2.fw failed with error -2
[  226.225542] cx24120: ### ERROR: Could not load firmware (dvb-fe-cx24120-1.20.58.2.fw): -2
thomas@videorechner:~$


Code: Select all
w_scan -fs -s S19E2 -E0 -X > channels.conf


Bricht nach einiger Zeit ab mit folgendem Fehler ab.

ERROR: Sorry - i couldn't get any working frequency/transponder
Nothing to scan!!

Ich habe ehrlich keinen Plan mehr was ich tun kann.
Die Karte sollte eigentlich nicht defekt sein aber genau sagen kann ich es natürlich nicht.
Gibt es eine Möglichkeit die Karte zum laufen zu bringen ?

Ich glaube ich habe da 2 Fehler.
Backend.log zeigt
Code: Select all
....
Jul 11 23:48:10 videorechner mythbackend: mythbackend[3508]: E CoreContext mythcorecontext.cpp:979 (GetBackendServerIP) MythCoreContext::GetBackendServerIP(): No address defined for host: localhost
Jul 11 23:48:10 videorechner mythbackend: mythbackend[3508]: E MythSocketThread(-1) mythsocket.cpp:729 (ConnectToHostReal) MythSocket(1c62b90:-1): Failed to connect to (127.0.0.1:6543) Connection refused
Jul 11 23:48:10 videorechner mythbackend: mythbackend[3508]: E CoreContext mythcorecontext.cpp:979 (GetBackendServerIP) MythCoreContext::GetBackendServerIP(): No address defined for host: videorechner
Jul 11 23:48:10 videorechner mythbackend: mythbackend[3508]: I LogForward loggingserver.cpp:295 (SyslogLogger) Added syslogging
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: C thread_unknown mythcommandlineparser.cpp:2599 (ConfigureLogging) mythbackend version: fixes/0.28 [v0.28-2-g15cf421] www.mythtv.org
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: C thread_unknown mythcommandlineparser.cpp:2601 (ConfigureLogging) Qt version: compile: 5.5.1, runtime: 5.5.1
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: N thread_unknown mythcommandlineparser.cpp:2603 (ConfigureLogging) Enabled verbose msgs:  general
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: N thread_unknown logging.cpp:920 (logStart) Setting Log Level to LOG_INFO
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Unterbrechung handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Beendet handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Speicherzugriffsfehler handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Abgebrochen handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Bus-Zugriffsfehler handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Gleitkomma-Ausnahme handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Ungültiger Maschinenbefehl handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Real-Time Signal 0 handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I thread_unknown signalhandling.cpp:194 (SetHandlerPrivate) Setup Aufgelegt handler
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: N thread_unknown mythdirs.cpp:192 (InitializeMythDirs) Using runtime prefix = /usr
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: N thread_unknown mythdirs.cpp:194 (InitializeMythDirs) Using configuration directory = /home/mythtv/.mythtv
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I CoreContext mythcorecontext.cpp:266 (Init) Assumed character encoding: de_DE.UTF-8
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: N CoreContext mythcontext.cpp:505 (LoadDatabaseSettings) Empty LocalHostName.
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I CoreContext mythcontext.cpp:513 (LoadDatabaseSettings) Using localhost value of videorechner
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I Logger logging.cpp:313 (run) Added logging to the console
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: N CoreContext mythcorecontext.cpp:1670 (InitLocale) Setting QT default locale to de_DE
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I CoreContext mythcorecontext.cpp:1703 (SaveLocaleDefaults) Current locale de_DE
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: N CoreContext mythlocale.cpp:123 (LoadDefaultsFromXML) Reading locale defaults from /usr/share/mythtv//locales/de_de.xml
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I CoreContext mythtranslation.cpp:73 (load) Loading de translation for module mythfrontend
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I CoreContext schemawizard.cpp:120 (Compare) Current MythTV Schema Version (DBSchemaVer): 1344
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I CoreContext mythtranslation.cpp:73 (load) Loading de translation for module mythfrontend
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: E CoreContext mythcorecontext.cpp:979 (GetBackendServerIP) MythCoreContext::GetBackendServerIP(): No address defined for host: localhost
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: E MythSocketThread(-1) mythsocket.cpp:729 (ConnectToHostReal) MythSocket(1b6b620:-1): Failed to connect to (127.0.0.1:6543) Connection refused
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: E CoreContext mythcorecontext.cpp:979 (GetBackendServerIP) MythCoreContext::GetBackendServerIP(): No address defined for host: videorechner
Jul 11 23:48:11 videorechner mythbackend: mythbackend[3516]: I LogForward loggingserver.cpp:295 (SyslogLogger) Added syslogging
thomas@videorechner:~$
....


...und die FW die nicht mehr will.

Hat jemand ne Idee was ich da tun kann ?
Ich habe das System eben neu aufgesetzt und alles Platt gemacht. Ich komme aber nicht weiter :(

Gruß
Thomas
Germanylinuxer
Junior
 
Posts: 38
Joined: Thu Sep 29, 2016 7:07 am

Re: Technisat SkyStar2 probleme mit FW ..

Postby linuxer » Wed Jul 12, 2017 9:53 am

Hallo Leute,

OK das Problem mit der Karte scheint gelöst zu sein. Ich hatte vergessen die FW "dvb-fe-cx24120-1.20.58.2.fw" nach "/lib/firmware" zu kopieren.
Zumindest kann ich jetzt eine channel.conf erstellen und mit Kaffeine einen Sendersuchlauf starten.

Allerdings habe ich noch das Problem mit dem mythtv-backend und dem Exit Status 138.

Code: Select all
thomas@videorechner:~$ systemctl status mythtv-backend.service
● mythtv-backend.service - MythTV Backend
   Loaded: loaded (/lib/systemd/system/mythtv-backend.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Wed 2017-07-12 10:46:09 CEST; 42min ago
     Docs: https://www.mythtv.org/wiki/Mythbackend
  Process: 2008 ExecStart=/usr/bin/mythbackend --quiet --syslog local7 $ADDITIONAL_ARGS (code=exited, status=138)
 Main PID: 2008 (code=exited, status=138)

Jul 12 10:46:08 videorechner systemd[1]: mythtv-backend.service: Main process exited, code=exited, status=138/n/a
Jul 12 10:46:08 videorechner systemd[1]: mythtv-backend.service: Unit entered failed state.
Jul 12 10:46:08 videorechner systemd[1]: mythtv-backend.service: Failed with result 'exit-code'.
Jul 12 10:46:09 videorechner systemd[1]: mythtv-backend.service: Service hold-off time over, scheduling restart.
Jul 12 10:46:09 videorechner systemd[1]: Stopped MythTV Backend.
Jul 12 10:46:09 videorechner systemd[1]: mythtv-backend.service: Start request repeated too quickly.
Jul 12 10:46:09 videorechner systemd[1]: Failed to start MythTV Backend.
thomas@videorechner:~$


Hat das was mit mysql zu tun ?
Während der Installation von Mythtv musste ich ein root passwort für mysql vergeben das hatte ich getan.
Wenn ich versuche mit mysql -u mythtv -p und das Passwort aus /etc/mythtv/config.xml mit der Datenbank zu verbinden scheint das jetzt auch zu funktionieren. gestern ging es komischerweise nicht.

Was bedeutet exit 138 ?

Gruß
Thomas
Germanylinuxer
Junior
 
Posts: 38
Joined: Thu Sep 29, 2016 7:07 am

Re: Technisat SkyStar2 probleme mit FW ..

Postby beppo » Wed Jul 12, 2017 9:58 am

Morgen Thomas,

die Firmware kannst du dir schon mal hier ziehen
https://github.com/OpenELEC/dvb-firmware/raw/master/firmware/dvb-fe-cx24120-1.20.58.2.fw

Und das das Backend nicht startet, könnte daran liegen, dass noch keine Adresse konfiguriert worden ist an der es lauschen soll.
No address defined for host: videorechner

Starte doch das mythtvsetup und geh die Netzwerkkonfig durch.
Viele Grüße Beppo
Germanybeppo
Senior
 
Posts: 134
Joined: Sun Feb 09, 2014 8:12 am

Re: Technisat SkyStar2 probleme mit FW ..

Postby linuxer » Fri Jul 14, 2017 11:05 am

Hallo Beppo,

nach langem hin und her habe ich es nun geschafft. Es lag, wie Du richtig erkannt hast an der fehlenden Adresse.
Auch musste ich die Zeit in der Karteneinstellung massiv nach oben schrauben. 60000 und 65000. Das hattest Du mir aber letztes mal schon gesagt. Komischerweise hat es erst mal nicht funktioniert, erst als ich das System 2 mal neu aufgesetzt habe, hat er die Zeiten auch benutzt beim Senderscan.

Ich habe momentan trotzdem ab und zu noch ein Problem. Die Karte wird im mythtv-setup nicht immer benutzt. Er zeigt die Karte zwar an, aber meint die ist "blockiert".
Erst wenn ich den Rechner ein paarmal neu gestartet habe geht es dann irgendwann.
Komischerweise kann ich aber mit der "blockierten" Karte im Frontend TV schauen. Das Verstehe ich nicht so ganz. Ein anderes Programm (kaffeine) habe ich noch nicht installiert was die Karte blockieren könnte.

Eine Frage habe ich noch.
Ich habe noch eine 2te Karte. Momentan habe ich die Hauppauge WinTv Nova wieder im Rechner, auch wenn die einen Schuss hat. Die findet Tele5 nicht mehr. Auch andere Sender hatten damals Probleme, deswegen hatte ich letztes Jahr die gegen eine Technisat SkyStar 2 ausgetauscht.
Nun hat aber zufällig während dem Testen mit der Nova der Senderscan funktioniert weswegen ich die erst mal im Rechner lasse. Wenn ich die später gegen die Technisat austausche, muss ich dann einen Senderscan neu anstarten, oder reicht es die neue Karte in der Karteneinstellung im mythtv-setup nur einzutragen und die Verlinkung der alten zu benutzen ?

Gruß
Thomas
Germanylinuxer
Junior
 
Posts: 38
Joined: Thu Sep 29, 2016 7:07 am

Re: Technisat SkyStar2 probleme mit FW ..

Postby beppo » Fri Jul 14, 2017 3:45 pm

Hallo Thomas,

wenn du das mythtvsetup startest und lässt das sSetup dann das mythbackend killen kann es sein das die dann noch blockiert erscheint.
Vielleicht kannst du das einfach umgehen in dem die das Backend selber aus machst.
Aber das ist nur eine Vermutung...

Die Karten kannst du wenn du das Medium nicht änderst tauschen oder aufstocken, das ist mythtv total egal ;)
Nur neu eintragen musst du sie, aber das hast du ja bereits gesagt.
Viele Grüße Beppo
Germanybeppo
Senior
 
Posts: 134
Joined: Sun Feb 09, 2014 8:12 am

Re: Technisat SkyStar2 probleme mit FW ..

Postby linuxer » Sat Jul 22, 2017 3:42 pm

Hallo Beppo,

danke für die Info. Werde ich mal testen. Sorry für die späte Antwort aber ich war im Urlaub und Irgendwie bekomme ich die Mails nicht.

Gruß
Thomas
Germanylinuxer
Junior
 
Posts: 38
Joined: Thu Sep 29, 2016 7:07 am

Re: Technisat SkyStar2 probleme mit FW ..

Postby beppo » Sun Jul 30, 2017 8:33 am

Hallo Thomas,

kein Ding. Ich hoffe es funktioniert jetzt.
Viele Grüße Beppo
Germanybeppo
Senior
 
Posts: 134
Joined: Sun Feb 09, 2014 8:12 am


Return to Deutschland - Germany



Who is online

Users browsing this forum: No registered users and 1 guest