Search found 119 matches

by wmorrison
Wed Feb 05, 2020 12:32 am
Forum: General Development
Topic: Service to get SHUTDOWN_COUNTDOWN?
Replies: 6
Views: 501
United States of America

Re: Service to get SHUTDOWN_COUNTDOWN?

http://localhost:6547/Frontend/GetStatus returns "standbymode" for "currentlocation" when in standby mode.
by wmorrison
Tue Feb 04, 2020 6:20 pm
Forum: Linux
Topic: Invoke tmdb3 via a script and pass tmdb id
Replies: 7
Views: 547
United States of America

Re: Invoke tmdb3 via a script and pass tmdb id

Hello, I have an existing movie library, and for each movie i have the TMDB id. Is it possible to invoke tmdb3 script directly for each folder and pass TMDB ID for metadata lookup? At the moment I have to goto 'Media Library' invoke a scan and feed TMDB id manually for each file. Unfortunately, my ...
by wmorrison
Tue Feb 04, 2020 2:55 pm
Forum: General Development
Topic: Service to get SHUTDOWN_COUNTDOWN?
Replies: 6
Views: 501
United States of America

Re: Service to get SHUTDOWN_COUNTDOWN?

You can easily check if the frontend is idle by using the network control port. Thanks! I'll check that out. However, I'm also going to check if the Frontend service call GetStatus will tell when frontend is in standby mode. However I would recommend rather handle this by adding some checks to the ...
by wmorrison
Tue Feb 04, 2020 12:36 am
Forum: General Development
Topic: Service to get SHUTDOWN_COUNTDOWN?
Replies: 6
Views: 501
United States of America

Re: Service to get SHUTDOWN_COUNTDOWN?

I just did some testing and noted that mythfrontend logs a message when it enters standby mode, and another when it leaves. So if nothing else, I can monitor the log.
by wmorrison
Mon Feb 03, 2020 11:41 pm
Forum: General Development
Topic: Service to get SHUTDOWN_COUNTDOWN?
Replies: 6
Views: 501
United States of America

Re: Service to get SHUTDOWN_COUNTDOWN?

Use case: I want to run a background queue processor (not mythtv jobs, completely external) that will process jobs whenever the system is on, and either the backend is busy or the frontend is being actively used. If backend is not busy, mythshutdown -c still returns "OK to shutdown" even if the fron...
by wmorrison
Fri Jan 31, 2020 4:32 pm
Forum: General Discussion
Topic: Standalone EIT grabber?
Replies: 1
Views: 197
United States of America

Standalone EIT grabber?

Is there a standalone EIT grabber for linux? One that can output listings data to a file/database? I configured my system to use SchedulesDirect very early on, but would like to get familiar with what data is available over EIT without reconfiguring MythTV and corrupting my existing listings data. J...
by wmorrison
Tue Jan 28, 2020 8:59 pm
Forum: General Development
Topic: Service to get SHUTDOWN_COUNTDOWN?
Replies: 6
Views: 501
United States of America

Service to get SHUTDOWN_COUNTDOWN?

Is there a programatic way for a script to get myth's shutdown countdown? (The value you see at the top of mythwelcome when the system is idle and it's going to shut down when the countdown reaches zero.)
by wmorrison
Thu Jan 23, 2020 4:41 pm
Forum: Troubleshooting
Topic: 100% Signal, No Lock
Replies: 5
Views: 533
United States of America

Re: 100% Signal, No Lock

I would test running the antenna straight to only your MythTV box, eliminating all splitters. If possible with a single unbroken run of coax.

If that works, the problem may be reflections within the "maze" of splitters/coax. Especially if the layout changed when you moved the machine.
by wmorrison
Wed Jan 22, 2020 12:09 am
Forum: Troubleshooting
Topic: 100% Signal, No Lock
Replies: 5
Views: 533
United States of America

Re: 100% Signal, No Lock

So you ran the antenna direct to the tuner, no amplification at all? None integrated into the antenna either? Antenna still in the same location? So you're getting 100% signal, I assume just on some channels? Are they close/strong? Are other weaker/farther channels that work showing less than 100% (...
by wmorrison
Mon Jan 20, 2020 6:35 pm
Forum: General Development
Topic: mythpython documentation?
Replies: 2
Views: 591
United States of America

Re: mythpython documentation?

OK, so don't bother pointing shebang to mythpython, just python2 and import MythTV if needed. Thanks.
by wmorrison
Mon Jan 20, 2020 5:29 pm
Forum: General Development
Topic: mythpython documentation?
Replies: 2
Views: 591
United States of America

mythpython documentation?

I see there's an executable "mythpython" where the description is simply "mythpython is a command line utility shell for the python bindings of MythTV." Googling mythpython returns no useful info that I've found so far other than the description above. Is mythpython current, or an "old way" of doing...
by wmorrison
Sun Jan 19, 2020 11:38 pm
Forum: Wishlist/Feature Suggestions
Topic: Make AddVideo return Id?
Replies: 0
Views: 1579
United States of America

Make AddVideo return Id?

It would be helpful if the Video service 'AddVideo' returned the Id of the newly added video rather than just a boolean. I am adding a video, then updating its metadata with UpdateVideoMetadata, which requires an Id. In between I get the Id with GetVideoByFileName (the same name as used in AddVideo....
by wmorrison
Sun Jan 19, 2020 4:23 pm
Forum: Troubleshooting
Topic: Help! "No Recordings available, or screen loading..."
Replies: 4
Views: 462
United States of America

Re: Help! "No Recordings available, or screen loading..."

This usually happens when the currently selected Filter or Group doesn't have any recordings My settings do not remember the previously selected group when exiting recordings. It always starts on Default recording group. And Default definitely has recordings. On the other hand, somebody else had be...
by wmorrison
Sat Jan 18, 2020 9:59 pm
Forum: Troubleshooting
Topic: AddVideo filename syntax?
Replies: 2
Views: 394
United States of America

Re: AddVideo filename syntax?

The API is looking for the Storage Group: Videos . I'd verify that that points to /data2/videos too. Thanks. That must be it. I haven't defined a Videos storage group. mythutil --scanvideos works fine when automatically scanning for all videos, but I'm working on transcoding specific recordings wit...
by wmorrison
Sat Jan 18, 2020 9:34 pm
Forum: Troubleshooting
Topic: Help! "No Recordings available, or screen loading..."
Replies: 4
Views: 462
United States of America

Re: Help! "No Recordings available, or screen loading..."

OK, this is weird, but I found a solution, at least it works for now. I'll report back if it changes. In the "Watch Recordings" screen, press m for menu, choose "Change Group Filter", then choose any group. Boom. Listings back. Change back to default group, still works. Exit frontend and restart it,...