Search found 515 matches

by paulh
Wed Mar 26, 2014 1:01 pm
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

Glad things are fixed for you [WHITE SMILING FACE]

Do you see a big difference between the tree view and gallery view?

A graphic equaliser is probably beyond my skill level unless I can find some example code. The UI side is no problem but I wouldn't know how to process the audio.
by paulh
Tue Mar 25, 2014 11:10 pm
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

Try updating once more I think I've got it beat this time :)

You may need to rescan to sort the albumart out. If that doesn't work there is a button on the general settings page to reset the music tables so you can do a clean rescan.
by paulh
Tue Mar 25, 2014 12:10 pm
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

Can you try commenting out this line https://code.mythtv.org/cgit/mythtv/tree/mythtv/programs/mythutil/musicmetautils.cpp#n173 So it look like this //gCoreContext->SendMessage(QString("MUSIC_METADATA_CHANGED %1").arg(songID)); Looks like sending a MUSIC_METADATA_CHANGED there could cause an infinite...
by paulh
Tue Mar 25, 2014 9:34 am
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

OK sounds like some junk has been inserted into the albumart table. Can you please run this query in mysql just to confirm it.

Code: Select all

select * FROM music_albumart WHERE filename = 'front.jpg' AND embedded = 1;
by paulh
Mon Mar 24, 2014 11:34 pm
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

Please update both FE and BE and try again. The tree view should now be a lot quicker since we now don't look up any icons at all. The gallery view should be quicker but not as quick as the tree view since we still need to hunt for the icons/album art. On my dev computer which is a FE only I can't a...
by paulh
Sun Mar 23, 2014 7:49 pm
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

Can you update and try again. I've fixed a few things including the hunt for the icons looking in all the storage groups. It will now only look in the AlbumArt storage group.
by paulh
Sat Mar 22, 2014 8:00 am
Forum: Troubleshooting
Topic: Mythfrontend crashes with nvidia drivers 334.21
Replies: 3
Views: 8381
Great Britain

Re: Mythfrontend crashes with nvidia drivers 334.21

piper wrote:Thanks :)

I never had problems with those drivers, and I don't have problems with 331.49 either :)

Hopefully it helps others
The 331.xx drivers are OK it's the 334.xx drivers that have the problem or if Stuart is correct it's actually the way Myth is using them.
by paulh
Sat Mar 22, 2014 7:21 am
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

The logs are password protected. It would be more useful to run htop and select the option to see the process tree then run the FE under gdb. When you see the high cpu usage make a note of the PIDs of the FE processes in htop that are using a lot of cpu. Switch to gdb and press Ctrl-C to interrupt t...
by paulh
Thu Mar 20, 2014 10:13 pm
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

There's something really screwed up with your set up. You say you are using current master but the log snippet shows you are actually using 77 WindMark which is 0.27-fixes if I'm not mistaken. There is also a mismatch between FE and BE versions because one part of the log shows --imagetype='Front' w...
by paulh
Thu Mar 20, 2014 12:58 pm
Forum: General Development
Topic: [solved] recent mythmusic commits - high CPU load on FE
Replies: 18
Views: 2339
Great Britain

Re: recent mythmusic commits - high CPU load on FE

I can't think of any recent changes that would affect CPU usage. From your fe log it looks like you started a file scan shortly before you started myth music which will run in the background. If I recall correctly you have a lot of music files so the scan will take some time. The fe log doesn't show...
by paulh
Mon Mar 10, 2014 7:11 am
Forum: Hardware
Topic: Can I connect Tuner Directly to PC Ethernet?
Replies: 4
Views: 1186
Great Britain

Re: Can I connect Tuner Directly to PC Ethernet?

There is no reason why it shouldn't work. It's just a question of setting it up so your MythTV system can find it so probably better if the HD HomeRun allows it to give it a static address on the same network as your wireless.
by paulh
Sat Mar 01, 2014 8:00 am
Forum: Troubleshooting
Topic: Odd front end calibration issue
Replies: 10
Views: 1428
Great Britain

Re: Odd front end calibration issue

Surely everyone's not just watching their Myth boxes without adjusting anything in the appearance? Can anyone let me in on the secret?! For me it just works :) I have 'Use Fixed Window Size' on but leave the position and size at 0 to let Myth use the maximum size depending on the resolution being u...
by paulh
Sun Feb 23, 2014 11:38 am
Forum: Troubleshooting
Topic: Odd front end calibration issue
Replies: 10
Views: 1428
Great Britain

Re: Odd front end calibration issue

I'm running a front end on a Foxconn NT-A3500. When I try calibrating the screen in the wizards menu option, I move the triangles into the corner of the screen perfectly, but when I save and exit, it puts a massive black border at the bottom and RHS of the screen?! I don't think the screen setup wi...
by paulh
Sun Feb 23, 2014 11:11 am
Forum: Troubleshooting
Topic: [solved] TBS6285 problems
Replies: 5
Views: 1592
Great Britain

Re: TBS6285 problems

Ok sorted it - I found that if I deleted the contents of the media drivers in the kernel folders *before* installing the card on a fresh install, it picked the card up ok! Glad you got it sorted. Yeah that is one of the problems with using a newer kernel than the one TBS based their driver on. If y...
by paulh
Sun Feb 23, 2014 11:01 am
Forum: General Discussion
Topic: Deinterlacing Settings in 0.27
Replies: 4
Views: 907
Great Britain

Re: Deinterlacing Settings in 0.27

Page 3/8 Playback Profiles. Choose the one you want to edit at the top then press Edit. On the second page you can choose what deinterlacer will be used etc. The playback profiles allow you to choose which decoder, video renderer, osd renderer, filters and deinterlacer will be used based on the vide...