Search found 61 matches

by mark_k
Mon May 04, 2020 4:15 pm
Forum: Troubleshooting
Topic: mythtranscode fifo for HD encodes on Mythtv 31 and kubuntu 20.04 not working
Replies: 3
Views: 292
Great Britain

Re: mythtranscode fifo for HD encodes on Mythtv 31 and kubuntu 20.04 not working

Thanks dnalorernst, It's good to know that it has been reported already. Just one thing - in that link Mark stated "was looking at just adding full FFmpeg functionality to transcode directly." Is this still in the pipeline or something that is available now? From my perspective, it is on a very lon...
by mark_k
Mon May 04, 2020 3:52 pm
Forum: Linux
Topic: DVD menus freezing in episode section since updating to v31
Replies: 8
Views: 665
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Rob

To be clear - are you only seeing the issue with VDPAU enabled?

Can you post the full output from 'mythfrontend -v playback' from a crash?

thanks and regards
Mark
by mark_k
Wed Apr 15, 2020 9:23 am
Forum: Linux
Topic: playing copyprotected DVD crashes internal DVD Player
Replies: 3
Views: 912
Great Britain

Re: playing copyprotected DVD crashes internal DVD Player

udfread ERROR: ECMA 167 Volume Recognition failed libdvdnav: Using dvdnav version 6.0.0 - commit dcb9109e45ccd304ec82a7c7bf46cca63620adf9 *** libdvdread: CHECK_VALUE failed in dvdread/ifo_read.c:572 *** *** for vmgi_mat->vmg_last_sector != 0 *** *** libdvdread: CHECK_VALUE failed in dvdread/ifo_rea...
by mark_k
Wed Apr 15, 2020 9:18 am
Forum: Linux
Topic: DVD menus freezing in episode section since updating to v31
Replies: 8
Views: 665
Great Britain

Re: DVD menus freezing in episode section since updating to v31

Rob I'm not seeing any crashes with DVD playback. Can you get any more details? Firstly a complete 'mythfrontend -v playback' log and ideally a backtrace when it crashes - are you using a packaged version or building from source? if from source, can you produce a debug build for the backtrace? As a ...
by mark_k
Fri Apr 03, 2020 4:14 pm
Forum: Troubleshooting
Topic: MythTV 31.0 and 4k playback tests with several hardware
Replies: 12
Views: 1030
Great Britain

Re: MythTV 31.0 and 4k playback tests with several hardware

Today I am starting to check the same hardware under Windows 10 with Kodi and it works fine (but VLC doesn't). Same test under Xubuntu 20.04: kodi have same same issue as MythTV. So it looks like more an issue of the linux driver. Next was to crosscheck the NVidia pages for this board (PCI DeviceID...
by mark_k
Fri Apr 03, 2020 11:00 am
Forum: Troubleshooting
Topic: MythTV 31.0 and 4k playback tests with several hardware
Replies: 12
Views: 1030
Great Britain

Re: MythTV 31.0 and 4k playback tests with several hardware

NUC is working now with the applied patch nearly perfect . That's great. I will check my other 4K material now. When we would make it better: there are some seconds of stuttering at the start? But hey, great progress! VAAPI Acceleration (decode only) doesn't work: Got pictures all 2 seconds but the...
by mark_k
Fri Apr 03, 2020 9:43 am
Forum: Troubleshooting
Topic: [Solved] Slight Visual Studder with TrueHD 7.1 Audio Track
Replies: 22
Views: 1326
Great Britain

Re: Slight Visual Studder with TrueHD 7.1 Audio Track

Sorry - hit the submit button a little early there:) Looking at the logs, it appears as if playback is fine after the display is pre-empted. Does that match what you are seeing? Once playback has settled down again, it looks like there are no subsequent frame drops. On the other hand, I see no reaso...
by mark_k
Fri Apr 03, 2020 9:31 am
Forum: Troubleshooting
Topic: [Solved] Slight Visual Studder with TrueHD 7.1 Audio Track
Replies: 22
Views: 1326
Great Britain

Re: Slight Visual Studder with TrueHD 7.1 Audio Track

Thanks for this. I did switch my Onkyo receiver over to a different system with an NVidia Gt1050 and everything worked without issue again. Sorry for the delay on this... Here's what I've got. I used a .mkv rip of the Wonder Woman bluray. It has a TrueHD track that usually causes significant studder...
by mark_k
Thu Apr 02, 2020 6:48 pm
Forum: Troubleshooting
Topic: MythTV 31.0 and 4k playback tests with several hardware
Replies: 12
Views: 1030
Great Britain

Re: MythTV 31.0 and 4k playback tests with several hardware

decodersv31.diff Attached patch (for v31) is for both NVDEC and VAAPI. The NVDEC portion won't fix anything but extra logging should highlight why it is rejecting HEVC4k decoding. The VAAPI portion is just a hunch... fingers crossed:) re VAAPI - I should have asked before. Can you check whether VAA...
by mark_k
Wed Apr 01, 2020 5:43 pm
Forum: Troubleshooting
Topic: MythTV 31.0 and 4k playback tests with several hardware
Replies: 12
Views: 1030
Great Britain

Re: MythTV 31.0 and 4k playback tests with several hardware

re VAAPI - can you confirm for me that mpv works with VAAPI on the NUC?

i.e. Does the following work? :-

mpv -v -v --hwdec=vaapi '4K HEVC 59.940 Broadcast Capture Sample.mkv'

Thanks
Mark
by mark_k
Wed Apr 01, 2020 9:08 am
Forum: Troubleshooting
Topic: MythTV 31.0 and 4k playback tests with several hardware
Replies: 12
Views: 1030
Great Britain

Re: MythTV 31.0 and 4k playback tests with several hardware

Thanks for quick answer. I have attached the 3 log files. For GTX950 I found that region most interesting: ... I VDP: decoder:nvdec renderer:opengl-hw deint0:high:shader:driver deint1:high:shader:driver cpus:1 I NVDEC: NVDEC does NOT support 'H265 Main 10 yuv420p10le Depth:10 3840x2160' I AFD: Unav...
by mark_k
Tue Mar 31, 2020 8:56 pm
Forum: Troubleshooting
Topic: MythTV 31.0 and 4k playback tests with several hardware
Replies: 12
Views: 1030
Great Britain

Re: MythTV 31.0 and 4k playback tests with several hardware

I have checked the possibilities to playback 4K material with MythTV 31.0. So I am very happy to see that MythTV 31.0 comeback with Nvidia support for HEVC (VDPAU and NVDEC). My test material (e.g. HEVC Main@L5.1, 3840x2160@59.940fps, YUV, 10 Bit, HDR) works well with GTX1050Ti (GP107). The informa...
by mark_k
Tue Mar 31, 2020 10:52 am
Forum: Troubleshooting
Topic: [Solved] Slight Visual Studder with TrueHD 7.1 Audio Track
Replies: 22
Views: 1326
Great Britain

Re: Slight Visual Studder with TrueHD 7.1 Audio Track

So good news and bad news. The good news is that both samples play without issue using TrueHD passthrough to the Onkyo receiver. The bad news - well, I can't reproduce the problem. I've created a log using 'mythfrontend -v playback,audio' :- https://pastebin.com/enCcM4yj This is an Intel Coffeelake ...
by mark_k
Mon Mar 30, 2020 3:04 pm
Forum: Troubleshooting
Topic: [Solved] Slight Visual Studder with TrueHD 7.1 Audio Track
Replies: 22
Views: 1326
Great Britain

Re: Slight Visual Studder with TrueHD 7.1 Audio Track

Vaska

Thanks. Second clip plays fine as well with a basic audio setup.

I've just realised however that my ageing Onkyo receiver supports TrueHD - so I'll see if I can test with that. Just need to work around the rest of the 'housebound' family...

Regards
Mark
by mark_k
Sun Mar 29, 2020 8:33 am
Forum: Troubleshooting
Topic: [Solved] Slight Visual Studder with TrueHD 7.1 Audio Track
Replies: 22
Views: 1326
Great Britain

Re: Slight Visual Studder with TrueHD 7.1 Audio Track

Vaska Thanks for the clip. Testing with master, I don't see/hear any problems. Audio is fairly straightforward stereo speaker setup - no hdmi, spdif etc. Tried with both software playback and VAAPI (Intel) and Alsa and PulseAudio. Everything looks/sounds fine. Can you narrow down the setup/configura...