Search found 20 matches

by gpw928
Sun Apr 05, 2020 9:05 pm
Forum: Troubleshooting
Topic: [Solved] Weekly cron job fails with fixes/30 on Debian 10
Replies: 8
Views: 561
Australia

Re: Weekly cron job fails with fixes/30 on Debian 10

bill6502 wrote:
Sun Apr 05, 2020 3:23 pm
FYI, a solution was pushed on 4/1: https://github.com/MythTV/packaging/blo ... ron.weekly
Thank you. I see that the code was changed to test "${USER:-}", which is instructive in the context (non-interactive, "set -e" active).
by gpw928
Sun Mar 22, 2020 1:02 am
Forum: Troubleshooting
Topic: [Solved] Weekly cron job fails with fixes/30 on Debian 10
Replies: 8
Views: 561
Australia

Re: Weekly cron job fails with fixes/30 on Debian 10

My goal is to get the sources patched correctly so we won't have to go through it again.
by gpw928
Sat Mar 21, 2020 9:40 pm
Forum: Troubleshooting
Topic: [Solved] Weekly cron job fails with fixes/30 on Debian 10
Replies: 8
Views: 561
Australia

Re: Weekly cron job fails with fixes/30 on Debian 10

Thank you for that. I just realised that I tested the change interactively, and that invalidated the testing ("dash -e" works differently when interactive). The correct fix requires the failing command to explicitly tested, so lines 17 through 21 need to be replaced with this: CMDPREFIX="" [ "X$USER...
by gpw928
Fri Mar 20, 2020 9:26 pm
Forum: Troubleshooting
Topic: [Solved] Weekly cron job fails with fixes/30 on Debian 10
Replies: 8
Views: 561
Australia

[Solved] Weekly cron job fails with fixes/30 on Debian 10

Hi, I have recently upgraded to Debian 10 with MythTV from source fixes/30, and just got this in the mail: Message 318/318 Anacron <...my.domain> Mar 21, 2020 07:47:52 am +1100 Date: Sat, 21 Mar 2020 07:47:52 +1100 To: root@mith.my.domain Subject: Anacron job 'cron.weekly' on mith /etc/cron.weekly/m...
by gpw928
Tue Mar 17, 2020 2:22 am
Forum: Troubleshooting
Topic: VDPAU unusable with fixes/30
Replies: 2
Views: 396
Australia

Re: VDPAU unusable with fixes/30

Thank you for your assistance. I used Terra 1.4. I have also now tested Steppes 30.4 and MythCenter 1.4. They all behave in the same way with VDPAU enabled. When looking at the program guide, the TV display shrinks and moves to a corner, bright traces flash across the screen momentarily, and the are...
by gpw928
Mon Mar 16, 2020 4:39 am
Forum: Troubleshooting
Topic: VDPAU unusable with fixes/30
Replies: 2
Views: 396
Australia

VDPAU unusable with fixes/30

Hi, I have just upgraded to Debian 10 using the source MythTV fixes/30. I have had to abandon VDPAU (frontend Setup->Video->Playback->VDPAU High Quality) because the program guide gets blanked out when I press the button to see it. I think it may be related to "picture-in-picture" because pressing t...
by gpw928
Mon Mar 16, 2020 4:21 am
Forum: General Discussion
Topic: [Solved] Upgrade Plan
Replies: 3
Views: 280
Australia

Re: Upgrade Plan

I have now completed the upgrade, and modified the plan above to reflect exactly what I did.

In the end it was a lot easier to use the new IP addresses, as keeping the old ones meant a lot of work with ssh keys.
by gpw928
Sun Mar 15, 2020 11:18 pm
Forum: Troubleshooting
Topic: [Solved] Remote frontend won't connect to DB
Replies: 7
Views: 617
Australia

Re: [Solved] Remote frontend won't connect to DB

For those who follow I have summarised the setup below. I have disabled all proxies on all MythTV hosts (I usually set them in environment variables pointing at the local squid server when I login). The new MythTV Master Backend server is 192.168.1.28. The mysql bind address = 0.0.0.0 (all interface...
by gpw928
Wed Mar 11, 2020 11:06 pm
Forum: General Discussion
Topic: Relationship between videosource and capture cards ?
Replies: 14
Views: 711
Australia

Re: Relationship between videosource and capture cards ?

I have MythTV servers that have both USB and HDHomeRun tuners "attached" to the same server. I have only ever used one video source for the "capture cards", the local free-to-air transmission. As an aside, the HDHomeRuns all work very well. The USB tuners have to be chosen with great care. The only ...
by gpw928
Wed Mar 11, 2020 1:24 am
Forum: General Discussion
Topic: [Solved] Upgrade Plan
Replies: 3
Views: 280
Australia

Re: Upgrade Plan

Thank you Bill. Well spotted.

I have modified the plan, and will leave it for a day or so before executing.

If I strike issues I'll modify it to reflect what actually happened.
by gpw928
Tue Mar 10, 2020 1:38 am
Forum: General Discussion
Topic: [Solved] Upgrade Plan
Replies: 3
Views: 280
Australia

[Solved] Upgrade Plan

Hi, My "MythTV Upgrade and Database Conversion Plan" is below. I'd appreciate any comments so it can be left here for those who follow. I'm particularly interested in maintaining the integrity of the database and recordings at all times (so I can safely retreat, if required). The MythTV server has t...
by gpw928
Mon Mar 09, 2020 11:32 am
Forum: Troubleshooting
Topic: [Solved] Remote frontend won't connect to DB
Replies: 7
Views: 617
Australia

Re: Remote frontend won't connect to DB

On the backend setup, I had the PIN set to 0000, but the Primary IP was set to 127.0.0.1. After I changed this to 192.168.1.28, the remote frontend started working (and stopped displaying the "MythTV Startup Status" screen which I expect is only seen when things go wrong). Thank you Mike. The issue ...
by gpw928
Mon Mar 09, 2020 6:29 am
Forum: Troubleshooting
Topic: [Solved] Remote frontend won't connect to DB
Replies: 7
Views: 617
Australia

Re: Remote frontend won't connect to DB

Thank you for your response. To summarise the situation: The MythTV backend server is 192.168.1.28 (hostname mith). It also runs the mysql server, and a local MythTV frontend. There is a second (remote) MythTV frontend is installed 192.168.1.29 (hostname fable). The MythTV backend server, and the my...
by gpw928
Mon Mar 09, 2020 1:53 am
Forum: Troubleshooting
Topic: [Solved] Remote frontend won't connect to DB
Replies: 7
Views: 617
Australia

[Solved] Remote frontend won't connect to DB

Hi, I am building new MythTV server, local frontend, and remote frontend with Debian 10.3 and MythTV patch 30. I have compiled the MythTV code from source and created the Debian packages without problems, by following the instructions in the Wiki. I have installed the MythTV server, with local front...
by gpw928
Thu Aug 29, 2019 5:27 am
Forum: Hardware
Topic: HDHomeRun Quatro HDHR5-4DT no channels
Replies: 3
Views: 515
Australia

Re: HDHomeRun Quatro HDHR5-4DT no channels

I decided to fiddle with signal and tuning timeout defaults. On the new MythV server, I set the signal timeout to 1500 ms (default 1000), and suddenly the channel scan worked. Suspicious, I set it back to 1000 ms, and it still worked. So I went over to the old MythTV server, and with no changes at a...