Search found 1203 matches

by bill6502
Wed Apr 24, 2019 5:11 pm
Forum: Troubleshooting
Topic: HDHomeRun with mythtv .30
Replies: 10
Views: 107
United States of America

Re: HDHomeRun with mythtv .30

To be clear, when building from source, the default location of the objects is
in /usr/local/bin. Distributions usually put them in /usr/bin. I didn't mean to suggest
that /usr/bin is incorrect.
by bill6502
Tue Apr 23, 2019 8:02 pm
Forum: Linux
Topic: [solved]backend configuration location
Replies: 4
Views: 57
United States of America

Re: backend configuration location

I think there's more to this story. The backend log shows v30 and schema 1350 while the MFDB log shows v29 and 1348. The timestamps aren't the same, so I can't tell if the backend was running when MFDB was run. Both use the same profile name (hostname) of rooster-Inspiron-580. Both are using /home/m...
by bill6502
Tue Apr 23, 2019 2:20 am
Forum: Linux
Topic: [solved]backend configuration location
Replies: 4
Views: 57
United States of America

Re: backend configuration location

It is stored in config.xml. The backend's copies should point to localhost, while remote frontends require a routable address, typically a Private Network one. Sounds like you've got that covered. But pastebin a full log, not a single line. There will be a line like : ...Using configuration director...
by bill6502
Tue Apr 23, 2019 1:57 am
Forum: Troubleshooting
Topic: HDHomeRun with mythtv .30
Replies: 10
Views: 107
United States of America

Re: HDHomeRun with mythtv .30

Let's see if mythtv-setup (which should represent everything myth) was built with the library in place: mythtv-setup --version|grep --color=always using_hdhomerun ldd /usr/local/bin/mythtv-setup | grep -i homerun On my 18.04 and 19.04 boxes it works fine (although I'm on v31-Pre right now.) Expect t...
by bill6502
Sun Apr 21, 2019 10:24 pm
Forum: Troubleshooting
Topic: Remote Frontend
Replies: 8
Views: 82
United States of America

Re: Remote Frontend

I'd try things like (adjusted for your distribution):

Code: Select all

dpkg -l libqt5sql5-mysql
apt show -a libqt5sql5-mysql
ldd /usr/local/bin/mythbackend | grep -i libqt5sql
To see if the package is installed and loaded (based on the error message:
Driver not loaded.)
by bill6502
Sat Apr 20, 2019 9:45 pm
Forum: Troubleshooting
Topic: Remote Frontend
Replies: 8
Views: 82
United States of America

Re: Remote Frontend

pastebin.com, no login required.
by bill6502
Sat Apr 20, 2019 9:36 pm
Forum: Troubleshooting
Topic: Upgrade mythtv (30.0-dmo3) fails on Debian testing/buster
Replies: 3
Views: 54
United States of America

Re: Upgrade mythtv (30.0-dmo3) fails on Debian testing/buster

FYI only, in *buntu this file has the administrative user info:

sudo cat /etc/mysql/debian.cnf

'Til a real Debian user replies, might be worth a look. Maybe the password
is empty/missing there. As a rule, I never change its contents.
by bill6502
Thu Apr 11, 2019 3:46 am
Forum: Troubleshooting
Topic: (solved) No more mysql backups?
Replies: 9
Views: 65
United States of America

Re: No more mysql backups?

Agreed, cron jobs are run by the user defined in /etc/crontab, most likely root, or as modified. However, non-hourly jobs are most likely run by anacron. There may be an /etc/anacrontab file on your host. If you're running systemd, you could try these 2: $ journalctl --unit anacron | grep cron.weekl...
by bill6502
Thu Apr 11, 2019 2:04 am
Forum: Troubleshooting
Topic: (solved) No more mysql backups?
Replies: 9
Views: 65
United States of America

Re: No more mysql backups?

Thanks. But how 'bout the contents of /etc/default/mythtv-backend. When run from the command line, $USER will have a value, "root" in the tests above. But when run out of cron, $USER will be empty. Since I don't have that file, I don't know if USER is set in it. Looking at system logs may help. jour...
by bill6502
Wed Apr 10, 2019 9:39 pm
Forum: Troubleshooting
Topic: (solved) No more mysql backups?
Replies: 9
Views: 65
United States of America

Re: No more mysql backups?

Hi,

Your test implies that /etc/default/mythtv-backend doesn't exist (or it doesn't have USER=...) in it.
If that's not the case, I'd re-run as CMDPREFIX would be set.

Try running the cron script directly: sudo /etc/cron.weekly/mythtv-database
by bill6502
Sun Apr 07, 2019 4:16 pm
Forum: Troubleshooting
Topic: [SOLVED] WebFrontend: cannot search by channel
Replies: 3
Views: 67
United States of America

Re: [SOLVED] WebFrontend: cannot search by channel

Fixed in master and fixes/30 ref: [0939394].

Thanks for testing.
by bill6502
Sun Apr 07, 2019 2:33 pm
Forum: Troubleshooting
Topic: [SOLVED] WebFrontend: cannot search by channel
Replies: 3
Views: 67
United States of America

Re: WebFrontend: cannot search by channel

Hi, See if you can find this file: programsearch.qsp. I <think> yours will be under: /usr/share/mythtv/html/tv. The following is a patch, note the single line that's been changed: diff --git a/mythtv/html/tv/programsearch.qsp b/mythtv/html/tv/programsearch.qsp index cfce030..6441e76 100644 --- a/myt...
by bill6502
Wed Apr 03, 2019 4:24 pm
Forum: General Discussion
Topic: 501 error on install of JW Player
Replies: 4
Views: 49
United States of America

Re: 501 error on install of JW Player

No idea why you're getting the 501.

From the backend, try: cd /tmp ; wget http://www.mythtv.org/ftp/3rdParty/jwplayer.zip
It gets redirected to the same URL, only with https. So try that if the above fails.

FYI, on the backend the unzipped files live under: ~mythtv/.mythtv/3rdParty/JW_Player
by bill6502
Wed Apr 03, 2019 2:48 pm
Forum: General Discussion
Topic: 501 error on install of JW Player
Replies: 4
Views: 49
United States of America

Re: 501 error on install of JW Player

Hi,

Works for me, but I'm running on v31-Pre.

mythbackend --version will tell what you're running on.

There was a fix [6ae82b11] for v29 and above.
by bill6502
Wed Apr 03, 2019 1:13 pm
Forum: Troubleshooting
Topic: [SOLVED] No sound with PulseaAudio / NVidia / HDMI
Replies: 2
Views: 73
United States of America

Re: No sound with PulseaAudio / NVidia / HDMI

... so that I can get mythtv to control volume instead of using the TV remote control.
Not the answer you requested, but did you use frontend setup -> Audio -> Use internal volume controls?