Search found 37 matches

by mtrax
Tue Nov 19, 2019 6:12 am
Forum: Services API
Topic: inconsistancy XML vs JSON
Replies: 0
Views: 36
Australia

inconsistancy XML vs JSON

I have only found one item so far but in API GetUpcomingList recording status is different .

JSON: ProgramList.Program[0].Recording.Status contacts a number (-2,-1)
XML it contains a word eg Recording,WillRecord

is this intentional?
by mtrax
Tue Nov 19, 2019 6:07 am
Forum: Services API
Topic: getting CORS blocking JSON request (solved)
Replies: 9
Views: 54
Australia

Re: getting CORS blocking JSON request

solved,by inserting AllowedOriginsList value in settings table.
by mtrax
Sun Nov 17, 2019 10:53 pm
Forum: Services API
Topic: getting CORS blocking JSON request (solved)
Replies: 9
Views: 54
Australia

Re: getting CORS blocking JSON request

Jsonp will send xml
by mtrax
Sun Nov 17, 2019 8:16 pm
Forum: Services API
Topic: getting CORS blocking JSON request (solved)
Replies: 9
Views: 54
Australia

Re: getting CORS blocking JSON request

backend log message

(AddCORSHeaders) HTTPRequest: Cross-origin request received with origin (http://mythbox)
by mtrax
Sun Nov 17, 2019 7:46 pm
Forum: Services API
Topic: getting CORS blocking JSON request (solved)
Replies: 9
Views: 54
Australia

Re: getting CORS blocking JSON request

I don't find any matches for that name in settings table
by mtrax
Sun Nov 17, 2019 7:35 pm
Forum: Services API
Topic: getting CORS blocking JSON request (solved)
Replies: 9
Views: 54
Australia

Re: getting CORS blocking JSON request

Yes it works for curl and php but not for jquery Ajax request for json.
is the AllowedOriginsList setting in database somewhere how do insert /create?
by mtrax
Sun Nov 17, 2019 4:08 am
Forum: Services API
Topic: getting CORS blocking JSON request (solved)
Replies: 9
Views: 54
Australia

getting CORS blocking JSON request (solved)

I'm writing a simple AJAX request to retrieve upcoming recordings but I'm getting: the following error: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://mythbox:6544/Dvr/GetUpcomingList?count=3. (Reason: CORS header ‘Access-Control-Allow-Origin’ mi...
by mtrax
Tue Aug 06, 2019 8:09 am
Forum: Troubleshooting
Topic: mythtv v30 video metadata images not loading?
Replies: 4
Views: 266
Australia

Re: mythtv v30 video metadata images not loading?

I've created ticket , I hope thats enough info and it can help other people.
by mtrax
Sat Aug 03, 2019 11:51 pm
Forum: Troubleshooting
Topic: mythtv v30 video metadata images not loading?
Replies: 4
Views: 266
Australia

Re: mythtv v30 video metadata images not loading?

ok found the issue it seems the large "Cast" list was causing a timeout:

/usr/share/mythtv/metadata/Movie/tmdb3.py -l en -a AU -D 399579 --debug

I removed this loop and the script returned cover image ok.

how do I report a bug with script?
by mtrax
Sat Aug 03, 2019 11:28 pm
Forum: Troubleshooting
Topic: mythtv v30 video metadata images not loading?
Replies: 4
Views: 266
Australia

Re: mythtv v30 video metadata images not loading?

scratch that after I rerun on another day and it worked for one the other I'm getting a timed out exception.

it would be good if I could do this from command line or web frontend makes editing the title a little easier.
by mtrax
Sat Aug 03, 2019 11:22 pm
Forum: Troubleshooting
Topic: mythtv v30 video metadata images not loading?
Replies: 4
Views: 266
Australia

mythtv v30 video metadata images not loading?

I have Mythtv v30 and the tmdb lookup appears to be working , its returning a result and updating the synopsis and text fields but I'm not seeing any images cover-art loading ?
How do I figure out whats going on here?
Note is there a way to do this from the Webfrontend instead of UI?
by mtrax
Sat Jul 13, 2019 9:18 pm
Forum: Troubleshooting
Topic: [SOLVED] How On Earth Do You Get It Working?
Replies: 16
Views: 3399
Australia

Re: [SOLVED] How On Earth Do You Get It Working?

Is there a way to determine the changelog for these updates using this repository?
by mtrax
Mon Jul 01, 2019 7:39 am
Forum: Troubleshooting
Topic: Audio delay with hdmi at start of playback (solved)
Replies: 7
Views: 411
Australia

Re: Audio delay with hdmi at start of playback (solved)

update:

I added the load of loopback module to my pulseaudio config file and problem solved.
/etc/pulse/default.pa :

load-module module-loopback
by mtrax
Sun Jun 30, 2019 11:25 am
Forum: Troubleshooting
Topic: Audio delay with hdmi at start of playback (solved)
Replies: 7
Views: 411
Australia

Re: Audio delay with hdmi at start of playback

I've worked out it's a actually ubuntu issue, so I guess I need to try figure out what is going on
by mtrax
Fri Jun 14, 2019 9:30 pm
Forum: Troubleshooting
Topic: Audio delay with hdmi at start of playback (solved)
Replies: 7
Views: 411
Australia

Re: Audio delay with hdmi at start of playback

Note that the the delay seems to be only start of playback, not when I pause /play.
Is there any logging I can look at which will help determine root cause?