Search found 50 matches

by mtbdrew
Tue Jul 28, 2020 4:55 pm
Forum: Troubleshooting
Topic: Daily mythfilldatabase update not running.
Replies: 6
Views: 344
United States of America

Re: Daily mythfilldatabase update not running.

Nope it was a completely new install. Attempted upgrade from v30 failed completely and I forgot to take a backup first! Anyway decided to upgrade Ubuntu at that time to 20.04 and chose delete option so system wasn't dragging any old mythbuntu baggage forward.
by mtbdrew
Mon Jul 27, 2020 9:20 pm
Forum: Troubleshooting
Topic: Daily mythfilldatabase update not running.
Replies: 6
Views: 344
United States of America

Re: Daily mythfilldatabase update not running.

Looks like removing the "--dd-grab-all " did the trick. So if it is no longer valid for v31 why was it added during a clean install of OS and v31?
by mtbdrew
Mon Jul 27, 2020 1:17 am
Forum: Troubleshooting
Topic: Daily mythfilldatabase update not running.
Replies: 6
Views: 344
United States of America

Re: Daily mythfilldatabase update not running.

| sourceid | name | xmltvgrabber | +----------+------+-------------------+ | 1 | SD | tv_grab_zz_sdjson | +----------+------+-------------------+ | value | data | hostname | +----------------------+------------------+----------+ | MythFillDatabaseArgs | --dd-grab-all | NULL | | MythFillDatabasePath ...
by mtbdrew
Sun Jul 26, 2020 9:24 pm
Forum: Troubleshooting
Topic: Daily mythfilldatabase update not running.
Replies: 6
Views: 344
United States of America

Daily mythfilldatabase update not running.

Mythtv v31 running on Ubuntu 20.04.1 LTS 64bit FE status shows: Last mythfilldatabase Guide Update: Started: Fri Jul 24 2020, 4:52 PM Finished: Fri Jul 24 2020, 4:53 PM Result: Succesful Suggested next: yesterday, 4:52 PM (16 days) If I log into the mythtv use and run "sudo -H -u mythtv bash -c "myt...
by mtbdrew
Sun Jul 26, 2020 9:06 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

Okay thanks for the help and information.
by mtbdrew
Sun Jul 26, 2020 3:52 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

When you tried to edit the file, were you user mythtv? If yes, then what does this command return: echo $HOME . If not, then become the mythtv user as you have done before. Yes I was in mythtv user. echo $HOME gives me this: /home/mythtv if I use this command "nano $HOME/.mythtv/SD.xmltv" I get the...
by mtbdrew
Fri Jul 24, 2020 10:17 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

I'm showing about 30 but can't image these are not showing up in the OTA scan as i have a 100 mile antenna and get a crap load of stations that are picked up in the mythtv-setup scan. Now I did go in the channel edit and deselected all the shopping, Spanish, other non-English stations. Could this be...
by mtbdrew
Fri Jul 24, 2020 9:55 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

Made the changes in mythtv-set this cleared the error code but I still get fewer skipping messages but this do have these: 2020-07-24 16:53:09.671307 N Unknown xmltv channel identifier: I100147.json.schedulesdirect.org - Skipping channel. Tried editing the file $HOME/.mythtv/SD.xmltv as per https://...
by mtbdrew
Fri Jul 24, 2020 8:52 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

So I need to take database=SD.xmltv back out and then go into the backend (mythtv-setup) and change the grabber to which one exactly?
by mtbdrew
Fri Jul 24, 2020 5:55 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

Just ran mythtv-setup to confirm it is using Multinational (Schedules Direct JSON web services with SQLite....). When I sudo su - mythtv I then run this "tv_grab_zz_sdjson_sqlite --manage-lineups --config-file $HOME/master/.mythtv/SD.xmltv" to initialize etc (followed the wiki) so I should definitel...
by mtbdrew
Fri Jul 24, 2020 3:16 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

I don't have this file:

/home/mythtv/.mythtv/OTA.xmltv

So where and how do you deselect the stations "Set selected to 0"
by mtbdrew
Fri Jul 24, 2020 3:09 am
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

Not sure exactly what you mean: "mythconverg DB doesn't have that identifier, but the grabber's DB does have the channel (xmltvid) and it is marked as selected. Set selected to 0 and the message should go away." Yes the </tv> is at the end Definitely couldn't run the command until I added mythtv sud...
by mtbdrew
Thu Jul 23, 2020 11:58 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

Okay tried something different: First ran sudo su - mythtv Then ran the command (after adding mythtv to sudo) sudo -H -u mythtv bash -c "mythfilldatabase -v system" This did not give the original error message however it did give a bunch of: Unknown xmltv channel identifier: I90202.json.schedulesdir...
by mtbdrew
Thu Jul 23, 2020 11:47 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

tv_grab_zz_sdjson_sqlite --config-file '/home/mythtv/.mythtv/SD.xmltv' --output /tmp/JustMeTesting This runs fine with no errors. Seems like only when mythtv runs it or using the sudo -H -u mythtv bash -c "mythfilldatabase -v system" command line format does the error occur. I tried tv_grab_zz_sdjso...
by mtbdrew
Thu Jul 23, 2020 9:26 pm
Forum: Troubleshooting
Topic: XMLTV grabber returned error code 1
Replies: 36
Views: 938
United States of America

Re: XMLTV grabber returned error code 1

2020-07-23 15:53:21.077838 E Malformed XML file, missing </tv> element, at line 1, Premature end of document

So what XML file is this referring too?