Search found 4 matches

by boomshalek
Thu Jul 03, 2014 3:31 pm
Forum: Linux
Topic: [solved] Archlinux: mythbackend segfault 0.27-fixes
Replies: 6
Views: 988
Germany

Re: Archlinux: mythbackend segfault 0.27-fixes

OK, new try with: options=(debug !strip) in PKGBUILD-File Attaching to process 2354 Reading symbols from /usr/bin/mythbackend...done. warning: Could not load shared library symbols for linux-vdso.so.1. Do you need "set solib-search-path" or "set sysroot"? Reading symbols from /usr/lib/libmythtv-0.27...
by boomshalek
Wed Jul 02, 2014 6:34 pm
Forum: Linux
Topic: [solved] Archlinux: mythbackend segfault 0.27-fixes
Replies: 6
Views: 988
Germany

Re: Archlinux: mythbackend segfault 0.27-fixes

I have recompiled and installed the package again with ./configure --compile-type=debug but it still says 'no debugging symbols found' Attaching to process 3154 Reading symbols from /usr/bin/mythbackend...(no debugging symbols found)...done. warning: Could not load shared library symbols for linux-v...
by boomshalek
Wed Jul 02, 2014 3:25 pm
Forum: Linux
Topic: [solved] Archlinux: mythbackend segfault 0.27-fixes
Replies: 6
Views: 988
Germany

Re: Archlinux: mythbackend segfault 0.27-fixes

Backtraces are basically useless if the binaries have been stripped (of debugging symbols). All we can see is that somewhere in libmythtv, we botched a QMap lookup. OK, Sorry for not using the correct way. I followed the MythTV Debugging WIKI where it says In many cases, a profile build will be acc...
by boomshalek
Wed Jul 02, 2014 1:15 pm
Forum: Linux
Topic: [solved] Archlinux: mythbackend segfault 0.27-fixes
Replies: 6
Views: 988
Germany

[solved] Archlinux: mythbackend segfault 0.27-fixes

Hi I am running mythtv 0.27-fixes from git dated from march 2014 in a stable state on Archlinux. When I compile 0.27-fixes from recently (Upgrade to 0.27.2) I get a Segfault running the backend (no custom patches applied.) Additinally I get "cannot connect to backend" from mythwelcome before the seg...