Search found 41 matches

by AKADAP
Wed Jul 20, 2016 4:32 am
Forum: Troubleshooting
Topic: Mythbackend starts before network is working.
Replies: 4
Views: 1543
United States of America

Re: Mythbackend starts before network is working.

I did a clean install of Mint 18, and installed MythTV from the software manager. I made the mistake of trying to run mythfrontend which got me in an infinite restart loop with the frontend restarting every time I tried to exit it. I believe that this was caused by the database not being set up corr...
by AKADAP
Tue Jul 19, 2016 3:55 am
Forum: Troubleshooting
Topic: Mythbackend starts before network is working.
Replies: 4
Views: 1543
United States of America

Re: Mythbackend starts before network is working.

Thanks. I was given a simpler solution on the mailing list, and I came back to add it here. Edited to add that I'm running Mint 18 1)copy /lib/systemd/system/mythtv-backend.service to /etc/systemd/system/mythtv-backend.service. Make a copy so that an update wont delete the changes you make to the fi...
by AKADAP
Mon Jul 18, 2016 10:22 pm
Forum: Troubleshooting
Topic: Mythbackend starts before network is working.
Replies: 4
Views: 1543
United States of America

Mythbackend starts before network is working.

This causes problems because if the network is not running when mythbackend starts, it assumes there is no network, and can't see the HDHomeRun tuners.
What is the proper way to guarantee that mythbackend does not start until after the network is functional?
by AKADAP
Mon Jul 18, 2016 10:19 pm
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

I have fixed the startup and shutdown commands in mythbackend setup so that they actually work now. Thank you.
Now it is down to resolving the race condition on boot. I'll start a new thread on that since this one is getting rather long and confusing.
by AKADAP
Mon Jul 18, 2016 8:17 pm
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

It looks like mint is running systemd, but the restart command did not work. $ systemctl restart mythbackend.service Failed to restart mythbackend.service: Unit mythbackend.service not found. $ sudo restart mythtv-backend [sudo] password for dpeale: restart: Unable to connect to Upstart: Failed to c...
by AKADAP
Mon Jul 18, 2016 4:27 pm
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

[quote I suspect it will work if you simply restart the backend. I presume that if I run backend setup, this stops the backend and starts it again when it is exited. I have done this many times, and it has not fixed the problem even temporarily. I have changed the IP address in the backend setup to...
by AKADAP
Sun Jul 17, 2016 10:50 pm
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

Deleting with "Delete All Cards" and re-creating did not help.
by AKADAP
Sun Jul 17, 2016 10:36 pm
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

When you delete the tuners it's recommended to always select "Delete all cards on all hosts" and recreate them from scratch. Editing/deleting tuners or "Delete cards on this host" is known to have issues. Not known to me. I'll try again with the delete all cards selection. I only have a single back...
by AKADAP
Sun Jul 17, 2016 2:13 am
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

In an attempt to eliminate the deleted DVB tuner from the backend, I deleted all tuners and recreated the HDHomeRun tuners. It did not seem to have helped. Backend log: Jul 16 19:09:02 Compromise mythbackend: mythbackend[1416]: I ProcessRequest mainserver.cpp:1698 (HandleAnnounce) MainServer: MainSe...
by AKADAP
Sat Jul 16, 2016 3:22 am
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

after a bit of googleng I tried running mythtv-status. This was not installed so I installed it. It complained about not finding the perl API, so I installed libmythtv-perl. This did not help The results of running mythtv-status are now: $ mythtv-status --verbose Today: 20160715 Tomorrow: 20160716 C...
by AKADAP
Thu Jul 14, 2016 5:49 am
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

Sometimes I forget that the Log files exist. From the Backend log: Jul 13 22:35:09 Compromise mythbackend: mythbackend[1421]: E ProcessRequest mainserver.cpp:4718 (HandleRemoteEncoder) MainServer: HandleRemoteEncoder(cmd GET_STATE) Unknown encoder: 10 Jul 13 22:35:09 Compromise mythbackend: mythback...
by AKADAP
Tue Jul 12, 2016 4:01 am
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: Unable to get mythtv working Mint 16,17 &18

Another day, another change in behavior.
Now both localhost, and the IP address are giving the same result the IP address gave yesterday.

I checked the firewall, and it was disabled.

I don't know what to try next.
by AKADAP
Mon Jul 11, 2016 3:49 am
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: [SOLVED] Unable to get mythtv working on Mint 16,17 &18

Now it is just getting weird. http://localhost/mythweb/ and http://192.168.63.3/mythweb/ give me different results. localhost gets me: on the listings page: Fatal Error !!NoTrans: SQL Error: Expression #3 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'mythconverg.program...
by AKADAP
Mon Jul 11, 2016 2:12 am
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: [SOLVED] Unable to get mythtv working on Mint 16,17 &18

Everything was working yesterday. Re-boot, now mythweb can no-longer connect to the back end, and myth front end can no-longer play live TV. Setting up mythTV is always difficult. Backend is running, and it looks like it is set up to respond to the address mythweb is trying. mysql mythtv password ha...
by AKADAP
Sun Jul 10, 2016 5:47 am
Forum: Troubleshooting
Topic: Unable to get mythtv working Mint 16,17 &18
Replies: 30
Views: 8178
United States of America

Re: [SOLVED] Unable to get mythtv working on Mint 16 &17

Resurrecting a dead thread, because this problem exists in Mint 18 as well. If you install mythTV, then try and run myth front end, you get stuck in an infinite full screen loop that is very difficult to get out of since cancel just causes myth front end to re-start. I manually edited .mythtv/config...