Search found 43 matches

by williamatwood
Wed Dec 25, 2019 5:09 am
Forum: Linux
Topic: [Solved] Activating MythWeb
Replies: 6
Views: 456
Canada

Re: Activating MythWeb

The problem was a letter "l" that was entered as a figure "1" in the mysql password. (The two are indistinguishable in the font used by my terminal emulator.)

Thank you all who offered advice. Mythweb now works properly, and I can browse the schedule without standing in front of the TV...

Bill
by williamatwood
Mon Dec 23, 2019 2:42 am
Forum: Linux
Topic: [Solved] Activating MythWeb
Replies: 6
Views: 456
Canada

Re: Activating MythWeb

I have not read much in the Wiki for the past two years. I never knew that WebFrontend existed.

As you say, "WebFrontend requires no setup". I typed in the URL, and there is was.

Thank you!
by williamatwood
Mon Dec 23, 2019 12:46 am
Forum: Linux
Topic: [Solved] Activating MythWeb
Replies: 6
Views: 456
Canada

Re: Activating MythWeb

Yes, that should be 0.28.2, not 0.38.2. Assuming that "localhost" should be written as the IP address of the computer running MythTV, I get a Fatal Error page, the .txt version of which is shown in the attachment. If you need to see the original web page, please access https://users.encs.concordia.c...
by williamatwood
Sun Dec 22, 2019 5:01 pm
Forum: Linux
Topic: [Solved] Activating MythWeb
Replies: 6
Views: 456
Canada

[Solved] Activating MythWeb

I am running MythTV 0.38.2 on Unbuntu 16.04 LTS. The last time that I tried to puzzle out how to get MythWeb working, I was able to install Apache2, and view the "Apache2 Ubuntu Default Page". However, what little documentation that I could find on MythWeb seemed to be written only for those who wer...
by williamatwood
Sat Oct 20, 2018 1:08 am
Forum: Linux
Topic: [Solved] Deleting a recording fails to delete the associated media files
Replies: 7
Views: 1318
Canada

Re: Deleting a recording fails to delete the associated media files

Thank you, all who commented.

The comment by dizygotheca got me to the correct screen to do the deletions, and the comment by paulh allowed me to see the recordings move into the auto expire list, and then actually get deleted some time later (more than a few minutes; less than 8 hours).
by williamatwood
Wed Oct 17, 2018 12:54 am
Forum: Linux
Topic: [Solved] Deleting a recording fails to delete the associated media files
Replies: 7
Views: 1318
Canada

Re: Deleting a recording fails to delete the associated media files

Thank you for the hints about changing the storage group. I will make those changes once I get my file space back. My real concern is that deleting the recording using "D" did not delete the associated media file. (I understand, from some other reading, that it may have only "enabled" the deletion, ...
by williamatwood
Mon Oct 15, 2018 2:55 am
Forum: Linux
Topic: [Solved] Deleting a recording fails to delete the associated media files
Replies: 7
Views: 1318
Canada

[Solved] Deleting a recording fails to delete the associated media files

Hello, I am running Mythtv 0.28.2-6-g9031599 on Ubuntu 16.04.5 LTS. I have 240 GB of my internal hard drive for Ubuntu, and a 2 TB external hard drive on which I store the media files for recordings of TV shows. Rather than modify the location of the "default" folder in Mythtv, I have a soft link fr...
by williamatwood
Mon Oct 08, 2018 2:33 am
Forum: General Discussion
Topic: Deleting previously-recorded TV shows
Replies: 2
Views: 359
Canada

Re: Deleting previously-recorded TV shows

Thanks! "D" works!
by williamatwood
Mon Oct 08, 2018 12:35 am
Forum: General Discussion
Topic: Deleting previously-recorded TV shows
Replies: 2
Views: 359
Canada

Deleting previously-recorded TV shows

I need to delete recordings of shows that I have watched, to make space on my disk drive. I have done this before, but have forgotten how to do it, and my searches of the web, the wiki, and the forum have not turned up anything useful. I know that I had to select individual shows and then use a pop-...
by williamatwood
Tue Sep 19, 2017 10:02 pm
Forum: Troubleshooting
Topic: Class 'MythBase' not found
Replies: 11
Views: 1201
Canada

Re: Class 'MythBase' not found

OK, I installed php-mythtv. I re-booted the backend server (just in case). I checked that the set of php files are indeed now located at /usr/share/mythtv/bindings/php Now, I get an error message: Fatal Error !!NoTrans: Access denied for user ''@'localhost' (using password: NO) [#1045] along with an...
by williamatwood
Tue Sep 19, 2017 8:02 pm
Forum: Troubleshooting
Topic: Class 'MythBase' not found
Replies: 11
Views: 1201
Canada

Re: Class 'MythBase' not found

Update: Since I knew (from an update on another machine) that an updated version was available for MythTV, I ran sudo apt-get update sudo apt-get upgrade in the hope that this might install the missing files. The upgrade certainly touched mythbackend (and lots of other myth* components). The updated...
by williamatwood
Mon Sep 18, 2017 9:07 pm
Forum: Troubleshooting
Topic: Class 'MythBase' not found
Replies: 11
Views: 1201
Canada

Re: Class 'MythBase' not found

I used a standard "full system" install on Ubuntu 16.04 LTS:

set up the PPA

sudo apt-get install mythtv
by williamatwood
Mon Sep 18, 2017 7:08 pm
Forum: Troubleshooting
Topic: Class 'MythBase' not found
Replies: 11
Views: 1201
Canada

Re: Class 'MythBase' not found

OK, I went back over the install procedure. Since it is simply a git clone, followed by a git checkout, followed by a copy of the checked out files to /usr/local/share/mythtv/mythweb, there is no way that the "Install Mythweb" step on the "Install from sources" page is going to put anything in /usr/...
by williamatwood
Fri Sep 15, 2017 2:47 am
Forum: Troubleshooting
Topic: Class 'MythBase' not found
Replies: 11
Views: 1201
Canada

Re: Class 'MythBase' not found

I have none of these files (or even these directories). When I installed Mythweb, I had installed Apache but not PHP (Mysql was, of course, already there). I suspect that the install procedure just skipped the PHP parts when it could not find the PHP binaries. I will try forcing a new install; if th...
by williamatwood
Thu Sep 14, 2017 10:29 pm
Forum: Troubleshooting
Topic: Class 'MythBase' not found
Replies: 11
Views: 1201
Canada

Re: Class 'MythBase' not found

The file /etc/apache2/sites-available/mythweb.conf contains a (commented-out) line # setenv include_path "/usr/share/mythweb/" However, /usr/share/mythweb does not exist. (/usr/share/mythtv does, but there is no subdirectory related to mythweb.) The directory referenced in the error message does exi...