Search found 306 matches

by kmdewaal
Mon Jun 21, 2021 8:15 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

mythtv-setup-2.log CODE: SELECT ALL 2021-06-07 00:29:44.690652 I ScreenSaverX11Private: DPMS is disabled. 2021-06-07 00:29:44.783345 E DB Error (StorageGroup::StorageGroup()): Query was: Driver error was [1/]: Driver not loaded Database error was: Driver not loaded This is not good what caused the ...
by kmdewaal
Fri Jun 18, 2021 6:17 pm
Forum: Troubleshooting
Topic: Jerky live TV on version 31
Replies: 8
Views: 326
Netherlands

Re: Jerky live TV on version 31

OK so this is not a 50Hz/60Hz issue. Maybe your RPi4 clock is a bit inaccurate. Is your frontend connected to the Internet and does it have time service (NNTP) enabled? The easiest way to check this could be issuing the "date" command both on your frontend and your backend and this command should gi...
by kmdewaal
Wed Jun 16, 2021 5:30 pm
Forum: Troubleshooting
Topic: Jerky live TV on version 31
Replies: 8
Views: 326
Netherlands

Re: Jerky live TV on version 31

Interesting! This should not happen of course. The only thing I can imagine that 50Hz content is accidentally played back at 60Hz. Can you do some measurements, e.g. start Live TV, delay for 60 seconds, unpause Live TV, and check every 10 seconds the time to live. Also, what video card and driver do...
by kmdewaal
Fri Jun 11, 2021 9:32 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

OK, so this The StartupScreenDelay setting does seem to be causing the issue I'm having. does mean that the problem is solved by setting a value of 2. The lowest value is 1 second and that also works for me. Does the backend use a 2s delay regardless of the setting? The backend is a command line app...
by kmdewaal
Thu Jun 10, 2021 9:38 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

The first database does NOT have the StartupScreenDelay setting so a value of 2 seconds will be used.
The second and the third databases do have a StartupScreenDelay setting of 0.
by kmdewaal
Thu Jun 10, 2021 9:00 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

About the DB Error (StorageGroup::StorageGroup()) in the beginning of the log file. This error is caused by the setting StartupScreenDelay. This can be set in the mythfrontend configuration menu "Theme/Screen settings" and this is the help text: The Startup Screen will show the progress of starting ...
by kmdewaal
Wed Jun 09, 2021 9:38 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

The LibCecInitialize bug was fixed only in master, not in v31.See commit e787645fd974bbed6b02ed45ae3530477bb49c58.
This bug happened sometimes when mythfrontend was connected to a monitor or a TV that does not support CEC.
by kmdewaal
Wed Jun 09, 2021 9:28 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

And now it looks like I can somewhat reproduce this, using the 3rd database version. I have changed the host name in the database tables storagegroup, program, recorded, capturecard and settings to the host name of my system and created the /var/lib/mythtv/.... storage group directories. Now mythtv-...
by kmdewaal
Wed Jun 09, 2021 9:54 am
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

Did you try running mythtv-setup with my restored databases? Yes and mythtv-setup works OK with every restored database. This is however on Fedora 34. One thing that strikes me is the location of the storage groups: MariaDB [mythconverg]> select * from storagegroup; +----+-------------+----------+-...
by kmdewaal
Tue Jun 08, 2021 7:48 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

About the database error, I do have that also sometimes on my systems. I think this happens when the database does not respond quickly enough. If it is not followed by other database errors it is probably not harmful although it should not happen. About the log files. I did not see anything wrong in...
by kmdewaal
Sun Jun 06, 2021 9:30 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

This is now the issue as I understand it: - do a clean install - run mythtv-setup - mythtv-setup works OK, GUI works OK, channelscan is OK - run mythbackend and mythfrontend - do one recording - stop mythfrontend and mythbackend - run mythtv-setup - NOW mythtv-setup fails: GUI freezes Also: - mythtv...
by kmdewaal
Sat Jun 05, 2021 10:05 pm
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

Doing it remotely via SSH also does not work then. This rules out local display issues. Reading the attached log file a bit more carefully shows this error a few times: Jun 4 19:10:23 htpc-HP mythtv-setup.real: mythtv-setup[7539]: E CoreContext mythuifilebrowser.cpp:604 (updateLocalFileList) MythUIF...
by kmdewaal
Sat Jun 05, 2021 7:29 am
Forum: Troubleshooting
Topic: mythtv-setup freezes upon launching
Replies: 39
Views: 433
Netherlands

Re: mythtv-setup freezes upon launching

How to configure all the bits for channel scanning is described in the Wiki https://www.mythtv.org/wiki/Channel_Scanning and especially the paragraph https://www.mythtv.org/wiki/Channel_Scanning#Scanning_with_HDHomeRun_tuners is of interest because the configuration of these is rather different sinc...
by kmdewaal
Mon May 31, 2021 9:14 pm
Forum: Troubleshooting
Topic: Subtitles and NVDEC?
Replies: 14
Views: 1274
Netherlands

Re: Subtitles and NVDEC?

Now reported in Github issue #364 https://github.com/MythTV/mythtv/issues/364.
N.B. This does not guarantee a quick fix but it does raise the visibility of this bug and it reduces the likelihood of this bug being forgotten.....
by kmdewaal
Fri May 28, 2021 9:30 pm
Forum: Troubleshooting
Topic: Subtitles and NVDEC?
Replies: 14
Views: 1274
Netherlands

Re: Subtitles and NVDEC?

Yes, this does select NVDEC but only if it is available for your graphics card. As far as I know NVDEC only works for Nvidia cards. If you select NVDEC on e.g. Intel-only cards where NVDEC is not available then automatically FFmpeg is used instead. CC subtitle playback with FFMpeg is OK. The decoder...