Search found 26 matches

by monkeypet
Tue Jul 28, 2020 7:20 pm
Forum: Raspberry Pi
Topic: Raspberry Pi 4 Case + Fan
Replies: 4
Views: 586
United States of America

Re: Raspberry Pi 4 Case + Fan

rodr wrote:
Mon Jul 27, 2020 10:40 pm
I'm very pleased with my aluminum passive heatsink case. On a stress test temperature never got over 67C.
Thanks for sharing, did you try overclocking?
by monkeypet
Sun Jul 26, 2020 7:34 am
Forum: Raspberry Pi
Topic: RPi 4 MythTV-light 31 issues
Replies: 18
Views: 234
United States of America

Re: RPi 4 MythTV-light 31 issues

Because of your post, I went looking at the script to see what the script did. I discovered that you can run mythfrontend without the X server. So if you disabled the GUI desktop via raspi-config, then use the following, mythfrontend will launch without the need for X or its compositor... this expla...
by monkeypet
Sun Jul 26, 2020 7:26 am
Forum: Raspberry Pi
Topic: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth
Replies: 10
Views: 577
United States of America

Re: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth

I just discovered a way to run mythfrontend without an X server. Disable the GUI desktop, using raspi-config, then login and run: QT_QPA_EGLFS_ALWAYS_SET_MODE="1" QT_QPA_PLATFORM=eglfs mythfrontend -O PowerOffTVOnExit=0 --logpath=/home/pi/logs FYI: Kodi can be run this way also, replace mythfrontend...
by monkeypet
Sat Jul 25, 2020 1:00 am
Forum: Raspberry Pi
Topic: RPi 4 MythTV-light 31 issues
Replies: 18
Views: 234
United States of America

Re: RPi 4 MythTV-light 31 issues

If you are using a custom .xsession file, you can start the compositor by doing the following, add /usr/lib/raspi-config/cmstart.sh : pi@raspberrypi:~ $ cat /home/pi/.xsession #!/bin/bash /usr/lib/raspi-config/cmstart.sh & sleep 5s /home/pi/bin/start.mythfrontend FWIW I'm seeing the same problem as ...
by monkeypet
Thu Jul 23, 2020 6:20 pm
Forum: Raspberry Pi
Topic: RPi 4 MythTV-light 31 issues
Replies: 18
Views: 234
United States of America

Re: RPi 4 MythTV-light 31 issues

The worst of the problems, is that whenever the Mythtv window is in front, the graphics get shuffled, so they become illegible (it looks like the horizontal sync on an old school tv is out of whack, except that it's static, not moving around). As soon as I move another window in front of it, the gr...
by monkeypet
Mon Jul 13, 2020 7:47 pm
Forum: Raspberry Pi
Topic: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth
Replies: 10
Views: 577
United States of America

Re: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth

I am satisfied for now, since most of the above are nits. I am revising my claim. After using it for awhile i found these problems: 1. Starting up playback, it starts the playback, speed is wrong, need to jump back to correct and/or get the audio/video to sync. 2. Jumping back and forth 30 secs, ca...
by monkeypet
Mon Jul 13, 2020 7:41 pm
Forum: Raspberry Pi
Topic: V31.0-54 audio problems
Replies: 4
Views: 180
United States of America

Re: V31.0-54 audio problems

I was able to get it working use the https://www.mythtv.org/wiki/Raspberry_Pi#Audio creating the .asoundrc file as directed. Using 5.1 passthrough via HDMI to a bose amp.
by monkeypet
Sun May 17, 2020 6:21 pm
Forum: Raspberry Pi
Topic: Raspberry Pi 4 Case + Fan
Replies: 4
Views: 586
United States of America

Raspberry Pi 4 Case + Fan

I noticed that the Raspberry Pi 4 B was running sightly over 80C. Throttle temp is around 85C, but i didn't observe it throttling yet. Anyways, this case i bought from ebay for around $8 included a small fan, aluminum case, and screws also. When i activated the fan the temperature dropped to around ...
by monkeypet
Sat May 16, 2020 6:49 pm
Forum: Raspberry Pi
Topic: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth
Replies: 10
Views: 577
United States of America

Re: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth

Definitely Raspberry Pi 4 is a usable frontend, some issues i have seen after using it for a over a week... 1. When watching the news recording and if they have graphic overlays, you can see the overlays shaking or vibrating, but you need to observe it carefully. 2. Sometimes pixelation and shading ...
by monkeypet
Fri May 08, 2020 3:08 am
Forum: Raspberry Pi
Topic: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth
Replies: 10
Views: 577
United States of America

Re: Raspberry Pi 4 MPEG 2 HD playback not smooth

I fixed it. I disabled booting into the desktop environment and instead directly started mythfrontend. It looks beautiful now. Make sure everything else is working before doing this since losing the desktop makes things a bit harder. Configure to autologin, then create ~/.xsession file as follows #!...
by monkeypet
Fri May 08, 2020 1:01 am
Forum: Raspberry Pi
Topic: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth
Replies: 10
Views: 577
United States of America

Re: Raspberry Pi 4 MPEG 2 HD playback not smooth

So i tried the following and nothing seems to improve the playback compared to prior: 1. Overclocked the Raspberry Pi from 1.7 to 2. 2. Boosted the GPU memory from 256 to 320. 3. Increased 2 to 4 CPU for the profile. 4. Changed the nice to -20 of the frontend, changed the priority to realtime 99. 5....
by monkeypet
Thu May 07, 2020 4:42 pm
Forum: Raspberry Pi
Topic: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth
Replies: 10
Views: 577
United States of America

Re: Raspberry Pi 4 MPEG 2 HD playback not smooth

I've been told that mythfrontend up to v30 was getting hard to maintain, so with v31 the leap was done to newer methods so the code could be maintained. If that is true then I understand it may take a while before v31 on RPi will be as good as v30 which is what I observe on MPEG2 OTA HD recordings....
by monkeypet
Thu May 07, 2020 2:26 pm
Forum: Raspberry Pi
Topic: [solved] Raspberry Pi 4 MPEG 2 HD playback not smooth
Replies: 10
Views: 577
United States of America

[solved] Raspberry Pi 4 MPEG 2 HD playback not smooth

I am noticing the playback of MPEG2 HD 1080 recording using hdhomerun not as smooth. It is definitely watchable and my family probably won't notice it because it is too obvious, but you can definitely see some artifacts in the playback. I have the Raspberry Pi 4, 4GB running Raspian Buster with myht...
by monkeypet
Thu May 07, 2020 4:43 am
Forum: Raspberry Pi
Topic: No 5.1 audio on V31
Replies: 2
Views: 447
United States of America

Re: No 5.1 audio on V31

I couldn't figure this out, but the custom .asoundrc file seem to have fixed it for me. I tried multiple things prior to using the custom .asoundrc, nothing worked. Then I followed this, https://www.mythtv.org/wiki/Raspberry_P ... ck_Profile
by monkeypet
Sun May 03, 2020 4:54 pm
Forum: Raspberry Pi
Topic: Mythtv Installation instructions for RPI 4
Replies: 4
Views: 685
United States of America

Re: Mythtv Installation instructions for RPI 4

jfabernathy wrote:
Mon Dec 16, 2019 7:55 pm
Please let me know if you see any mistakes that need to be fixed.
I'll be following this when i get my Raspberry Pi 4 in about 1 week. I'll let you know what I find. Thanks for sharing this!