Search found 54 matches

by bklein
Mon Dec 14, 2020 12:42 pm
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

@daraden - Thanks. The user job is working now. Running it from the command line as the mythtv user revealed that mythtv did not have access to the folder I specified for the log file (as blm-ubunet has pointed out). I fixed that and the user job is running now. @blm-ubunet - Thanks. I will try thos...
by bklein
Sun Dec 13, 2020 4:22 pm
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Hmmm

I'm on ruby

Code: Select all

ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux-gnu]
but am up to date on all my packages (Ubuntu 18.04).

Using just #!/usr/bin/ruby worked on the command line but still failed as a user job :-(
by bklein
Sun Dec 13, 2020 12:10 pm
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Yes, that warning would be another likely cause of the job not running from MythTV. I tried changing to #!/usr/bin/ruby -W:no-deprecated but that gave me the following error (I tried with lowercase and uppercase W) - Traceback (most recent call last): /usr/bin/ruby: invalid option -: (-h will show v...
by bklein
Sun Dec 13, 2020 11:26 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Thanks for the info and help. Using STARTTIMEUTC gave the right time for the filename, but the job still failed from MythTV. From the mythbackend.log - User Job '/home/ben/Scripts/myth_h264_transcode --starttime 20201205054300 --chanid 80090 --title "The Garden Gurus" --outdir /home/ben/Videos' fail...
by bklein
Sun Dec 13, 2020 9:19 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Thanks. OK, when running /home/ben/Scripts/myth_h264_transcode --starttime 20201205164300 --chanid 80090 --title "The Garden Gurus" --outdir /home/ben/Videos from the command line the job terminates straightaway and the log file shows the following - 2020-12-13 18:17:39.742643 E Couldn't find record...
by bklein
Sun Dec 13, 2020 4:27 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

OK. Thanks. I had a look at the other backend job options as suggested and discovered that this job was not marked to execute on this backend (my only backend), which explains the perpetual queued status. I enabled it and reran the job, but it is failing and I can't figure out why. The logs are not ...
by bklein
Sun Dec 13, 2020 1:51 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Thanks for the input. journalctl -xe gives the following. I've tried the job a few times and these messages seem to coincide with that. I've tried googling the messages but haven't found any useful posts. EDIT: Ignore this code. I realised is has nothing to do with the user job and is related to two...
by bklein
Wed Dec 09, 2020 4:39 pm
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Thanks for all the input. I missed that about crf and preset - thanks for that. At quality=31 my output file was about half the size of the original. Using quality=25 gave me a result closer to the original. I would really like to get this working as a user job. I need to find out why my user job is...
by bklein
Tue Dec 08, 2020 7:55 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

The changes to the script worked for me too, which is great. I have some issues though. Firstly the output file has come down in size dramatically, but is still about twice the size of the input file. Any suggestions (I'm guessing to the ffmpeg settings) to bring it down to about the same size as th...
by bklein
Sun Dec 06, 2020 12:41 pm
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Thanks for this input guys. I am looking forward to trying these suggestions.
by bklein
Sat Dec 05, 2020 9:28 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

I'm getting a bit confused about the different ffmpeg's. I think the important thing is that I (presumably) used the system ffmpeg which is compiled with libx264 (as per the ldd). mythffmpeg Is also compiled with libx264 but I don't understand when mythffmpeg would be invoked as opposed to the syste...
by bklein
Sat Dec 05, 2020 6:47 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Thanks for persisting. I compiled ffmpeg with libx264, following the instructions here https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu . ldd gives the following - $ ldd /usr/bin/ffmpeg | grep 264 libx264.so.152 => /usr/lib/x86_64-linux-gnu/libx264.so.152 (0x00007f288fab0000) I did a 7.5min reco...
by bklein
Sat Dec 05, 2020 12:19 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Thanks for the input again. I read here that you don't need to compile with libx264 if you can install libx264-dev version ≥ 118, which I installed. libx264-dev/bionic,now 2:0.152.2854+gite9a5903-2 amd64 [installed] However, the process is still very slow (around 10fps), creates a much larger file a...
by bklein
Thu Dec 03, 2020 9:24 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Gee wiz. This is getting complicated. I know this is all done by developers with great skills on a voluntary basis, but it is disappointing that there is no solution as elegant as mythtranscode for H264 recordings. Why is this? What is the difficulty presented by H264? Why is there seemingly not muc...
by bklein
Thu Dec 03, 2020 1:32 am
Forum: Troubleshooting
Topic: Transcoding jobs not working all of a sudden
Replies: 43
Views: 985
Australia

Re: Transcoding jobs not working all of a sudden

Thanks. I have run it from the command line with the necessary parameters. That warning still comes up but the transcode seems to run. However, I am having issues with the transcode. It has run for a couple of hours on a 3.4G recording and has produced a file 4.2G in size, but seems to be hanging (c...